MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025310Open CASCADE[OCCT] OCCT:Meshpublic2014-10-01 14:032014-11-11 13:01
Reporteremv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0025310: Keeping temporary data structures in BRepMesh_FaceAttribute leads to out-of-memory exception
DescriptionAfter refactoring of BRepMesh package in context of 0023106 issue, BRepMesh_FaceAttribute is supposed to keep all calculated mesh data for further storing it into the target shape in a single place. However, in case of shapes with huge number of faces, especially based on BSpline surfaces, attributes map consumes a lot of memory and leads to out-of-memory exception.

It is necessary to divide storing of mesh data into a particular face on two steps:
- store surface tesselation directly after processing of a face and clean temporary data structures;
- store shared boundary tesselation when all faces are processed to avoid data races.

Problem can be reproduced using the following test cases (see steps to reproduce):
- test bugs modalg_5 bug25232_9 ("vdisplay result" kills Draw in release mode as well as "vsetdispmode 1" in debug);
- test perf bop buildfaces (shapes are not displayed in 3d viewer).
Steps To Reproduce# debug mode
test perf bop buildfaces
vinit View1
chrono t reset; chrono t start;
vdisplay rp
chrono t stop; chrono t show
# Elapsed time: 0 Hours 10 Minutes 20.0895829143 Seconds
# CPU user time: 614.6283399 seconds
# CPU system time: 2.5740165 seconds
vsetdispmode 1
# it does not changes the view mode for the shape rp


test bugs modalg_5 bug25232_9
vinit View1
vdisplay result
vsetdispmode 1
TagsNo tags attached.
Test case numberbugs modalg_5(010) bug25232_9; perf bop(018) buildfaces
Attached Files

- Relationships
has duplicate 0025320closedoan Open CASCADE Regression on perf bop buildfaces test case on Windows platform 
child of 0023106closedbugmaster Open CASCADE BRepMesh_IncrementalMesh returns wrong status 

-  Notes
(0032818)
azn (developer)
2014-10-08 15:00

Brunch CR23106M is a ready to be reviewed.
(0032836)
azn (developer)
2014-10-08 18:58

Please review new modification of brunch CR23106M.
(0032838)
git (administrator)
2014-10-08 19:20

Branch CR25310 has been created by azn.

SHA-1: 4cbb23d3e166bcb2b83e29ee6bd2e5e9e8f3e697


No new revisions were added by this update.
(0032939)
git (administrator)
2014-10-09 18:37

Branch CR25310 has been updated forcibly by azn.

SHA-1: de5b3a84fdff4e7e18a95b17606247f80fe954fa
(0032947)
git (administrator)
2014-10-09 18:56

Branch CR25310 has been updated forcibly by azn.

SHA-1: 972772b1e9d544d1ace446ab9da3677f84872f53
(0032949)
oan (developer)
2014-10-09 19:00

Reviewed, please test.
(0033042)
mkv (tester)
2014-10-13 21:04

Dear BugMaster,
Branch CR25310 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 972772b1e9d544d1ace446ab9da3677f84872f53

Number of compiler warnings:

occt component :
Linux: 15 (15 on master)
Windows: 0 (0 on master)
MacOS: 199 (199 on master)

products component :
Linux: 11 (11 on master)
Windows: 1 (1 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR25310-master-occt/Debian60-64/bugs/modalg_5/bug25232_9.html [^]
bugs modalg_5(010) bug25232_9: OK

http://occt-tests/CR25310-master-occt/Windows-32-VC10/bugs/modalg_5/bug25232_9.html [^]
bugs modalg_5(010) bug25232_9: FAILED

http://occt-tests/CR25310-master-occt/Windows-32-VC10/perf/bop/buildfaces.html [^]
http://occt-tests/CR25310-master-occt/Debian60-64/perf/bop/buildfaces.html [^]
perf bop(018) buildfaces: OK

Testing on Linux:
occt component :
Total MEMORY difference: 368450708 / 397911416
Total CPU difference: 48266.01000000008 / 47179.31000000023
products component :
Total MEMORY difference: 119289776 / 128595660
Total CPU difference: 17971.799999999967 / 17743.32999999997

Testing on Windows:
occt component :
Total MEMORY difference: 273487600 / 278279728
Total CPU difference: 35626.421875 / 32988.78125
products component :
Total MEMORY difference: 70587272 / 69892128
Total CPU difference: 10709.125 / 10861.0625

There are no differences in images found by testdiff.
(0033043)
mkv (tester)
2014-10-13 21:05
edited on: 2014-10-13 21:06

Dear BugMaster,
Branch CR25310 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Debug mode.

Regressions/Differences:
http://occt-tests/CR25310-master-occt-deb/Debian60-64/summary.html [^]
http://occt-tests/CR25310-master-occt-deb/Windows-32-VC10/summary.html [^]
bugs modalg_5(010) bug24981 - only on Linux platform

Debug messages:
http://occt-tests/CR25310-master-products-deb/Debian60-64/summary.html [^]
http://occt-tests/CR25310-master-products-deb/Windows-32-VC10/summary.html [^]

Testing cases:
http://occt-tests/CR25310-master-occt-deb/Debian60-64/bugs/modalg_5/bug25232_9.html [^]
bugs modalg_5(010) bug25232_9: OK

http://occt-tests/CR25310-master-occt-deb/Windows-32-VC10/bugs/modalg_5/bug25232_9.html [^]
bugs modalg_5(010) bug25232_9: FAILED

http://occt-tests/CR25310-master-occt-deb/Debian60-64/perf/bop/buildfaces.html [^]
http://occt-tests/CR25310-master-occt-deb/Windows-32-VC10/perf/bop/buildfaces.html [^]
perf bop(018) buildfaces: OK

Testing on Linux:
occt component :
Total MEMORY difference: 440476032 / 469603788
Total CPU difference: 163420.8499999999 / 160493.2000000001
products component :
Total MEMORY difference: 138066936 / 145585436
Total CPU difference: 36432.84999999999 / 36147.12000000002

Testing on Windows:
occt component :
Total MEMORY difference: 363717808 / 374276228
Total CPU difference: 93024.59375 / 97005.453125
products component :
Total MEMORY difference: 91943988 / 92932980
Total CPU difference: 25430.234375 / 26448.96875

There are no differences in images found by testdiff.

(0033174)
abv (manager)
2014-10-15 19:54

Please re-check the above mentioned regressions in Debug mode on current master, which already contains fix for 0025310. At least test bugs modalg_5 bug25232_9 seems to be Ok on Windows now.
(0033409)
git (administrator)
2014-10-21 16:40

Branch CR25310 has been deleted by inv.

SHA-1: 972772b1e9d544d1ace446ab9da3677f84872f53

- Related Changesets
occt: master fcf15f5c
Timestamp: 2014-10-08 10:57:22
Author: azn
Committer: bugmaster
Details ] Diff ]
0025310: Regressions in visualization

- Memory management in the BRepMesh_FastDiscret class is changed. Now the unused face attributes is immediately removed.
mod - src/BRepMesh/BRepMesh_FaceAttribute.cxx Diff ] File ]
mod - src/BRepMesh/BRepMesh_FaceAttribute.hxx Diff ] File ]
mod - src/BRepMesh/BRepMesh_FastDiscret.cxx Diff ] File ]
mod - src/BRepMesh/BRepMesh_FastDiscret.hxx Diff ] File ]
mod - src/BRepMesh/BRepMesh_FastDiscretFace.cxx Diff ] File ]
mod - src/BRepMesh/BRepMesh_FastDiscretFace.hxx Diff ] File ]
mod - src/BRepMesh/BRepMesh_IncrementalMesh.cxx Diff ] File ]
mod - src/BRepMesh/BRepMesh_IncrementalMesh.hxx Diff ] File ]
mod - src/MeshTest/MeshTest.cxx Diff ] File ]
mod - src/MeshTest/MeshTest_DrawableMesh.cxx Diff ] File ]
mod - src/XSDRAWSTLVRML/XSDRAWSTLVRML_ToVRML.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-10-01 14:03 emv New Issue
2014-10-01 14:03 emv Assigned To => kgv
2014-10-01 14:05 emv Status new => assigned
2014-10-01 14:13 abv Relationship added child of 0023106
2014-10-01 18:37 abv Assigned To kgv => azn
2014-10-06 13:13 kgv Category OCCT:Visualization => OCCT:Mesh
2014-10-08 15:00 azn Note Added: 0032818
2014-10-08 15:00 azn Assigned To azn => oan
2014-10-08 18:58 azn Note Added: 0032836
2014-10-08 18:58 azn Status assigned => resolved
2014-10-08 19:20 git Note Added: 0032838
2014-10-09 18:37 git Note Added: 0032939
2014-10-09 18:56 git Note Added: 0032947
2014-10-09 19:00 oan Note Added: 0032949
2014-10-09 19:00 oan Assigned To oan => bugmaster
2014-10-09 19:00 oan Status resolved => reviewed
2014-10-09 19:07 mkv Assigned To bugmaster => mkv
2014-10-13 11:47 oan Summary Regressions in visualization => Keeping temporary data structures in BRepMesh_FaceAttribute leads to out-of-memory exception
2014-10-13 11:47 oan Description Updated View Revisions
2014-10-13 11:48 oan Description Updated View Revisions
2014-10-13 11:49 oan Description Updated View Revisions
2014-10-13 11:51 oan Description Updated View Revisions
2014-10-13 12:40 oan Relationship added has duplicate 0025320
2014-10-13 12:41 oan Relationship added related to 0025293
2014-10-13 16:56 oan Relationship added has duplicate 0025364
2014-10-13 17:52 bugmaster Changeset attached => occt master fcf15f5c
2014-10-13 17:52 bugmaster Assigned To mkv => bugmaster
2014-10-13 17:52 bugmaster Status reviewed => verified
2014-10-13 17:52 bugmaster Resolution open => fixed
2014-10-13 21:04 mkv Note Added: 0033042
2014-10-13 21:05 mkv Note Added: 0033043
2014-10-13 21:06 mkv Note Edited: 0033043 View Revisions
2014-10-13 21:07 mkv Test case number => bugs modalg_5(010) bug25232_9; perf bop(018) buildfaces
2014-10-15 19:54 abv Note Added: 0033174
2014-10-21 16:40 git Note Added: 0033409
2014-11-11 12:43 aiv Fixed in Version => 6.8.0
2014-11-11 13:01 aiv Status verified => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker