MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025270Community[OCCT] OCCT:Modeling Algorithmspublic2014-09-25 11:042014-11-12 09:52
ReporterIstvan Csanady 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.1 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0025270: OCCT fails to calculate extrema between extruded surface and line
DescriptionIn many cases the calculation of extrema between a line and an extruded surface fails. See the attached sample.
Steps To ReproduceCalculate the extrema of the attached edge with BRepExtrema_ExtCF.
Additional information
and documentation updates
I think the problem is at Extrema_ExtCS.cxx line 217

Extrema_ExtCC aLocator(C, anAx) does not find any extremas.
TagsNo tags attached.
Test case numberbugs modalg_5 bug25270
Attached Fileszip file icon line_extruded_face_extrema_failure.zip (3,005 bytes) 2014-09-25 11:04

- Relationships

-  Notes
(0032116)
abv (manager)
2014-09-25 11:42

Confirmed; the same problem existed in 6.7.1. To reproduce, first add line "DBRep_DrawableShape" at the top of the attached files. Then:

restore face.brep
restore edge.brep
distmini r edge face
dval r_val

the resulting distance is 2.2, while should be 0
(0034044)
ifv (developer)
2014-11-05 15:13

Bug is not reproducible now because of integration #25407
Please test and close.
(0034045)
ifv (developer)
2014-11-05 15:13

Is not reproducible
(0034049)
bugmaster (administrator)
2014-11-05 15:38

Dear APN,

Please create testing case
(0034102)
git (administrator)
2014-11-06 14:55

Branch CR25270 has been created by apn.

SHA-1: 66f5b2cf26bf8548055f876ae90049618896e9a5


Detailed log of new commits:

Author: apn
Date: Thu Nov 6 14:55:10 2014 +0300

    0025270: OCCT fails to calculate extrema between extruded surface and line
    
    Added test case bugs/modalg_5/bug25270
(0034103)
apn (administrator)
2014-11-06 14:56

Problem is not reproduced on current state of master on Windows and Debian60-64 in Release and Debug modes.
Branch CR25270 was created. It contains test case:
bugs modalg_5 bug25270 - OK
(0034300)
git (administrator)
2014-11-12 09:52

Branch CR25270 has been deleted by inv.

SHA-1: 66f5b2cf26bf8548055f876ae90049618896e9a5

- Related Changesets
occt: master 2fa97a43
Timestamp: 2014-11-06 11:55:10
Author: apn
Committer: bugmaster
Details ] Diff ]
0025270: OCCT fails to calculate extrema between extruded surface and line

Added test case bugs/modalg_5/bug25270
add - tests/bugs/modalg_5/bug25270 Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-09-25 11:04 Istvan Csanady New Issue
2014-09-25 11:04 Istvan Csanady Assigned To => ifv
2014-09-25 11:04 Istvan Csanady File Added: line_extruded_face_extrema_failure.zip
2014-09-25 11:42 abv Note Added: 0032116
2014-09-25 11:42 abv Product Version 6.8.0 => 6.7.1
2014-09-25 11:42 abv Target Version => 7.1.0
2014-09-25 11:42 abv Additional Information Updated View Revisions
2014-11-05 15:11 ifv Relationship added related to 0025407
2014-11-05 15:13 ifv Note Added: 0034044
2014-11-05 15:13 ifv Assigned To ifv => msv
2014-11-05 15:13 ifv Status new => resolved
2014-11-05 15:13 ifv Note Added: 0034045
2014-11-05 15:13 ifv Assigned To msv => bugmaster
2014-11-05 15:13 ifv Status resolved => reviewed
2014-11-05 15:30 abv Status reviewed => feedback
2014-11-05 15:30 abv Target Version 7.1.0 => 6.8.0
2014-11-05 15:38 bugmaster Note Added: 0034049
2014-11-05 15:38 bugmaster Assigned To bugmaster => apn
2014-11-06 11:55 apn Assigned To apn => Istvan Csanady
2014-11-06 11:55 apn Assigned To Istvan Csanady => apn
2014-11-06 14:55 git Note Added: 0034102
2014-11-06 14:56 apn Note Added: 0034103
2014-11-06 14:56 apn Test case number => bugs modalg_5 bug25270
2014-11-06 14:56 apn Assigned To apn => bugmaster
2014-11-06 14:56 apn Status feedback => tested
2014-11-06 16:15 bugmaster Changeset attached => occt master 2fa97a43
2014-11-06 16:15 bugmaster Status tested => verified
2014-11-06 16:15 bugmaster Resolution open => fixed
2014-11-11 12:42 user533 Fixed in Version => 6.8.0
2014-11-11 13:03 user533 Status verified => closed
2014-11-12 09:52 git Note Added: 0034300


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker