MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025269Open CASCADE[OCCT] OCCT:Codingpublic2014-09-25 09:522014-11-11 13:02
Reporteraml 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0025269: Make parallel version of boolean operations avaible from DRAW
DescriptionThere are parallel version of boolean opetations exists, but they
inaccessible in high-level API.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0024639closedmkv Parallelization FillDS part of BO 

-  Notes
(0032108)
git (administrator)
2014-09-25 10:02

Branch CR25269 has been created by aml.

SHA-1: 9af2245530d6d5ef6d368c023e2db6ddc4e67feb


Detailed log of new commits:

Author: aml
Date: Thu Sep 25 09:57:26 2014 +0400

    0025269: Make parallel version of boolean operations avaible from DRAW
    
    new command bsetparallelmode added.
    usage: bsetparallelmode 1/0.
(0032109)
aml (developer)
2014-09-25 10:03

Dear abv,
Please check current state of branch CR25269.
(0032111)
abv (manager)
2014-09-25 10:35

No remarks, please integrate (testing is not needed, perhaps just check compilation)
(0032184)
aml (developer)
2014-09-26 08:59

Results of testing with parallel boolean operations (win32, Release):

testgrid -parallel 1 (up to 4 workers)
No regressions

testgrid (up to 16 workers)
bugs modalg_5 bug23958 (Process killed by CPU limit (4000 sec) )

bug23958 has reproduced in standalone test only in Release mode on my workstation. Usage of Intel Parallel leads to "OK" state of test.
(0032194)
git (administrator)
2014-09-26 10:07

Branch CR25269 has been updated by aml.

SHA-1: 0bcbb3fa1531cae35731d08c1a1d48e6cb3f73e7


Detailed log of new commits:

Author: aml
Date: Fri Sep 26 09:58:48 2014 +0400

    0025269: Make parallel version of boolean operations avaible from DRAW
    
    Documentation for new command "bsetparallelmode" added.

(0032195)
git (administrator)
2014-09-26 10:08

Branch CR25269 has been updated forcibly by aml.

SHA-1: 74f80c87e7f090c5f2ffaed138e17d26292912f6
(0032208)
kgv (developer)
2014-09-26 11:37
edited on: 2014-09-26 11:42

+  if (n != 2)
+  {
+    di << "use  bsetparallelmode 1/0";
+    return 1;
+  }
...
+  theCommands.Add("bsetparallelmode", "use  bsetparallelmode 1/0", __FILE__, bsetparallelmode, 
g);

please notice that bsetparallelmode syntax is inconsistent to similar commands - there is NO way to see current state of this global flag.
Description is somewhat awkward - it relies on assumption that command name is self-descriptive, but it is NOT.
There are too many commands starting from "b" without any description!
Here is mpparallel for example:
mpparallel [toTurnOn] : show / set multi-threading flag for incremental mesh


(0032209)
aml (developer)
2014-09-26 11:40

I. Parallel versions of the following tests are checked by Intel Inspector (in debug):

boolean bcommon_simple A1
boolean bcut_simple A1
boolean bfuse_simple B2
boolean bsection S5

Inspector not detected any problems related to boolean operations.

II. Documentation for new command has been added.
(0032217)
git (administrator)
2014-09-26 12:31

Branch CR25269 has been updated forcibly by aml.

SHA-1: 0a528292f77f0c263722db6eb499370cb59b01e5
(0032218)
aml (developer)
2014-09-26 12:33

Command "bsetparallelmode" has changed due to kgv comments.
(0032244)
git (administrator)
2014-09-26 15:21

Branch CR25269 has been updated forcibly by apv.

SHA-1: f07e778f6b53646858698ce14ffe516112df236f
(0032289)
apv (tester)
2014-09-29 11:47

Dear BugMaster,

Branch CR25269 (and products from GIT master) was compiled on Linux, MacOS and Windows platforms.
SHA-1: f07e778f6b53646858698ce14ffe516112df236f

Number of compiler warnings:
occt component:
   Linux: 15 (15 on master)
   Windows: 0 (0 on master)
   MacOS: 193 (193 on master)
products component :
   Linux: 11 (11 on master)
   Windows: 3 (3 on master)
(0033469)
git (administrator)
2014-10-21 16:44

Branch CR25269 has been deleted by inv.

SHA-1: f07e778f6b53646858698ce14ffe516112df236f

- Related Changesets
occt: master e322db46
Timestamp: 2014-10-02 08:55:08
Author: aml
Committer: bugmaster
Details ] Diff ]
0025269: Make parallel version of boolean operations avaible from DRAW

new command bsetparallelmode added.
usage: bsetparallelmode [1/0].

Documentation for new command "bsetparallelmode" added.
mod - dox/user_guides/draw_test_harness.md Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_Algo.cdl Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_Algo.cxx Diff ] File ]
mod - src/BOPTest/BOPTest_BOPCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-09-25 09:52 aml New Issue
2014-09-25 09:52 aml Assigned To => aml
2014-09-25 09:54 aml Relationship added related to 0024639
2014-09-25 10:02 git Note Added: 0032108
2014-09-25 10:03 aml Note Added: 0032109
2014-09-25 10:03 aml Assigned To aml => abv
2014-09-25 10:03 aml Status new => resolved
2014-09-25 10:35 abv Note Added: 0032111
2014-09-25 10:35 abv Assigned To abv => bugmaster
2014-09-25 10:35 abv Status resolved => reviewed
2014-09-25 14:23 apv Assigned To bugmaster => apv
2014-09-26 08:59 aml Note Added: 0032184
2014-09-26 10:07 git Note Added: 0032194
2014-09-26 10:08 git Note Added: 0032195
2014-09-26 11:37 kgv Note Added: 0032208
2014-09-26 11:38 kgv Note Edited: 0032208 View Revisions
2014-09-26 11:39 kgv Note Edited: 0032208 View Revisions
2014-09-26 11:40 aml Note Added: 0032209
2014-09-26 11:42 kgv Note Edited: 0032208 View Revisions
2014-09-26 12:31 git Note Added: 0032217
2014-09-26 12:33 aml Note Added: 0032218
2014-09-26 15:21 git Note Added: 0032244
2014-09-26 17:48 abv Target Version => 6.8.0
2014-09-29 11:47 apv Note Added: 0032289
2014-09-29 11:47 apv Assigned To apv => bugmaster
2014-09-29 11:47 apv Status reviewed => tested
2014-09-29 11:47 apv Test case number => Not needed
2014-10-03 14:07 bugmaster Changeset attached => occt master e322db46
2014-10-03 14:07 bugmaster Status tested => verified
2014-10-03 14:07 bugmaster Resolution open => fixed
2014-10-21 16:44 git Note Added: 0033469
2014-11-11 12:43 aiv Fixed in Version => 6.8.0
2014-11-11 13:02 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker