MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025264Community[OCCT] OCCT:Meshpublic2014-09-23 14:352016-12-09 16:39
Reportereryar 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2008OS Version32 bit
Product Version[OCCT] 6.7.1 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0025264: Mesh very slow for Revol shape
DescriptionMesh algorithm very slow for a revol shape in occ6.7, while in occ6.2.0 is very fast.
 
PS:
The deflection of the BRepMesh::Mesh only have the effect for sphere; other shapes or surfaces have no effect.
TagsNo tags attached.
Test case numberbugs mesh bug25264
Attached Filespng file icon mesh_revol.PNG (30,656 bytes) 2014-09-23 14:35
? file icon wire.brep (1,475 bytes) 2014-09-23 14:35
? file icon revol.tcl (400 bytes) 2014-09-23 14:36

- Relationships

-  Notes
(0050486)
git (administrator)
2016-02-08 15:52

Branch CR25264 has been created by oan.

SHA-1: 4bbba407a83264ae4b34853c1a88b2876120e119


Detailed log of new commits:

Author: oan
Date: Mon Feb 8 15:51:59 2016 +0300

    0025264: Mesh very slow for Revol shape
    
    Test case added
(0050487)
oan (developer)
2016-02-08 15:56

Dear Mikhail,

on current master meshing of the problematic shape takes about 2 seconds instead of 52 seconds mentioned in the bug. Difference between OCCT version 6.2 is due to changed meshing algorithm.

Test case has been pushed to branch CR25264. Please review.
(0050489)
msv (developer)
2016-02-08 16:10

Reviewed.
(0050503)
abv (manager)
2016-02-08 19:52

Oleg, the problem does exist: I have tried with OCCT 6.0, and it takes 0.2 sec, while on current master it works ~ 13 sec.

Note that it is not correct to rely on time of vdisplay command, as it may use different parameters in different versions.

Use incmesh command instead:

tclean result; chrono s reset; chrono s start; incmesh result 0.1; chrono s show

For me, it takes 0.05 sec (33 K triangles) in OCCT 6.0 and 2.5 sec (31 K triangles) in master.
For tolerance 0.001, it works 2.3 sec in OCCT 6.0, and 112 sec in master.

As we see, slow down is ~ 50 times regardless of deflection (and corresponding number of elements), and I believe that difference of the algorithm should not be blamed without in-depth analysis.
(0050513)
abv (manager)
2016-02-09 11:14

More timings, incmesh with deflection 0.1:

OCCT 6.0.0: 0.05 sec, 33030 triangles
OCCT 6.3.1: 14.4 sec, 32480 triangles
OCCT 6.5.0: 2.25 sec, 32624 triangles
OCCT 6.6.0: 2.37 sec, 31208 triangles
OCCT 6.7.0: 2.21 sec, 31208 triangles
OCCT 6.8.0: 1.9 sec, 31208 triangles
OCCT 6.9.0: 2.02 sec, 31090 triangles
OCCT 6.9.1: 2.01 sec, 31090 triangles
master : 2.02 sec, 31090 triangles
(0058773)
git (administrator)
2016-10-17 12:21

Branch CR25264_1 has been created by oan.

SHA-1: 9c651b4d32e64d4fcfef1e086018781035743c98


Detailed log of new commits:

Author: oan
Date: Mon Oct 17 12:21:25 2016 +0300

    0025264: Mesh very slow for Revol shape
    
    Test case added
(0058774)
oan (developer)
2016-10-17 12:27

Dear Bugmaster,

behaviour of BRepMesh component has been improved for case of thin cylindrical surfaces in context of #27442 issue.

The following timings used in test suites are produced on current master:
CPU user time: 0.0468003 sec for reference case
CPU user time: 0.0468003 sec for problematic case

Test case for current issue has been created and pushed to branch CR25264_1. Please test and close the issue.

Best regards.
(0059119)
git (administrator)
2016-10-25 20:02

Branch CR25264_1 has been updated by apn.

SHA-1: 9bc559e702a0a9e7025881c17b09a8de5b0ca574


Detailed log of new commits:

Author: apn
Date: Tue Oct 25 20:01:42 2016 +0300

    Small corrections of test case

(0059120)
apn (administrator)
2016-10-25 20:09

Test case:
bugs mesh bug25264 - OK
(0059397)
git (administrator)
2016-10-28 21:37

Branch CR25264_1 has been deleted by kgv.

SHA-1: 9bc559e702a0a9e7025881c17b09a8de5b0ca574
(0059598)
git (administrator)
2016-10-28 21:51

Branch CR25264 has been deleted by kgv.

SHA-1: 4bbba407a83264ae4b34853c1a88b2876120e119

- Related Changesets
occt: master f204ec4c
Timestamp: 2016-10-27 14:18:18
Author: oan
Committer: apn
Details ] Diff ]
0025264: Mesh very slow for Revol shape

Test case added
Small corrections of test case
add - tests/bugs/mesh/bug25264 Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-09-23 14:35 eryar New Issue
2014-09-23 14:35 eryar Assigned To => oan
2014-09-23 14:35 eryar File Added: mesh_revol.PNG
2014-09-23 14:35 eryar File Added: wire.brep
2014-09-23 14:36 eryar File Added: revol.tcl
2016-02-08 15:52 git Note Added: 0050486
2016-02-08 15:55 oan Assigned To oan => msv
2016-02-08 15:55 oan Status new => resolved
2016-02-08 15:55 oan Steps to Reproduce Updated View Revisions
2016-02-08 15:55 oan Steps to Reproduce Updated View Revisions
2016-02-08 15:56 oan Note Added: 0050487
2016-02-08 16:10 msv Note Added: 0050489
2016-02-08 16:10 msv Assigned To msv => bugmaster
2016-02-08 16:10 msv Status resolved => reviewed
2016-02-08 17:05 apv Assigned To bugmaster => apv
2016-02-08 19:52 abv Note Added: 0050503
2016-02-08 19:52 abv Assigned To apv => oan
2016-02-08 19:52 abv Status reviewed => assigned
2016-02-08 19:52 abv Target Version => 7.1.0
2016-02-09 11:14 abv Note Added: 0050513
2016-10-17 11:59 oan Relationship added duplicate of 0027442
2016-10-17 12:21 git Note Added: 0058773
2016-10-17 12:27 oan Note Added: 0058774
2016-10-17 12:28 oan Assigned To oan => bugmaster
2016-10-17 12:28 oan Status assigned => feedback
2016-10-25 20:02 git Note Added: 0059119
2016-10-25 20:09 apn Note Added: 0059120
2016-10-25 20:10 apn Test case number => bugs mesh bug25264
2016-10-25 20:10 apn Status feedback => tested
2016-10-28 14:35 apn Changeset attached => occt master f204ec4c
2016-10-28 14:35 apn Assigned To bugmaster => apn
2016-10-28 14:35 apn Status tested => verified
2016-10-28 14:35 apn Resolution open => fixed
2016-10-28 21:37 git Note Added: 0059397
2016-10-28 21:51 git Note Added: 0059598
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker