MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025088Open CASCADE[OCCT] OCCT:Meshpublic2014-07-16 11:372014-11-11 12:53
Reporteroan 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0025088: Revert or change API of BRepMesh_IncrementalMesh to prevent possible errors occurred due to changed order of parameters
DescriptionRevert or change API of BRepMesh_IncrementalMesh to prevent possible errors occurred due to changed order of parameters.
According to note posted by ABV (http://tracker.dev.opencascade.org/view.php?id=25039#c30177 [^])
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0025039closedapn Open CASCADE Improvement of code structure of general and supporting tools implemented in BRepMesh 

-  Notes
(0030218)
git (administrator)
2014-07-17 11:31

Branch CR25088 has been created by oan.

SHA-1: 4a1643e4c75bc47f421acc590708aecd588c4b3d
(0030219)
oan (developer)
2014-07-17 11:49

changes have been pushed to OCCT and Products repositories, branch CR25088.
Please review.
(0030224)
git (administrator)
2014-07-17 13:30

Branch CR25088 has been updated by oan.

SHA-1: 2933ae43172a55782e6c9c8dd156048a9860f6a1
(0030232)
git (administrator)
2014-07-17 15:28

Branch CR25088_1 has been created by oan.

SHA-1: 1f36769d8ce7acf886401aeb39c5984bbbaa9617
(0030233)
oan (developer)
2014-07-17 15:29

Branch CR25088_1 is ready to be reviewed.
(0030234)
abv (manager)
2014-07-17 15:39

No remarks, please test
(0030242)
git (administrator)
2014-07-18 14:23

Branch CR25088_1 has been updated forcibly by mkv.

SHA-1: 2de5be85f54c30813e49c38f9c0bf3426a2f5275
(0030375)
mkv (tester)
2014-07-23 12:33

Dear BugMaster,

Branch CR25088_1 from occt git-repository and branch CR25088_1 from products git-repository was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 2de5be85f54c30813e49c38f9c0bf3426a2f5275
SHA-1: 326d003f3426b1efe89c54ee2fa975ac72f7a7e2

Number of compiler warnings:

occt component :
Linux: 15 (15 on master)
Windows: 0 (0 on master)
MacOS: 196 (196 on master)

products component :
Linux: 11 (11 on master)
Windows: 1 (1 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 350618372 / 351832620
Total CPU difference: 46605.589999999946 / 46199.39000000001

Testing on Windows:
Total MEMORY difference: 239222540 / 239171960
Total CPU difference: 33237.140625 / 35090.21875

There are no differences in images found by testdiff.
(0030445)
git (administrator)
2014-07-28 16:42

Branch CR25088_1 has been deleted by inv.

SHA-1: 2de5be85f54c30813e49c38f9c0bf3426a2f5275
(0030447)
git (administrator)
2014-07-28 16:42

Branch CR25088 has been deleted by inv.

SHA-1: 2933ae43172a55782e6c9c8dd156048a9860f6a1

- Related Changesets
occt: master 14434f3e
Timestamp: 2014-07-17 10:45:16
Author: oan
Committer: bugmaster
Details ] Diff ]
0025088: Revert or change API of BRepMesh_IncrementalMesh to prevent possible errors occurred due to changed order of parameters

Revert old constructor
mod - src/BRepMesh/BRepMesh_IncrementalMesh.cxx Diff ] File ]
mod - src/BRepMesh/BRepMesh_IncrementalMesh.hxx Diff ] File ]
mod - src/DBRep/DBRep_DrawableShape.cxx Diff ] File ]
mod - src/MeshTest/MeshTest.cxx Diff ] File ]
mod - src/QABugs/QABugs_11.cxx Diff ] File ]
mod - src/StdPrs/StdPrs_HLRPolyShape.cxx Diff ] File ]
mod - src/StdSelect/StdSelect_BRepSelectionTool.cxx Diff ] File ]
mod - src/StlTransfer/StlTransfer.cxx Diff ] File ]
mod - src/VrmlData/VrmlData_ShapeConvert.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-07-16 11:37 oan New Issue
2014-07-16 11:37 oan Assigned To => oan
2014-07-16 11:37 oan Description Updated View Revisions
2014-07-16 11:37 oan Relationship added child of 0025039
2014-07-16 11:38 oan Status new => assigned
2014-07-16 14:07 oan Relationship added has duplicate 0025089
2014-07-16 14:14 kgv Severity minor => integration request
2014-07-16 14:14 kgv Target Version => 6.8.0
2014-07-17 11:31 git Note Added: 0030218
2014-07-17 11:49 oan Note Added: 0030219
2014-07-17 11:49 oan Assigned To oan => kgv
2014-07-17 11:49 oan Status assigned => resolved
2014-07-17 11:52 oan Assigned To kgv => abv
2014-07-17 13:30 git Note Added: 0030224
2014-07-17 15:28 git Note Added: 0030232
2014-07-17 15:29 oan Note Added: 0030233
2014-07-17 15:39 abv Note Added: 0030234
2014-07-17 15:39 abv Assigned To abv => bugmaster
2014-07-17 15:39 abv Status resolved => reviewed
2014-07-18 14:23 git Note Added: 0030242
2014-07-18 14:31 mkv Assigned To bugmaster => mkv
2014-07-23 12:33 mkv Note Added: 0030375
2014-07-23 12:34 mkv Test case number => Not needed
2014-07-23 12:34 mkv Assigned To mkv => bugmaster
2014-07-23 12:34 mkv Status reviewed => tested
2014-07-25 14:45 bugmaster Changeset attached => occt master 14434f3e
2014-07-25 14:45 bugmaster Status tested => verified
2014-07-25 14:45 bugmaster Resolution open => fixed
2014-07-28 16:42 git Note Added: 0030445
2014-07-28 16:42 git Note Added: 0030447
2014-11-11 12:46 aiv Fixed in Version => 6.8.0
2014-11-11 12:53 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker