MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025042Community[OCCT] OCCT:Meshpublic2014-07-01 11:262018-11-11 12:00
ReporterVico Liang 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusverifiedResolutionfixed 
PlatformWin7OSWindowsOS VersionWin7
Product Version[OCCT] 6.7.1 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0025042: Cone Meshing: Missing two connecting edges.
DescriptionBRepMesh_IncrementalMesh will generated invalid mesh. The result is shown in the attached image file MeshingBugOfCone.png.
Steps To Reproduce1. Create a cone solid.
BRepPrimAPI_MakeCone aMakeCone(200, 0, 500);

2. Clean Mesh.
BRepTools::Clean(aMakeCone.Shape());

3. Generate incremental mesh:
BRepMesh_IncrementalMesh aMeshAlgo(aMakeCone.Shape(), 0.2, Standard_True, 0.2, Standard_True);

4. Display mesh with MeshVS.
TagsNo tags attached.
Test case numberbugs/mesh/bug25042
Attached Filespng file icon MeshingBugOfCone.png (51,649 bytes) 2014-07-01 11:26
png file icon OCC671.png (7,556 bytes) 2014-10-16 14:50
png file icon ConeMeshBug671.png (7,565 bytes) 2014-10-17 18:01
png file icon zoom_degenerative.png (11,862 bytes) 2014-11-05 15:42
png file icon mesh_parametric_1.png (46,069 bytes) 2014-11-05 15:43

- Relationships
has duplicate 0027798feedbackVico Liang Community Bad or degenerated triangles should be avoided (e.g for Cone meshing) 

-  Notes
(0033212)
oan (developer)
2014-10-16 14:50
edited on: 2014-10-16 14:51

Dear Vico Liang,

I can not reproduce reported problem neither on OCCT 6.7.1 nor on current master using Draw (see attached screenshot OCC671.png).

Please provide resulting shape containing broken mesh as well as description of the way how you display it.

(0033274)
Vico Liang (developer)
2014-10-17 18:07

Dear OAN,

Please have a try with following case, the bug is still there.

BRepPrimAPI_MakeCone aMakeCone(150, 0, 500);
BRepMesh_IncrementalMesh aMeshAlgo(aMakeCone.Shape(), 0.2, Standard_True, 0.2, Standard_True);

See picture ConeMeshBug671.png.
(0033917)
Vico Liang (developer)
2014-10-31 03:36

Dear OAN,

I don't have permission to assign this to the developer, please help me do it.
(0034020)
oan (developer)
2014-11-05 10:52

Hi Vico Liang,

to whom you expect to assign this issue?
(0034040)
Vico Liang (developer)
2014-11-05 14:23

Hi OAN,

Please have a look at the bug again, it can be reproduced with new data input in my previous feedback.
(0034051)
oan (developer)
2014-11-05 15:42

Dear Vico Liang,

Yes, I see the point - I have just tried to reproduce the bug using current master branch. In fact, mesh is consistent, tricheck command says nothing that means mesh is connected and does not contain lacks. Looking more precisely you can see that reported problem represents case with degenerative triangle (see the attached screenshot zoom_degenerative.png).

Such thing is possible due to transformations introduced during passing from parametric space to 3D (screenshot mesh_parametric_1.png describes this process).

Nevertheless, such result is not quite fine for cone and it will be fixed in order of priority. Be sure we are tracking this issue and it will not be lost.

You also welcome to make your contribution to OCCT and participate in the development of the fix for this bug. We will be glad to see you as a community developer.

With best regards,
Oleg.
(0034173)
Vico Liang (developer)
2014-11-08 06:57

Dear Oleg,

I understand the problem and there is actually a degenerated triangle. So the generated triangulation is consistent. To keep this issue for further bug fix, you might be the best candidate for this issue.

Thank you,
Vico
(0080854)
oan (developer)
2018-11-07 17:01

Should be fixed in context of #28379.
Could you please check and create test case.
(0080910)
git (administrator)
2018-11-08 09:59

Branch CR25042 has been created by nbv.

SHA-1: 64c5800618793374cee22d416f9a9f61c328a165


Detailed log of new commits:

Author: nbv
Date: Thu Nov 8 09:57:17 2018 +0300

    0025042: Cone Meshing: Missing two connecting edges.
    
    Adding test case for the issue.
    The problem has been fixed by the patch #28379.
(0080924)
nbv (developer)
2018-11-08 11:18

Dear Mikhail,

Please review the branch CR25042.

Test results are here:

Windows: http://jenkins-test-12.nnov.opencascade.com/view/CR25042-master_NBV/view/TESTING/job/CR25042-master_NBV-OCCT-Windows-64-VC14-opt-test-restart/HTML_20Report/ [^]

Linux: http://jenkins-test-12.nnov.opencascade.com/view/CR25042-master_NBV/view/TESTING/job/CR25042-master_NBV-OCCT-Debian80-64-opt-test-restart/HTML_20Report/ [^]
(0080971)
msv (developer)
2018-11-08 16:35

Reviewed.
(0080976)
bugmaster (administrator)
2018-11-08 17:26

Adding test case
(0080996)
git (administrator)
2018-11-09 13:38

Branch CR25042 has been updated forcibly by oan.

SHA-1: feec0b893e877e314f68a6c03fb90a78649df359
(0081020)
git (administrator)
2018-11-11 12:00

Branch CR25042 has been deleted by inv.

SHA-1: feec0b893e877e314f68a6c03fb90a78649df359

- Related Changesets
occt: master e2f8fe44
Timestamp: 2018-11-08 06:57:17
Author: nbv
Committer: bugmaster
Details ] Diff ]
0025042: Cone Meshing: Missing two connecting edges.

Adding test case for the issue.
The problem has been fixed after the patch #28379.
add - tests/bugs/mesh/bug25042 Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-07-01 11:26 Vico Liang New Issue
2014-07-01 11:26 Vico Liang Assigned To => oan
2014-07-01 11:26 Vico Liang File Added: MeshingBugOfCone.png
2014-09-12 12:32 abv Target Version => 6.8.0
2014-10-16 14:50 oan Note Added: 0033212
2014-10-16 14:50 oan Assigned To oan => Vico Liang
2014-10-16 14:50 oan Status new => feedback
2014-10-16 14:50 oan File Added: OCC671.png
2014-10-16 14:51 oan Note Edited: 0033212 View Revisions
2014-10-17 18:01 Vico Liang File Added: ConeMeshBug671.png
2014-10-17 18:07 Vico Liang Note Added: 0033274
2014-10-31 03:36 Vico Liang Note Added: 0033917
2014-10-31 09:52 abv Assigned To Vico Liang => oan
2014-10-31 09:52 abv Status feedback => assigned
2014-10-31 09:53 abv Target Version 6.8.0 => 7.1.0
2014-11-05 10:52 oan Note Added: 0034020
2014-11-05 11:39 oan Status assigned => feedback
2014-11-05 11:40 oan Assigned To oan => Vico Liang
2014-11-05 14:23 Vico Liang Note Added: 0034040
2014-11-05 14:23 Vico Liang Assigned To Vico Liang =>
2014-11-05 14:24 Vico Liang Assigned To => oan
2014-11-05 15:42 oan Note Added: 0034051
2014-11-05 15:42 oan File Added: zoom_degenerative.png
2014-11-05 15:43 oan File Added: mesh_parametric_1.png
2014-11-05 15:44 oan Assigned To oan => Vico Liang
2014-11-08 06:49 Vico Liang Assigned To Vico Liang => oan
2014-11-08 06:57 Vico Liang Note Added: 0034173
2014-11-25 20:50 oan Status feedback => assigned
2016-08-22 11:07 oan Relationship added has duplicate 0027798
2016-11-03 17:38 abv Target Version 7.1.0 => 7.2.0
2017-07-20 12:43 oan Target Version 7.2.0 => 7.3.0
2018-02-25 21:09 abv Target Version 7.3.0 => 7.4.0*
2018-11-07 16:33 oan Relationship added related to 0028379
2018-11-07 17:01 oan Note Added: 0080854
2018-11-07 17:01 oan Assigned To oan => nbv
2018-11-07 17:01 oan Status assigned => feedback
2018-11-08 09:59 git Note Added: 0080910
2018-11-08 11:18 nbv Note Added: 0080924
2018-11-08 11:18 nbv Assigned To nbv => msv
2018-11-08 11:18 nbv Status feedback => resolved
2018-11-08 16:35 msv Note Added: 0080971
2018-11-08 16:35 msv Assigned To msv => bugmaster
2018-11-08 16:35 msv Status resolved => reviewed
2018-11-08 17:26 bugmaster Note Added: 0080976
2018-11-08 17:26 bugmaster Status reviewed => tested
2018-11-08 17:27 bugmaster Test case number => bugs/mesh/bug25042
2018-11-09 13:38 git Note Added: 0080996
2018-11-11 11:52 bugmaster Changeset attached => occt master e2f8fe44
2018-11-11 11:52 bugmaster Status tested => verified
2018-11-11 11:52 bugmaster Resolution open => fixed
2018-11-11 12:00 git Note Added: 0081020


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker