MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024941Community[OCCT] OCCT:Codingpublic2014-05-21 09:122014-11-11 12:52
Reporterlaurie123 
Assigned Toapn 
PrioritynormalSeveritytrivial 
StatusclosedResolutionfixed 
PlatformMacOSOSOS VersionX
Product Version[OCCT] 6.7.1 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0024941: Need whitespace between adjacent string literals for CLang in c++11 mode
DescriptionThe files Interface_Version.hxx and STEPControl_Controller.cxx use the macro OCC_VERSION_STRING butting up against a string literal. CLang in c++11 mode vehemently rejects this.
Steps To Reproducecompile with Xcode 5.1.1 setting c++11 mode true. (on cmd line, clang -std=c++11 -stdlib=libc++)
Additional information
and documentation updates
This (trivial) problem has been present since at least OCC6.5.4, and is the only change I *must* make to the source tree to get it to compile in c++11 mode. I am not using -Werror -Wall -Weverything, though.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0029423)
abv (manager)
2014-05-21 09:44

Fix pushed to branch CR24941, please review
(0029447)
kgv (developer)
2014-05-21 17:06

Please test the patch.
(0029448)
abv (manager)
2014-05-21 17:17

Note that similar fix is pushed to products repository, in the same-name branch CR24941
(0029481)
laurie123 (reporter)
2014-05-23 10:12

(pls can you fix the typo in the summary: predecessor→preprocessor; I don't see a way to do it myself)
(0029482)
abv (manager)
2014-05-23 10:56

I have changed description to refer to "adjacent string literals"; their concatenation seems to be done by C++ compiler itself, not by preprocessor
(0029483)
laurie123 (reporter)
2014-05-23 10:59

thanks and yes you are right on that :)
(0029494)
apn (administrator)
2014-05-23 14:24

Branch will be tested with CR24897.

- Related Changesets
occt: master cae42e78
Timestamp: 2014-05-21 05:43:12
Author: abv
Committer: apn
Details ] Diff ]
0024941: Need whitespace between predecessor tokens for CLang in c++11 mode

Whitespace added between macro OCC_VERSION_STRING and string literals when concatenation of string literals is used.
mod - src/Interface/Interface_Version.hxx Diff ] File ]
mod - src/STEPControl/STEPControl_Controller.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-05-21 09:12 laurie123 New Issue
2014-05-21 09:12 laurie123 Assigned To => kgv
2014-05-21 09:44 abv Note Added: 0029423
2014-05-21 09:44 abv Assigned To kgv => laurie123
2014-05-21 09:44 abv Status new => resolved
2014-05-21 17:06 kgv Note Added: 0029447
2014-05-21 17:06 kgv Assigned To laurie123 => bugmaster
2014-05-21 17:06 kgv Status resolved => reviewed
2014-05-21 17:07 kgv Target Version => 6.8.0
2014-05-21 17:17 abv Note Added: 0029448
2014-05-22 11:01 bugmaster Assigned To bugmaster => apn
2014-05-23 10:12 laurie123 Note Added: 0029481
2014-05-23 10:56 abv Note Added: 0029482
2014-05-23 10:56 abv Summary Need whitespace between predecessor tokens for CLang in c++11 mode => Need whitespace between adjacent string literals for CLang in c++11 mode
2014-05-23 10:59 laurie123 Note Added: 0029483
2014-05-23 14:24 apn Note Added: 0029494
2014-05-26 17:58 apn Test case number => Not needed
2014-05-26 17:58 apn Assigned To apn => bugmaster
2014-05-26 17:58 apn Status reviewed => tested
2014-05-30 12:59 apn Changeset attached => occt master cae42e78
2014-05-30 12:59 apn Assigned To bugmaster => apn
2014-05-30 12:59 apn Status tested => verified
2014-05-30 12:59 apn Resolution open => fixed
2014-11-11 12:46 user533 Fixed in Version => 6.8.0
2014-11-11 12:52 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker