View Issue Details

IDProjectCategoryView StatusLast Update
0024929Open CASCADEOCCT:Visualizationpublic2017-05-11 12:25
Reporteraba Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionduplicate 
Product Version6.7.1 
Target Version7.2.0 
Summary0024929: Edge and vertex in compound are not highlighed in shading mode if compound is transparent
DescriptionIf compound contains vertex or edge, and compound transparency is set to not null value, then edge and vertex are not highlighted on compound highlighting.
Steps To Reproduce
pload MODELING VISUALIZATION
box b 2 0 0 1 2 3
explode b E
ttranslate b_1 0 -1 0
psphere s 1
vertex v -2 0 0
compound b b_1 s v c
vclear
vinit View1
vdisplay -dispMode 1 c
vfit
vsettransparency c 0.5
vmoveto 350 250
# OK
vselect 350 250
# KO - point and edge are NOT highlighted


Bug can be reproduced by following code:

    BRep_Builder aBuilder;
    TopoDS_Compound aCompound;
    builder.MakeCompound (aCompound);

    TopoDS_Vertex aVertex = BRepBuilderAPI_MakeVertex(gp_Pnt(-20,10,-30));
    aBuilder.Add (aCompound, aVertex);
    
    gp_Lin aLine (gp_Ax1(gp_Pnt(10,10,10),gp_Dir(1,0,0)));
    TopoDS_Edge anEdge = BRepBuilderAPI_MakeEdge (aLine,-20,10);
    aBuilder.Add (aCompound, anEdge);

    gp_Sphere aSphere (gp_Ax3(gp_Pnt(-80,0,0),gp_Dir(1,0,0)),150);
    TopoDS_Face aFace = BRepBuilderAPI_MakeFace (aSphere,0.1,0.7,0.2,0.9);
    aBuilder.Add (aCompound, aFace);

    TopoDS_Shape aBox = BRepPrimAPI_MakeBox(gp_Pnt(-60,0,0),30,60,40);
    aBuilder.Add (aCompound, aBox);

    Handle(AIS_Shape) aCompShape = new AIS_Shape (aCompound);
    myAISContext->SetDisplayMode (aCompShape, 1);
    myAISContext->Display (aCompShape, Standard_False);
    myAISContext->SetTransparency(aCompShape, 0.5);
    // Try to highlight a compound
TagsNo tags attached.
Test case number

Attached Files

  • AfterTransparency.png (10,164 bytes)
  • BeforeTransparency.png (12,177 bytes)

Relationships

duplicate of 0027527 closedbugmaster Community Visualization - can't highlight polyline presentation of Wire after setting transparency 

Activities

aba

2014-05-15 18:27

developer  

AfterTransparency.png (10,164 bytes)

aba

2014-05-15 18:28

developer  

BeforeTransparency.png (12,177 bytes)

kgv

2017-05-10 12:03

developer   ~0065799

Dear bugmaster,

please close the bug as duplicate of 0027527.

Issue History

Date Modified Username Field Change
2014-05-15 18:27 aba New Issue
2014-05-15 18:27 aba Assigned To => san
2014-05-15 18:27 aba File Added: AfterTransparency.png
2014-05-15 18:28 aba File Added: BeforeTransparency.png
2014-09-12 14:19 abv Target Version => 7.1.0
2016-06-16 20:55 kgv Relationship added has duplicate 0027527
2016-10-25 09:37 kgv Target Version 7.1.0 => 7.2.0
2017-05-10 12:02 kgv Steps to Reproduce Updated
2017-05-10 12:03 kgv Relationship replaced duplicate of 0027527
2017-05-10 12:03 kgv Note Added: 0065799
2017-05-10 12:03 kgv Assigned To san => bugmaster
2017-05-10 12:03 kgv Status new => feedback
2017-05-11 12:25 bugmaster Status feedback => closed
2017-05-11 12:25 bugmaster Resolution open => duplicate