MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024919Community[OCCT] OCCT:Modeling Datapublic2014-05-14 14:182014-11-11 12:52
Reporterdrazmyslovich 
Assigned Toapn 
PrioritynormalSeveritycrash 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version64 bit
Product Version[OCCT] 6.6.0 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0024919: ShapeFix can crash time-to-time due to inproper interator handling inside of Approx_SameParameter::Build function
DescriptionLines 461-464 of Approx_SameParameter::Build function:
while(Param_de_decoupeC1(inter) <= fcons + deltamin) inter++;
while(Param_de_decoupeC1(NbInt) >= lcons - deltamin) NbInt--;

while(inter <= NbInt || ii < NCONTROL) {
Variable inter isn't checked to be inside of Param_de_decoupeC1 range, what can result in access violation exception.
Steps To ReproduceI can't provide the model, which contains the case, when ShapeFix crashes due to this error.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0029319)
drazmyslovich (developer)
2014-05-14 14:35

Please, review the patch
(0029326)
abv (manager)
2014-05-14 15:35

@drazmyslovich: can you extract single edge or face on which the problem appears, instead of sending the whole model (which is confidential as far as I understand)? I deem single edge would not be confidential but still can allow creating a test case, and perhaps we can do more in-depth analysis of the problem.
(0029474)
apn (administrator)
2014-05-22 16:52

Tested with 24921
(0029475)
drazmyslovich (developer)
2014-05-22 17:11

Unfortunately, I was unable to find the test case, where I've met this error. Sorry.

- Related Changesets
occt: master 3f5bebe8
Timestamp: 2014-05-14 10:28:15
Author: razmyslovich
Committer: apn
Details ] Diff ]
0024919: ShapeFix can crash time-to-time due to inproper interator handling inside of Approx_SameParameter::Build function

Check inter variable to be inside of the desired range
mod - src/Approx/Approx_SameParameter.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-05-14 14:18 drazmyslovich New Issue
2014-05-14 14:18 drazmyslovich Assigned To => drazmyslovich
2014-05-14 14:35 drazmyslovich Note Added: 0029319
2014-05-14 14:35 drazmyslovich Status new => resolved
2014-05-14 15:35 abv Note Added: 0029326
2014-05-14 15:35 abv Assigned To drazmyslovich => ifv
2014-05-14 15:35 abv Target Version Unscheduled => 6.8.0
2014-05-22 16:52 apn Note Added: 0029474
2014-05-22 16:54 apn Test case number => Not needed
2014-05-22 16:54 apn Assigned To ifv => bugmaster
2014-05-22 16:54 apn Status resolved => reviewed
2014-05-22 16:54 apn Status reviewed => tested
2014-05-22 17:11 drazmyslovich Note Added: 0029475
2014-05-23 14:25 apn Changeset attached => occt master 3f5bebe8
2014-05-23 14:25 apn Assigned To bugmaster => apn
2014-05-23 14:25 apn Status tested => verified
2014-05-23 14:25 apn Resolution open => fixed
2014-06-17 12:47 user533 Project Open CASCADE => Community
2014-11-11 12:46 user533 Fixed in Version => 6.8.0
2014-11-11 12:52 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker