MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024906Community[OCCT] OCCT:Modeling Datapublic2014-05-07 17:512014-05-22 09:51
Reportershoogen 
Assigned Toshoogen 
PrioritynormalSeverityjust a question 
StatusclosedResolutionduplicate 
PlatformLinux 64-bitOSDebianOS Version7.4
Product Version 
Target VersionFixed in Version 
Summary0024906: Are commands in DRAWEXE for using MakePipeShellApi?
DescriptionI'd like to reproduce a problem in the MakePipeShellApi. Therefore i would like to ask if I have overseen existing commands in DRAWEXE that might be helpful to test the MakePipeShellApi.
Additional information
and documentation updates
(gdb) bt
#0 TopoDS_ListIteratorOfListOfShape::Initialize (this=0x7fffc92b8178, L=...)
    at TCollection/TCollection_ListIterator.gxx:48
0000001 0x00007fc4d1c5c88c in TopoDS_Iterator::Initialize (this=0x7fffc92b8160,
    S=..., cumOri=<optimized out>, cumLoc=<optimized out>)
    at TopoDS/TopoDS_Iterator.cxx:39
0000002 0x00007fc4d2747c2c in BRepLib_MakeWire::Add (this=0x7fffc92b8920, E=...)
    at BRepLib/BRepLib_MakeWire.cxx:167
#3 0x00007fc4d37bb955 in BRepFill_CompatibleWires::SameNumberByPolarMethod (
    this=this@entry=0x7fffc92b9240, WithRotation=WithRotation@entry=false)
    at BRepFill/BRepFill_CompatibleWires.cxx:1122
#4 0x00007fc4d37be3c9 in BRepFill_CompatibleWires::Perform (this=
    0x7fffc92b9240, WithRotation=false)
    at BRepFill/BRepFill_CompatibleWires.cxx:779
#5 0x00007fc4d3817006 in BRepFill_PipeShell::Prepare (this=this@entry=
    0x73ea430) at BRepFill/BRepFill_PipeShell.cxx:1071
#6 0x00007fc4d381af4b in BRepFill_PipeShell::Build (this=0x73ea430)
    at BRepFill/BRepFill_PipeShell.cxx:687
0000007 0x00007fc4d59dc7ba in BRepOffsetAPI_MakePipeShell::Build (this=
    0x7fffc92b9710)
    at BRepOffsetAPI/BRepOffsetAPI_MakePipeShell.cxx:240
0000008 0x00007fc4d68e0c55 in Part::Sweep::execute (this=0x3a06f20)
    at /free-cad/src/Mod/Part/App/PartFeatures.cpp:411
TagsNo tags attached.
Test case number
Attached Files

- Relationships
duplicate of 0024909newifv SIGSEGV in buildsweep 

-  Notes
(0029242)
shoogen (reporter)
2014-05-07 20:45

i can reproduce the problem in version 26fd0d9
Program received signal SIGSEGV, Segmentation fault.
0x00007fff8d8d9167 in BRepFill_SectionLaw::Law(int) const ()
   from occt/lib/libTKBool.so
#0 0x00007fff8d8d9167 in BRepFill_SectionLaw::Law(int) const ()
   occt/lib/libTKBool.so
0000001 0x00007fff8d8d6d81 in BRepFill_PipeShell::Build() ()
   occt/lib/libTKBool.so
0000002 0x00007fff8ba769ca in BRepOffsetAPI_MakePipeShell::Build() ()
   occt/lib/libTKOffset.so
#3 0x00007fff90280a22 in Part::Sweep::execute (this=0x3c88d80)
    free-cad/src/Mod/Part/App/PartFeatures.cpp:411
#4 0x00007ffff6c0ec0b in App::DocumentObject::recompute (this=0x3c88d80)
(0029244)
abv (manager)
2014-05-08 09:03

In order to build sweeps in DRAW, use commands mksweep, setsweep, addsweep, buildsweep; for example, see samples/tcl/drill.tcl
(0029452)
abv (manager)
2014-05-22 06:49

The actual problem is reported in 0024909
(0029456)
bugmaster (administrator)
2014-05-22 09:51

Duplicate of 0024909

- Issue History
Date Modified Username Field Change
2014-05-07 17:51 shoogen New Issue
2014-05-07 17:51 shoogen Assigned To => ifv
2014-05-07 20:45 shoogen Note Added: 0029242
2014-05-08 09:03 abv Note Added: 0029244
2014-05-08 09:03 abv Assigned To ifv => shoogen
2014-05-08 09:03 abv Status new => feedback
2014-05-08 10:52 shoogen Note Added: 0029247
2014-05-08 10:54 shoogen Note Edited: 0029247 View Revisions
2014-05-08 10:57 shoogen Note Deleted: 0029247
2014-05-12 17:01 shoogen Note Added: 0029283
2014-05-15 23:43 shoogen Note Deleted: 0029283
2014-05-15 23:43 shoogen Status feedback => resolved
2014-05-22 06:49 abv Note Added: 0029452
2014-05-22 06:49 abv Status resolved => closed
2014-05-22 06:49 abv Resolution open => duplicate
2014-05-22 06:49 abv Relationship added duplicate of 0024909
2014-05-22 09:50 bugmaster Status closed => assigned
2014-05-22 09:51 bugmaster Note Added: 0029456
2014-05-22 09:51 bugmaster Status assigned => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker