MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024881Open CASCADE[OCCT] OCCT:Shape Healingpublic2014-04-29 17:172015-05-14 15:32
Reporterszy 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.1 
Target Version[OCCT] 6.9.0Fixed in Version[OCCT] 6.9.0 
Summary0024881: Wrong status returned by ShapeFix_Wire::FixGaps3d () operation
DescriptionAttempt to apply ShapeFix_Wire::FixGaps3d () to a valid shape returns wrong status
FAIL2 (ShapeAnalysis_WireOrder failed).
As input shape can be used any valid shape, for example ordinary Box.
Steps To ReproduceTo reproduce the specified problem the attached script Test.bat can be used.
Before using the script it is necessary to open the Test.bat file and modify
environment variable PRODROOT (it should point to OCCT root directory.

cmd> Test.bat box.brep

//=================================================
Before the fix: "Fix_FillGaps_3dSomeGapsFail, nb failed = 6"
After the fix: "Fix_FillGaps_NothingToDo"
TagsNo tags attached.
Test case numberbugs heal(017) bug24881
Attached Files? file icon Test.bat (7,193 bytes) 2014-04-29 17:17

- Relationships

-  Notes
(0032214)
abv (manager)
2014-09-26 12:05

Is this issue still relevant??
(0037271)
git (administrator)
2015-02-10 11:55

Branch CR24881 has been created by akz.

SHA-1: d2d98f03cf5c77fa4d542306c18f09f7227235c6


Detailed log of new commits:

Author: akz
Date: Tue Feb 10 11:47:42 2015 +0300

    0024881: Wrong status returned by ShapeFix_Wire::FixGaps3d () operation
    
    The reason of FAIL status of FixGaps3d is that the trying to convert
    curves to BSplines on valid edges (both adjacent points saticfy a
    precision) leads to skipping of the convertation and gives wrong status.
    
    Check of the gap on adjacent points before try ro convert curves was
    added.
(0037273)
akz (developer)
2015-02-10 11:56

Branch CR24881 is ready to review.
(0037281)
gka (developer)
2015-02-10 12:52

Branch CR24881 is ready to be tested
(0037409)
git (administrator)
2015-02-12 11:17

Branch CR24881 has been updated by apv.

SHA-1: 2ede141f776248f8e0c9879b73ddb8c650f60b05


Detailed log of new commits:

Author: apv
Date: Thu Feb 12 11:17:30 2015 +0300

    Test-case for issue 0024881

(0037411)
apv (tester)
2015-02-12 11:21

Dear BugMaster,

Branch CR24881 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: d2d98f03cf5c77fa4d542306c18f09f7227235c6

Number of compiler warnings:
occt component:
   Linux: 18 (18 on master)
   Windows: 0 (0 on master)
products component:
   Linux: 11 (11 on master)
   Windows: 1 (1 on master)

Regressions/Differences:
Not detected

Testing cases:
bugs heal(017) bug24881 - OK
http://occt-tests/CR24881-master-occt/Debian60-64/bugs/heal/bug24881.html [^]
http://occt-tests/CR24881-master-occt/Windows-32-VC10/bugs/heal/bug24881.html [^]

Testing on Linux:
Total MEMORY difference: 86193499 / 86229117
Total CPU difference: 48746.729999999894 / 47876.709999999846

Testing on Windows:
Total MEMORY difference: 40648511 / 40658608
Total CPU difference: 38009.140625 / 32754.1875
(0038491)
git (administrator)
2015-03-18 13:32

Branch CR24881 has been deleted by inv.

SHA-1: 2ede141f776248f8e0c9879b73ddb8c650f60b05

- Related Changesets
occt: master 2bfe59b6
Timestamp: 2015-02-12 09:08:05
Author: akz
Committer: bugmaster
Details ] Diff ]
0024881: Wrong status returned by ShapeFix_Wire::FixGaps3d () operation

The reason of FAIL status of FixGaps3d is that the trying to convert
curves to BSplines on valid edges (both adjacent points saticfy a
precision) leads to skipping of the convertation and gives wrong status.

Check of the gap on adjacent points before try ro convert curves was added.

Test-case for issue 0024881
mod - src/QABugs/QABugs_19.cxx Diff ] File ]
mod - src/ShapeFix/ShapeFix_Wire_1.cxx Diff ] File ]
add - tests/bugs/heal/bug24881 Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-04-29 17:17 szy New Issue
2014-04-29 17:17 szy Assigned To => gka
2014-04-29 17:17 szy File Added: Test.bat
2014-09-26 12:05 abv Note Added: 0032214
2014-09-26 12:05 abv Target Version 6.8.0 => 7.1.0
2015-01-22 11:00 gka Assigned To gka => akz
2015-01-22 11:00 gka Status new => assigned
2015-02-10 11:55 git Note Added: 0037271
2015-02-10 11:56 akz Note Added: 0037273
2015-02-10 11:56 akz Assigned To akz => gka
2015-02-10 11:56 akz Status assigned => resolved
2015-02-10 11:56 akz Steps to Reproduce Updated View Revisions
2015-02-10 12:52 gka Note Added: 0037281
2015-02-10 12:52 gka Assigned To gka => bugmaster
2015-02-10 12:52 gka Status resolved => reviewed
2015-02-10 13:00 mkv Assigned To bugmaster => apv
2015-02-12 11:16 apv Test case number => bugs heal(017) bug24881
2015-02-12 11:17 git Note Added: 0037409
2015-02-12 11:21 apv Note Added: 0037411
2015-02-12 11:21 apv Assigned To apv => bugmaster
2015-02-12 11:21 apv Status reviewed => tested
2015-02-13 17:55 bugmaster Changeset attached => occt master 2bfe59b6
2015-02-13 17:55 bugmaster Status tested => verified
2015-02-13 17:55 bugmaster Resolution open => fixed
2015-03-10 12:59 bugmaster Target Version 7.1.0 => 6.9.0
2015-03-18 13:32 git Note Added: 0038491
2015-05-14 15:29 aiv Status verified => closed
2015-05-14 15:32 aiv Fixed in Version => 6.9.0


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker