MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024761Open CASCADE[OCCT] OCCT:Codingpublic2014-03-24 16:552014-11-11 12:51
Reporterdln 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0024761: Convertation of the generic classes to the non-generic. Part 5
Description1) Generic class "GccEnt_QualifiedCurv" from "GccEnt" package converted to the non-generic class and moved to the "Geom2dGcc" package. Name of this class was changed to "Geom2dGcc_QCurve".

2) Generic classes "HatchGen_ElementGen", "HatchGen_ElementsGen", "HatchGen_HatchingGen" and "HatchGen_Hatcher" from "HatchGen" package converted to the non-generic classes and moved to the "Geom2dHatch" package. Names of this classes were changed to "Geom2dHatch_Element", "Geom2dHatch_Elements", "Geom2dHatch_Hatching" and "Geom2dHatch_Hatcher". Also all instantiations of the "internal" classes of this classes were moved to the "Geom2dHatch.cdl".

3) Generic classes "Extrema_GExtCC", "Extrema_GExtCC2d", "Extrema_GLocateExtCC" and "Extrema_GLocateExtCC2d" from "Extrema" package converted to the non-generic classes. Names of this classes were changed to "Extrema_ExtCC", "Extrema_ExtCC2d", "Extrema_LocateExtCC" and "Extrema_LocateExtCC2d". Also all instantiations of the "internal" classes of this classes were moved to the "Extrema.cdl".
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0024487closedabv Getting rid of generic CDL classes 

-  Notes
(0028454)
dln (developer)
2014-03-24 16:59

Changes are ready for review in CR24761 branch.
(0028521)
kgv (developer)
2014-03-27 21:51

Dear ifv, please check patch from your point of view.
(0028547)
ifv (developer)
2014-03-28 16:46

Seems to be Ok
(0028583)
mkv (tester)
2014-04-01 12:54

Dear BugMaster,

Branch CR24761 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 40897b75ff08a7203f21026a302449c85520228f

Number of compiler warnings:

occt component :
Linux: 27 (27 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 393410900 / 393242136
Total CPU difference: 53198.51000000003 / 57189.309999999896

Testing on Windows:
Total MEMORY difference: 420624804 / 414274688
Total CPU difference: 37377.78125 / 42798.984375

There are no differences in images found by testdiff.

- Related Changesets
occt: master 0b85f9a6
Timestamp: 2014-03-20 04:19:13
Author: dln
Committer: apn
Details ] Diff ]
0024761: Convertation of the generic classes to the non-generic. Part 5

1) Generic class "GccEnt_QualifiedCurv" from "GccEnt" package converted to the non-generic class and moved to the "Geom2dGcc" package. Name of this class was changed to "Geom2dGcc_QCurve".

2) Generic classes "HatchGen_ElementGen", "HatchGen_ElementsGen", "HatchGen_HatchingGen" and "HatchGen_Hatcher" from "HatchGen" package converted to the non-generic classes and moved to the "Geom2dHatch" package. Names of this classes were changed to "Geom2dHatch_Element", "Geom2dHatch_Elements", "Geom2dHatch_Hatching" and "Geom2dHatch_Hatcher". Also all instantiations of the "internal" classes of this classes were moved to the "Geom2dHatch.cdl".

3) Generic classes "Extrema_GExtCC", "Extrema_GExtCC2d", "Extrema_GLocateExtCC" and "Extrema_GLocateExtCC2d" from "Extrema" package converted to the non-generic classes. Names of this classes were changed to "Extrema_ExtCC", "Extrema_ExtCC2d", "Extrema_LocateExtCC" and "Extrema_LocateExtCC2d". Also all instantiations of the "internal" classes of this classes were moved to the "Extrema.cdl".
mod - src/Extrema/Extrema.cdl Diff ] File ]
mod - src/GccEnt/GccEnt.cdl Diff ] File ]
mod - src/Geom2dGcc/Geom2dGcc.cdl Diff ] File ]
mod - src/Geom2dGcc/Geom2dGcc_Circ2d2TanOn.cxx Diff ] File ]
mod - src/Geom2dGcc/Geom2dGcc_Circ2d2TanRad.cxx Diff ] File ]
mod - src/Geom2dGcc/Geom2dGcc_Circ2d3Tan.cxx Diff ] File ]
mod - src/Geom2dGcc/Geom2dGcc_Circ2dTanCen.cxx Diff ] File ]
mod - src/Geom2dGcc/Geom2dGcc_Circ2dTanOnRad.cxx Diff ] File ]
mod - src/Geom2dGcc/Geom2dGcc_Lin2d2Tan.cxx Diff ] File ]
mod - src/Geom2dGcc/Geom2dGcc_Lin2dTanObl.cxx Diff ] File ]
mod - src/Geom2dHatch/Geom2dHatch.cdl Diff ] File ]
mod - src/HatchGen/HatchGen.cdl Diff ] File ]
mod - src/QABugs/QABugs_17.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-03-24 16:55 dln New Issue
2014-03-24 16:55 dln Assigned To => abv
2014-03-24 16:59 dln Note Added: 0028454
2014-03-24 16:59 dln Status new => resolved
2014-03-27 21:51 kgv Note Added: 0028521
2014-03-27 21:51 kgv Assigned To abv => ifv
2014-03-28 16:46 ifv Note Added: 0028547
2014-03-28 16:46 ifv Status resolved => reviewed
2014-03-28 18:32 mkv Assigned To ifv => mkv
2014-04-01 12:54 mkv Note Added: 0028583
2014-04-01 12:55 mkv Test case number => Not needed
2014-04-01 12:55 mkv Assigned To mkv => bugmaster
2014-04-01 12:55 mkv Status reviewed => tested
2014-04-04 14:00 abv Target Version 6.7.1 => 6.8.0
2014-04-04 17:03 apn Changeset attached => occt master 0b85f9a6
2014-04-04 17:03 apn Assigned To bugmaster => apn
2014-04-04 17:03 apn Status tested => verified
2014-04-04 17:03 apn Resolution open => fixed
2014-04-10 14:47 kgv Relationship added child of 0024487
2014-11-11 12:47 aiv Fixed in Version => 6.8.0
2014-11-11 12:51 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker