MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024720Open CASCADE[OCCT] OCCT:Samplespublic2014-03-13 10:592014-11-11 12:51
Reporterbugmaster 
Assigned Tobugmaster 
PriorityhighSeveritymajor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0024720: Some standard samples are not compiled after latest integration to visualisation
DescriptionWindows. Standard samples

mfc sample

http://jenkins-test-02.nnov.opencascade.com:8080/user/inv/my-views/view/Master%20builds%20Windows%20OCCT/job/mnt-master-master_build_occt_mfc_samples_windows/ [^]

Linux
IE and Tutorial QT samples

http://jenkins-test-02.nnov.opencascade.com:8080/user/inv/my-views/view/Master%20builds%20Linux/job/mnt-master-master_build_occt_qt_samples_ie_linux/ [^]

http://jenkins-test-02.nnov.opencascade.com:8080/user/inv/my-views/view/Master%20builds%20Linux/job/mnt-master-master_build_occt_qt_samples_tutorial_linux/ [^]
TagsNo tags attached.
Test case number
Attached Files

- Relationships
duplicate of 0024711closedapl Get rid of projection shift - port mfc samples 
related to 0024413closedabv Visualization - get rid of projection shift from orthographic camera definition 

-  Notes
(0028251)
bugmaster (administrator)
2014-03-13 11:09
edited on: 2014-03-13 13:01

Sergey,

Could you process request ASAP.

(0028258)
apl (developer)
2014-03-13 15:41

Dear kgv,

Could you please review branch CR24720?

If everything is OK, then the samples can be compiled and tested without recompiling OCCT.
(0028261)
kgv (developer)
2014-03-13 16:17

Dear bugmaster,

please test samples.
(0028266)
bugmaster (administrator)
2014-03-13 20:03

Samples are successfully compiled.

- Related Changesets
occt: master 9764ccbb
Timestamp: 2014-03-13 10:52:18
Author: apl
Committer: bugmaster
Details ] Diff ]
0024720: Some standard samples are not compiled after latest integration to visualisation

Fixed compilation errors in samples:
mfc/standard
qt/Tutorial
qt/IESample
mod - samples/mfc/standard/04_Viewer3d/src/OCCDemo_Presentation.cpp Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/src/OCCDemo_Presentation.h Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/src/Viewer3dView.cpp Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/src/Viewer3dView.h Diff ] File ]
mod - samples/mfc/standard/10_Convert/src/Convert_Presentation.cpp Diff ] File ]
mod - samples/mfc/standard/10_Convert/src/OCCDemo_Presentation.cpp Diff ] File ]
mod - samples/mfc/standard/10_Convert/src/OCCDemo_Presentation.h Diff ] File ]
mod - samples/mfc/standard/10_Convert/src/WNT/OCCDemoView.cpp Diff ] File ]
mod - samples/mfc/standard/10_Convert/src/WNT/OCCDemoView.h Diff ] File ]
mod - samples/mfc/standard/Common/OCC_StereoConfigDlg.cpp Diff ] File ]
mod - samples/qt/Common/src/DocumentCommon.cxx Diff ] File ]
mod - samples/qt/Common/src/DocumentCommon.h Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-03-13 10:59 bugmaster New Issue
2014-03-13 10:59 bugmaster Assigned To => bugmaster
2014-03-13 11:02 bugmaster Summary Some standard samles are crashed after latest integration to master => Some standard samles are crashed after latest integration to visualisation
2014-03-13 11:07 bugmaster Summary Some standard samles are crashed after latest integration to visualisation => Some standard samples are crashed after latest integration to visualisation
2014-03-13 11:09 bugmaster Note Added: 0028251
2014-03-13 11:09 bugmaster Assigned To bugmaster => san
2014-03-13 11:09 bugmaster Status new => assigned
2014-03-13 12:42 san Assigned To san => bugmaster
2014-03-13 12:42 san Assigned To bugmaster => apl
2014-03-13 12:43 bugmaster Assigned To apl => san
2014-03-13 12:43 bugmaster Priority normal => high
2014-03-13 12:43 bugmaster Severity crash => major
2014-03-13 12:43 bugmaster Summary Some standard samples are crashed after latest integration to visualisation => Some standard samples are not compiled after latest integration to visualisation
2014-03-13 12:44 san Relationship added related to 0024413
2014-03-13 12:46 san Relationship added duplicate of 0024711
2014-03-13 12:50 san Assigned To san => apl
2014-03-13 13:01 bugmaster Note Edited: 0028251 View Revisions
2014-03-13 15:41 apl Note Added: 0028258
2014-03-13 15:41 apl Assigned To apl => kgv
2014-03-13 15:41 apl Status assigned => resolved
2014-03-13 16:17 kgv Note Added: 0028261
2014-03-13 16:17 kgv Assigned To kgv => bugmaster
2014-03-13 16:17 kgv Status resolved => reviewed
2014-03-13 16:18 kgv Target Version => 6.7.1
2014-03-13 20:03 bugmaster Note Added: 0028266
2014-03-13 20:03 bugmaster Status reviewed => tested
2014-03-17 11:21 bugmaster Changeset attached => occt master 9764ccbb
2014-03-17 11:21 bugmaster Status tested => verified
2014-03-17 11:21 bugmaster Resolution open => fixed
2014-04-04 12:06 abv Target Version 6.7.1 => 6.8.0
2014-11-11 12:47 aiv Fixed in Version => 6.8.0
2014-11-11 12:51 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker