MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024688Open CASCADE[OCCT] OCCT:DRAWpublic2014-03-05 10:332014-11-11 12:51
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0024688: Draw Harness - vdump command makes snapshot only for the first view
DescriptionImplementation of vdump command was not adopted to multi-view functionality.
Steps To ReproduceSee test case v3d/glsl/phong_views which is currently broken:
pload MODELING VISUALIZATION
box b 1 2 3
vinit View1
vclear
vsetdispmode 1
vaxo
vdisplay b
vfit
vrotate 0.2 0.0 0.0
vdump view1.png
vinit View2
vdump view2.png
diffimage view1.png view2.png 0 0 0 view_diff.png

The dump of second view is equal to the first one.
TagsNo tags attached.
Test case numberv3d glsl(013) phong_views
Attached Files

- Relationships
related to 0023670closedaba Support for multiple 3D views 
related to 0024687closedbugmaster TKOpenGl shader programs - same view state for different v3d views 

-  Notes
(0028148)
kgv (developer)
2014-03-05 14:27

Patch is ready for review in CR24688 branch.
(0028159)
apl (developer)
2014-03-06 10:23

Dear Bugmaster,

The branch is reviewed. Please test.
(0028204)
mkv (tester)
2014-03-11 20:22

Dear BugMaster,

Branch CR24688 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 25a7649e6c39ff31e39a8c587c7e4b9ab0458ee2


Number of compiler warnings:

occt component :
Linux: 30 (30 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24688-master-occt/Debian60-64/v3d/glsl/phong_views.html [^]
phong_views_v2sel.png - bad shading

http://occt-tests/CR24688-master-occt/Windows-32-VC9/v3d/glsl/phong_views.html [^]
v3d glsl(013) phong_views: OK

Testing on Linux:
Total MEMORY difference: 385378184 / 385720176
Total CPU difference: 41651.61999999995 / 43631.789999999986

Testing on Windows:
Total MEMORY difference: 430950968 / 430805176
Total CPU difference: 34704.390625 / 30425.75

There are following differences in images found by testdiff.
http://occt-tests/CR24688-master-occt/Debian60-64/diff-Debian60-64.html [^]
http://occt-tests/CR24688-master-occt/Windows-32-VC9/diff-Windows-32-VC9.html [^]
IMAGE v3d glsl phong_views: phong_views.png differs
IMAGE bugs vis bug23670_1: bug23670_1_MyDriver_MyViewer_MyView.png differs
(0028207)
kgv (developer)
2014-03-12 08:49
edited on: 2014-03-12 08:50

Dear bugmaster,

bug23670_1 - change is OK, no vfit is called for this view. Test case might be changed but I think it doesn't really matter for this case.
phong_views - the issue is expected (see 0024687).

(0028243)
mkv (tester)
2014-03-12 20:11

OK.
Branch CR24688 is TESTED.

- Related Changesets
occt: master 34db9c00
Timestamp: 2014-03-13 10:27:13
Author: kgv
Committer: bugmaster
Details ] Diff ]
0024688: Draw Harness - vdump command makes snapshot only for the first view
mod - src/ViewerTest/ViewerTest.cxx Diff ] File ]
mod - tests/v3d/glsl/phong_views Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-03-05 10:33 kgv New Issue
2014-03-05 10:33 kgv Assigned To => san
2014-03-05 10:34 kgv Assigned To san => kgv
2014-03-05 10:34 kgv Status new => assigned
2014-03-05 10:35 kgv Relationship added related to 0023670
2014-03-05 10:36 kgv Relationship added related to 0024687
2014-03-05 14:27 kgv Note Added: 0028148
2014-03-05 14:27 kgv Assigned To kgv => apl
2014-03-05 14:27 kgv Status assigned => resolved
2014-03-06 10:23 apl Note Added: 0028159
2014-03-06 10:23 apl Assigned To apl => bugmaster
2014-03-06 10:23 apl Status resolved => reviewed
2014-03-06 11:36 mkv Assigned To bugmaster => mkv
2014-03-11 20:22 mkv Note Added: 0028204
2014-03-11 20:23 mkv Test case number => v3d glsl(013) phong_views
2014-03-11 20:23 mkv Assigned To mkv => kgv
2014-03-11 20:23 mkv Status reviewed => feedback
2014-03-12 08:49 kgv Note Added: 0028207
2014-03-12 08:49 kgv Assigned To kgv => mkv
2014-03-12 08:50 kgv Note Edited: 0028207 View Revisions
2014-03-12 20:11 mkv Note Added: 0028243
2014-03-12 20:12 mkv Status feedback => tested
2014-03-12 20:23 mkv Assigned To mkv => bugmaster
2014-03-17 11:21 bugmaster Changeset attached => occt master 34db9c00
2014-03-17 11:21 bugmaster Status tested => verified
2014-03-17 11:21 bugmaster Resolution open => fixed
2014-04-04 12:06 abv Target Version 6.7.1 => 6.8.0
2014-11-11 12:47 aiv Fixed in Version => 6.8.0
2014-11-11 12:51 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker