MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024676Community[OCCT] OCCT:Modeling Algorithmspublic2014-03-03 15:052019-10-21 13:44
Reporteremv 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 7.4.0Fixed in Version[OCCT] 6.7.1 
Summary0024676: Wrong result done by intersection algorithm
DescriptionIntersection algorithm produces 42 identical curves for each face b1_* intersected with the face b2.
Steps To Reproducerestore b1_1.brep b1_1
restore b1_2.brep b1_2
restore b1_3.brep b1_3
restore b1_4.brep b1_4
restore b1_5.brep b1_5
restore b1_6.brep b1_6

restore b2.brep b2

bopcurves b1_1 b2
#Tolerance Reached=5.5209844896474728e-010
#c_1 c_2 c_3 c_4 c_5 c_6 c_7 c_8 c_9 c_10 c_11 c_12 c_13 c_14 c_15 c_16 c_17 c_18 c_19 c_20 c_21 c_22 c_23 c_24 c_25 c_26 c_27 c_28 c_29 c_30 c_31 c_32 c_33 c_34 c_35 c_36 c_37 c_38 c_39 c_40 c_41 c_42

bopcurves b1_2 b2
#Tolerance Reached=5.8701940370756115e-010
#c_1 c_2 c_3 c_4 c_5 c_6 c_7 c_8 c_9 c_10 c_11 c_12 c_13 c_14 c_15 c_16 c_17 c_18 c_19 c_20 c_21 c_22 c_23 c_24 c_25 c_26 c_27 c_28 c_29 c_30 c_31 c_32 c_33 c_34 c_35 c_36 c_37 c_38 c_39 c_40 c_41 c_42

bopcurves b1_3 b2
#Tolerance Reached=1.4003736675191704e-009
#c_1 c_2 c_3 c_4 c_5 c_6 c_7 c_8 c_9 c_10 c_11 c_12 c_13 c_14 c_15 c_16 c_17 c_18 c_19 c_20 c_21 c_22 c_23 c_24 c_25 c_26 c_27 c_28 c_29 c_30 c_31 c_32 c_33 c_34 c_35 c_36 c_37 c_38 c_39 c_40 c_41 c_42

bopcurves b1_4 b2
#Tolerance Reached=1.0479588607462894e-009
#c_1 c_2 c_3 c_4 c_5 c_6 c_7 c_8 c_9 c_10 c_11 c_12 c_13 c_14 c_15 c_16 c_17 c_18 c_19 c_20 c_21 c_22 c_23 c_24 c_25 c_26 c_27 c_28 c_29 c_30 c_31 c_32 c_33 c_34 c_35 c_36 c_37 c_38 c_39 c_40 c_41 c_42

bopcurves b1_5 b2
#Tolerance Reached=6.9954439341157332e-010
#c_1 c_2 c_3 c_4 c_5 c_6 c_7 c_8 c_9 c_10 c_11 c_12 c_13 c_14 c_15 c_16 c_17 c_18 c_19 c_20 c_21 c_22 c_23 c_24 c_25 c_26 c_27 c_28 c_29 c_30 c_31 c_32 c_33 c_34 c_35 c_36 c_37 c_38 c_39 c_40 c_41 c_42

bopcurves b1_6 b2
#Tolerance Reached=6.9954439341157332e-010
#c_1 c_2 c_3 c_4 c_5 c_6 c_7 c_8 c_9 c_10 c_11 c_12 c_13 c_14 c_15 c_16 c_17 c_18 c_19 c_20 c_21 c_22 c_23 c_24 c_25 c_26 c_27 c_28 c_29 c_30 c_31 c_32 c_33 c_34 c_35 c_36 c_37 c_38 c_39 c_40 c_41 c_42
TagsNo tags attached.
Test case numberbugs modalg_7 bug24676
Attached Files? file icon b1_1.brep (1,874 bytes) 2014-03-03 15:05
? file icon b1_2.brep (2,154 bytes) 2014-03-03 15:05
? file icon b1_3.brep (1,933 bytes) 2014-03-03 15:06
? file icon b1_4.brep (1,600 bytes) 2014-03-03 15:06
? file icon b1_5.brep (2,424 bytes) 2014-03-03 15:06
? file icon b1_6.brep (2,238 bytes) 2014-03-03 15:06
? file icon b2.brep (15,594 bytes) 2014-03-03 15:06

- Relationships
child of 0024628closedabv Intersection result is unfixed 

-  Notes
(0048801)
nbv (developer)
2015-12-07 15:46

On the current MASTER the result of every intersection is empty.
(0072645)
nbv (developer)
2017-12-01 13:07
edited on: 2017-12-01 13:08

Check if empty result is correct requires additional analysis. So, I suggest to put (temporary) TODO "Result is EMPTY" in new test cases.

As far as I know, the new result is stable.

(0080326)
nbv (developer)
2018-10-25 16:35
edited on: 2018-10-25 16:37

The shape b2.brep has dimension ~ 1.0e-7. This thin face is bad to be an intersection argument. So, empty intersection result should be considered as OK.

Therefore, on the current MASTER, no problems are detected by intersection algorithm.

Particularly, the problem with unstable behavior has been fixed in frame of the issue #24650.

(0080329)
msv (developer)
2018-10-25 16:42

Please create a test case.
(0080332)
git (administrator)
2018-10-25 17:18

Branch CR24676 has been created by nbv.

SHA-1: 37049bde25c4f59a6863be07cbfd2ca8740c25b0


Detailed log of new commits:

Author: nbv
Date: Thu Oct 25 17:14:21 2018 +0300

    0024676: Wrong result done by intersection algorithm
    
    Only test case has been created because the problem is not reproduced on the current MASTER
(0080352)
nbv (developer)
2018-10-26 09:29

Dear Mikhail,

Please review the branch CR24676. New test cases have been created only.

Test results are here:

Linux: http://jenkins-test-12.nnov.opencascade.com/view/CR24676-master_NBV/view/TESTING/job/CR24676-master_NBV-OCCT-Debian80-64-opt-test-restart/HTML_20Report/ [^]

Windows: http://jenkins-test-12.nnov.opencascade.com/view/CR24676-master_NBV/view/TESTING/job/CR24676-master_NBV-OCCT-Windows-64-VC14-opt-test-restart/HTML_20Report/ [^]
(0080355)
git (administrator)
2018-10-26 09:52

Branch CR24676 has been updated forcibly by nbv.

SHA-1: 980bd014eb795f8446cb5750d019928f8437ba3f
(0080356)
msv (developer)
2018-10-26 09:57

Reviewed.
(0080366)
apn (administrator)
2018-10-26 12:33

Test case:
bugs modalg_7 bug24676 - OK
(0080405)
git (administrator)
2018-10-28 16:13

Branch CR24676 has been deleted by inv.

SHA-1: 980bd014eb795f8446cb5750d019928f8437ba3f

- Related Changesets
occt: master df1d6870
Timestamp: 2018-10-25 14:14:21
Author: nbv
Committer: apn
Details ] Diff ]
0024676: Wrong result done by intersection algorithm

Only test case has been created because the problem is not reproduced on the current MASTER
add - tests/bugs/modalg_7/bug24676 Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-03-03 15:05 emv New Issue
2014-03-03 15:05 emv Assigned To => ifv
2014-03-03 15:05 emv File Added: b1_1.brep
2014-03-03 15:05 emv File Added: b1_2.brep
2014-03-03 15:06 emv File Added: b1_3.brep
2014-03-03 15:06 emv File Added: b1_4.brep
2014-03-03 15:06 emv File Added: b1_5.brep
2014-03-03 15:06 emv File Added: b1_6.brep
2014-03-03 15:06 emv File Added: b2.brep
2014-03-03 15:07 emv Relationship added child of 0024628
2014-03-03 15:41 ifv Assigned To ifv => nbv
2014-03-03 15:41 ifv Status new => assigned
2015-12-07 15:46 nbv Note Added: 0048801
2017-12-01 13:07 nbv Note Added: 0072645
2017-12-01 13:08 nbv Note Edited: 0072645 View Revisions
2018-10-25 16:35 nbv Note Added: 0080326
2018-10-25 16:37 nbv Note Edited: 0080326 View Revisions
2018-10-25 16:42 msv Note Added: 0080329
2018-10-25 17:18 git Note Added: 0080332
2018-10-26 09:29 nbv Note Added: 0080352
2018-10-26 09:29 nbv Assigned To nbv => msv
2018-10-26 09:29 nbv Status assigned => resolved
2018-10-26 09:52 git Note Added: 0080355
2018-10-26 09:57 msv Note Added: 0080356
2018-10-26 09:57 msv Assigned To msv => bugmaster
2018-10-26 09:57 msv Status resolved => reviewed
2018-10-26 12:33 apn Test case number => bugs modalg_7 bug24676
2018-10-26 12:33 apn Note Added: 0080366
2018-10-26 12:33 apn Status reviewed => tested
2018-10-28 13:20 apn Changeset attached => occt master df1d6870
2018-10-28 13:20 apn Assigned To bugmaster => apn
2018-10-28 13:20 apn Status tested => verified
2018-10-28 13:20 apn Resolution open => fixed
2018-10-28 16:13 git Note Added: 0080405
2019-10-21 13:44 abv Status verified => closed
2019-10-21 13:44 abv Fixed in Version => 6.7.1
2019-10-21 13:44 abv Target Version => 7.4.0


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker