MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024672Open CASCADE[OCCT] OCCT:Visualizationpublic2014-02-28 10:092015-04-07 12:36
Reporterkgv 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0024672: Visualization - AIS_TexturedShape does not activate back face culling aspect
DescriptionAIS_TexturedShape manage back face culling property in way inconsistent to AIS_Shape.
TagsNo tags attached.
Test case numberNot needed
Attached Filespng file icon cull_tex.png (88,897 bytes) 2014-02-28 10:09

- Relationships
related to 0024521closedbugmaster Open CASCADE Visualization - automatic back face culling is not turned on for Solids packed into compound 
related to 0026027closedbugmaster Open CASCADE Visualization, AIS_TexturedShape - back face culling option should not be overridden by texturing aspect 

-  Notes
(0028073)
kgv (developer)
2014-02-28 12:30

Patch is ready for review in CR24672 branch (based on CR24622_1).
(0028074)
apl (developer)
2014-02-28 13:15

Dear Bugmaster,

Branch CR24672_1 is reviewed and ready for testing.
(0028087)
mkv (tester)
2014-03-03 13:00

Dear BugMaster,

Branch CR24672_1 (and products from GIT master) was compiled on Linux and Windows platforms.
There is compilation error on Linux platform:
http://jenkins-test-02.nnov.opencascade.com:8080/user/mnt/my-views/view/CR24622_1/job/mnt-CR24622_1-master_build_occt_linux/1/parsed_console/? [^]
../../../../src/QABugs/QABugs_19.cxx:1718: error: conversion from ‘BRepPrimAPI_MakeBox’ to ‘TopoDS_Shape’ is ambiguous
(0028092)
apl (developer)
2014-03-03 16:50
edited on: 2014-03-03 16:51

Dear kgv,

The branch was rebased on fresh CR24622_1 and pushed as CR24672_2. Please check and send this one to testing when you finish reviewing CR24622_1.

(0028096)
kgv (developer)
2014-03-03 17:00

Please test branch CR24672_2.
(0028135)
mkv (tester)
2014-03-04 17:14

Dear BugMaster,

Branch CR24672_2 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 5b8cc5fee08c378d31107a3bb53f187412e54105

Number of compiler warnings:

occt component :
Linux: 29 (29 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 383115756 / 382850156
Total CPU difference: 62257.44999999978 / 52926.71000000003

Testing on Windows:
Total MEMORY difference: 429273972 / 428923596
Total CPU difference: 31353.28125 / 32992.875

There are following differences in images found by testdiff.
http://occt-tests/CR24672-2-master-occt/Debian60-64/diff-Debian60-64.html [^]
http://occt-tests/CR24672-2-master-occt/Windows-32-VC9/diff-Windows-32-VC9.html [^]
IMAGE bugs vis bug5988: bug5988_Driver1_Viewer1_View1.png differs
IMAGE bugs vis bug23813: bug23813_Driver1_Viewer1_View1.png differs
(0039287)
abv (manager)
2015-04-07 10:22

The problem is reproduced again

- Related Changesets
occt: master 8e3ebc7a
Timestamp: 2014-03-06 10:40:36
Author: abv
Committer: abv
Details ] Diff ]
0024672: Visualization - AIS_TexturedShape does not activate back face culling aspect
mod - src/AIS/AIS_TexturedShape.cxx Diff ] File ]
mod - src/AIS/AIS_TexturedShape.hxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-02-28 10:09 kgv New Issue
2014-02-28 10:09 kgv Assigned To => san
2014-02-28 10:09 kgv File Added: cull_tex.png
2014-02-28 10:10 kgv Assigned To san => kgv
2014-02-28 10:10 kgv Status new => assigned
2014-02-28 10:10 kgv Relationship added related to 0024622
2014-02-28 10:10 kgv Relationship added related to 0024521
2014-02-28 12:30 kgv Note Added: 0028073
2014-02-28 12:30 kgv Assigned To kgv => apl
2014-02-28 12:30 kgv Status assigned => resolved
2014-02-28 13:15 apl Note Added: 0028074
2014-02-28 13:15 apl Assigned To apl => bugmaster
2014-02-28 13:15 apl Status resolved => reviewed
2014-02-28 18:33 mkv Assigned To bugmaster => mkv
2014-03-03 13:00 mkv Note Added: 0028087
2014-03-03 13:00 mkv Assigned To mkv => kgv
2014-03-03 13:00 mkv Status reviewed => assigned
2014-03-03 16:50 apl Assigned To kgv => apl
2014-03-03 16:50 apl Note Added: 0028092
2014-03-03 16:50 apl Assigned To apl => kgv
2014-03-03 16:50 apl Status assigned => resolved
2014-03-03 16:51 apl Note Edited: 0028092 View Revisions
2014-03-03 17:00 kgv Note Added: 0028096
2014-03-03 17:00 kgv Assigned To kgv => bugmaster
2014-03-03 17:00 kgv Status resolved => reviewed
2014-03-03 18:34 mkv Assigned To bugmaster => mkv
2014-03-04 17:14 mkv Note Added: 0028135
2014-03-04 17:14 mkv Test case number => Not needed
2014-03-04 17:14 mkv Assigned To mkv => bugmaster
2014-03-04 17:14 mkv Status reviewed => tested
2014-03-11 14:41 abv Changeset attached => occt master 8e3ebc7a
2014-03-11 14:41 abv Assigned To bugmaster => abv
2014-03-11 14:41 abv Status tested => verified
2014-03-11 14:41 abv Resolution open => fixed
2014-04-04 12:06 abv Target Version 6.7.1 => 6.8.0
2014-11-11 12:47 aiv Fixed in Version => 6.8.0
2014-11-11 12:51 aiv Status verified => closed
2015-04-07 10:22 abv Note Added: 0039287
2015-04-07 12:36 kgv Relationship added related to 0026027


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker