MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024657Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2014-02-24 19:422017-12-05 17:09
Reporteribs 
Assigned Toibs 
PrioritynormalSeveritymajor 
StatusassignedResolutionopen 
PlatformOSOS Version
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0024657: 2dintersect returns different number of intersect points
Description2dintersect depends on 2d curve arg sequence:

there is the case when:
"2dintersect curve1 curve2" returns one intersect point
but
"2dintersect curve2 curve1" returns TWO intersect points
Steps To Reproducerestore bug24657.brep a
explode a e
pcu p4 a_4 a
pcu p5 a_5 a
2dintersect p4 p5 10e-7
2dintersect p5 p4 10e-7


TagsNo tags attached.
Test case numberbugs modalg_5(010) bug24657
Attached Files? file icon bug24657.brep (10,599 bytes) 2014-02-24 19:43

- Relationships

-  Notes
(0028030)
ibs (developer)
2014-02-25 16:18

dear ifv, please review CR24657 branch
(0028040)
ifv (developer)
2014-02-26 17:21

Ok
(0028059)
mkv (tester)
2014-02-27 18:54

Dear BugMaster,

Branch CR24657 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 241c852f5210dd78a507d48c6b2e3754bece389e

Number of compiler warnings:

occt component :
Linux: 29 (29 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
http://occt-tests/CR24657-master-occt/Debian60-64/summary.html [^]
http://occt-tests/CR24657-master-occt/Windows-32-VC9/summary.html [^]
Improvements:
de iges_1(001) F9
de iges_2(002) G7
de step_2(005) D1
heal split_angle_advanced(012) Z3
heal split_closed_faces(011) G5
Failed:
de iges_1(001) G6, K3, L8, P8, R8
de iges_2(002) B8, C2, F4
de step_2(005) M4
de step_3(006) C4, D9, E6, F2
heal split_angle_advanced(012) ZA5, ZA6


http://jenkins-test-02.nnov.opencascade.com:8080/user/mnt/my-views/view/CR24657/job/mnt-CR24657-master_products_tests_linux_start/label=Debian60-64,tests_group=parasolid,tests_subgroup=003/4/HTML_Report/? [^]
http://jenkins-test-02.nnov.opencascade.com:8080/user/mnt/my-views/view/CR24657/job/mnt-CR24657-master_products_tests_windows_start/label=windows_test,tests_group=parasolid,tests_subgroup=003/2/HTML_Report/? [^]
parasolid doc_3(003) E3

http://jenkins-test-02.nnov.opencascade.com:8080/user/mnt/my-views/view/CR24657/job/mnt-CR24657-master_products_tests_linux_start/label=Debian60-64,tests_group=sat,tests_subgroup=001/4/HTML_Report/? [^]

sat doc_1(001) ZV5

Testing cases:
http://occt-tests/CR24657-master-occt/Debian60-64/bugs/modalg_5/bug24657.html [^]
http://occt-tests/CR24657-master-occt/Windows-32-VC9/bugs/modalg_5/bug24657.html [^]
bugs modalg_5(010) bug24657: OK

Testing on Linux:
Total MEMORY difference: 379407000 / 378983764
Total CPU difference: 49329.440000000024 / 43578.700000000004

Testing on Windows:
Total MEMORY difference: 426789228 / 426390392
Total CPU difference: 26989.875 / 33726.015625

There are following differences in images found by testdiff.
http://occt-tests/CR24657-master-occt/Debian60-64/diff-Debian60-64.html [^]
http://occt-tests/CR24657-master-occt/Windows-32-VC9/diff-Windows-32-VC9.html [^]
IMAGE bugs iges bug22504: bug22504_Driver1_Viewer1_View1.png differs
(0028185)
ibs (developer)
2014-03-07 18:14
edited on: 2014-03-11 12:05

de step_3 C4
  max tol is the same as before but average tol has increased. it isn't regression
  
de iges_2 C2
  max tol is smaller. it is IMPROVEMENT
  
de step_2 M4
  max tol is smaller. it is IMPROVEMENT

heal split_angle_advanced ZA6
 the num of errors has decreased. it is IMPROVEMENT

heal split_angle_advanced ZA5
 the num of errors has decreased. it is IMPROVEMENT

all other aren't regressions (have different secondary params)

checkshape questions in the process: de step_3 D9, de iges_2 F4

(0028217)
ibs (developer)
2014-03-12 12:19

de iges_2 F4

this test contains a new additional faulty. the new one (wire self-intersection) appeared after loopback test due to poly intersection algorithm seeks with both criteria: exact intersection (in parametric space) and “node” intersection. The last criterion has been turned on (findIntersect method, last param is TRUE) due to the being processed polygons aren’t complemented by new points (ComputeWithBox isn’t used already).
So I deem the faulty isn’t regression
(0028398)
ibs (developer)
2014-03-20 14:38

de step_3 D9

isn't regression (see 24743 issue)
(0028400)
ibs (developer)
2014-03-20 14:58

and other
de iges_1(001) G6, K3, L8, P8, R8
de iges_2(002) B8
de step_3(006) C4, E6, F2

aren't regressions
(0028406)
ibs (developer)
2014-03-20 17:54
edited on: 2014-03-20 17:55

##copied from #24549 , http://tracker.dev.opencascade.org/view.php?id=24549#c28405 [^]

mkv:

Dear BugMaster,

Branch CR24549_with24657 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 88f9b3b2373f9547c91679565e8c4c4be873f891

Number of compiler warnings:

occt component :
Linux: 30 (30 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
http://occt-tests/CR24549-24657-master-occt/Debian60-64/summary.html [^] [^]
http://occt-tests/CR24549-24657-master-occt/Windows-32-VC9/summary.html [^] [^]
Improvements:
bugs heal bug210
de iges_2 E3
de step_1 N3
de step_2 G1
Failed:
de iges_1(001) B4, L5, Q3, R5
de iges_2(002) A9, B1, C4, G1, G8, I7
de iges_3(003) A2
de step_1(004) A3, G9, V3
de step_2(005) D7, D8, F1, K1, O8, Y5
de step_3(006) A5, A9, B5, C6, D8, D9, E6
de step_4(007) I2
de step_5(008) A1, A3
xcaf brep_to_stp_add_CL(009) I6

Testing cases:
http://occt-tests/CR24549-24657-master-occt/Debian60-64/bugs/heal/bug24549.html [^] [^]
http://occt-tests/CR24549-24657-master-occt/Windows-32-VC9/bugs/heal/bug24549.html [^] [^]
bugs heal(017) bug24549: OK

Testing on Linux:
Total MEMORY difference: 384014256 / 380174460
Total CPU difference: 44659.88000000026 / 46659.64

Testing on Windows:
Total MEMORY difference: 421755968 / 418700688
Total CPU difference: 31584.203125 / 30899.28125

There are following differences in images found by testdiff.
http://occt-tests/CR24549-24657-master-occt/Debian60-64/diff-Debian60-64.html [^] [^]
http://occt-tests/CR24549-24657-master-occt/Windows-32-VC9/diff-Windows-32-VC9.html [^] [^]
IMAGE bugs iges bug22504: bug22504_Driver1_Viewer1_View1.png differs

(0028408)
ibs (developer)
2014-03-20 18:19

there is the problem in CR24549_with24657 results. the pin on image in "bugs iges bug22504" is shifted.

but the pin on the image of current CR24657 (rebased at IR-2014-03-20) branch isn't shifted.
(0028410)
ibs (developer)
2014-03-20 19:02

dear mkv, please test CR24657 branch
(0028466)
mkv (tester)
2014-03-25 15:42

Dear BugMaster,

Branch CR24657 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 6b7715f685340b9785428b6391ff0324692129e4

Number of compiler warnings:

occt component :
Linux: 29 (29 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
http://occt-tests/CR24657-master-occt/Debian60-64/de/step_3/D3.html [^]
Improvements:
de step_3(006) D3 - corrected and pushed to branch CR24657

Testing cases:
http://occt-tests/CR24657-master-occt/Debian60-64/bugs/modalg_5/bug24657.html [^]
http://occt-tests/CR24657-master-occt/Windows-32-VC9/bugs/modalg_5/bug24657.html [^]
bugs modalg_5(010) bug24657: OK

Testing on Linux:
Total MEMORY difference: 390844552 / 390850480
Total CPU difference: 47064.130000000005 / 51146.809999999656

Testing on Windows:
Total MEMORY difference: 435054348 / 433684232
Total CPU difference: 33036.875 / 35632.53125

There are following differences in images found by testdiff.
http://occt-tests/CR24657-master-occt/Debian60-64/diff-Debian60-64.html [^]
http://occt-tests/CR24657-master-occt/Windows-32-VC9/diff-Windows-32-VC9.html [^]
IMAGE bugs iges bug22504: bug22504_Driver1_Viewer1_View1.png differs
(0028474)
ibs (developer)
2014-03-25 17:39

i have executed "bugs iges bug22504" test case on "windows 32 vc10" (current CR24657 branch) and it isn't different from master.

and also the made fixes in this issue shouldn't do any influence at the executed test.

dear bugmaster, please integrate
(0028543)
bugmaster (administrator)
2014-03-28 15:54

Problem bugs iges bug22504 is reproduced on IR-2014-03-27
(0028544)
ibs (developer)
2014-03-28 16:01

Ok. I'll start to investigate this problem more deeper

- Issue History
Date Modified Username Field Change
2014-02-24 19:42 ibs New Issue
2014-02-24 19:42 ibs Assigned To => ibs
2014-02-24 19:43 ibs File Added: bug24657.brep
2014-02-24 19:43 ibs Steps to Reproduce Updated View Revisions
2014-02-25 15:10 ibs Steps to Reproduce Updated View Revisions
2014-02-25 15:20 ibs Summary fix orientation in ShapeFix_Face causes the appearance of new additional intersection point of two 2dcurves => 2dintersect returns different number of intersect points
2014-02-25 15:20 ibs Description Updated View Revisions
2014-02-25 15:20 ibs Steps to Reproduce Updated View Revisions
2014-02-25 16:18 ibs Assigned To ibs => ifv
2014-02-25 16:18 ibs Note Added: 0028030
2014-02-25 16:18 ibs Status new => resolved
2014-02-26 17:21 ifv Note Added: 0028040
2014-02-26 17:21 ifv Status resolved => reviewed
2014-02-26 17:45 mkv Assigned To ifv => mkv
2014-02-27 18:54 mkv Note Added: 0028059
2014-02-27 18:55 mkv Test case number => bugs modalg_5(010) bug24657
2014-02-27 18:55 mkv Assigned To mkv => ibs
2014-02-27 18:55 mkv Status reviewed => assigned
2014-03-07 18:14 ibs Note Added: 0028185
2014-03-11 12:05 ibs Note Edited: 0028185 View Revisions
2014-03-11 17:19 ibs File Added: res_1_284_with_fix.png
2014-03-11 17:19 ibs File Added: res_1_284_master.png
2014-03-11 17:20 ibs File Deleted: res_1_284_with_fix.png
2014-03-11 17:20 ibs File Deleted: res_1_284_master.png
2014-03-11 17:20 ibs File Added: res_1_284_master.png
2014-03-11 17:20 ibs File Added: res_1_284_with_fix.png
2014-03-11 17:34 ibs File Added: res_2_285.png
2014-03-11 17:34 ibs File Added: res_2_285_master.png
2014-03-11 17:34 ibs File Deleted: res_2_285.png
2014-03-11 17:35 ibs File Added: res_2_285_with_fix.png
2014-03-12 12:19 ibs Note Added: 0028217
2014-03-12 12:31 ibs File Deleted: res_1_284_with_fix.png
2014-03-12 12:31 ibs File Deleted: res_2_285_with_fix.png
2014-03-12 12:31 ibs File Added: de_step_3_D9_after_loopback_with_fix.png
2014-03-12 12:32 ibs File Added: de_step_3_D9_first_read_with_fix.png
2014-03-12 12:34 ibs File Deleted: res_2_285_master.png
2014-03-12 12:34 ibs File Deleted: res_1_284_master.png
2014-03-12 12:35 ibs File Added: de_step_3_D9_first_read_master.png
2014-03-12 12:35 ibs File Added: de_step_3_D9_after_loopback_master.png
2014-03-12 15:55 ibs Note Added: 0028232
2014-03-12 15:55 ibs Assigned To ibs => bugmaster
2014-03-12 15:55 ibs Status assigned => feedback
2014-03-17 19:00 ibs Assigned To bugmaster => ibs
2014-03-17 19:00 ibs Status feedback => assigned
2014-03-18 18:01 ibs Note Deleted: 0028232
2014-03-20 14:38 ibs Note Added: 0028398
2014-03-20 14:43 ibs File Deleted: de_step_3_D9_after_loopback_master.png
2014-03-20 14:43 ibs File Deleted: de_step_3_D9_after_loopback_with_fix.png
2014-03-20 14:43 ibs File Deleted: de_step_3_D9_first_read_with_fix.png
2014-03-20 14:43 ibs File Deleted: de_step_3_D9_first_read_master.png
2014-03-20 14:58 ibs Note Added: 0028400
2014-03-20 15:34 ibs Category OCCT:Shape Healing => OCCT:Modeling Algorithms
2014-03-20 15:35 ibs Target Version 7.0.0 => 6.7.1
2014-03-20 17:54 ibs Note Added: 0028406
2014-03-20 17:55 ibs Note Edited: 0028406 View Revisions
2014-03-20 18:19 ibs Note Added: 0028408
2014-03-20 19:02 ibs Note Added: 0028410
2014-03-20 19:02 ibs Assigned To ibs => mkv
2014-03-20 19:02 ibs Status assigned => feedback
2014-03-21 17:22 mkv Status feedback => reviewed
2014-03-25 15:42 mkv Note Added: 0028466
2014-03-25 15:42 mkv Assigned To mkv => ibs
2014-03-25 15:42 mkv Status reviewed => assigned
2014-03-25 17:39 ibs Note Added: 0028474
2014-03-25 17:39 ibs Assigned To ibs => bugmaster
2014-03-25 17:39 ibs Status assigned => feedback
2014-03-26 09:56 bugmaster Status feedback => tested
2014-03-28 15:54 bugmaster Note Added: 0028543
2014-03-28 15:54 bugmaster Assigned To bugmaster => ibs
2014-03-28 15:54 bugmaster Status tested => assigned
2014-03-28 16:01 ibs Note Added: 0028544
2014-04-04 18:09 abv Target Version 6.7.1 => 6.8.0
2014-10-29 13:43 abv Target Version 6.8.0 => 7.1.0
2016-10-28 16:28 msv Target Version 7.1.0 => 7.2.0
2017-07-24 09:32 msv Target Version 7.2.0 => 7.3.0
2017-12-05 17:09 msv Target Version 7.3.0 => 7.4.0*


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker