MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024639Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2014-02-18 16:142014-11-11 12:58
Reporterifv 
Assigned Tomkv 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0024639: Parallelization FillDS part of BO
DescriptionParallelization of algorithms, which compute geometrical interferences between arguments of BO.
Steps To ReproduceNo script.
Just test it.
TagsNo tags attached.
Test case numberbugs modalg_5(010) bug24639
Attached Files? file icon zedges.tcl (1,067 bytes) 2014-03-04 12:15
? file icon zve1.tcl (414 bytes) 2014-03-20 10:37
? file icon zvf.tcl (558 bytes) 2014-04-01 08:24
? file icon zef.tcl (799 bytes) 2014-04-08 13:16
? file icon zff.tcl (688 bytes) 2014-04-15 07:27

- Relationships
related to 0024157closedapn Open CASCADE Parallelization of assembly part of BO 
related to 0024826closedbugmaster Community Wrapping of parallelisation algorithms 
related to 0025269closedbugmaster Open CASCADE Make parallel version of boolean operations avaible from DRAW 

-  Notes
(0028116)
pkv (developer)
2014-03-04 11:59
edited on: 2014-03-04 12:15

The branch CR24639 is ready to be reviewed.

Part 1.
The contents dealing with the parallel computation of Edge/Edge interferences.

Use the following commands to reproduce the problem:
#
source zedges.tcl
nurbsconvert bx bx
nurbsconvert by by
nurbsconvert bz bz

bclearobjects; bcleartools;
baddcompound bx
baddcompound by
baddcompound bz

bfillds -t
# result:
Tps: 1.42

bfillds -t -s
# result:
Tps: 3.30

(0028129)
ifv (developer)
2014-03-04 16:19

Ok
(0028149)
mkv (tester)
2014-03-05 14:32

Dear BugMaster,

Branch CR24639 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 53a43c290359715ca09e14278cc4f20f49d085d6

Number of compiler warnings:

occt component :
Linux: 29 (29 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24639-master-occt/Debian60-64/bugs/modalg_5/bug24639.html [^]
http://occt-tests/CR24639-master-occt/Windows-32-VC9/bugs/modalg_5/bug24639.html [^]
bugs modalg_5(010) bug24639: OK

Testing on Linux:
Total MEMORY difference: 383348680 / 382818784
Total CPU difference: 42815.77000000012 / 52882.73000000003

Testing on Windows:
Total MEMORY difference: 429512156 / 428923596
Total CPU difference: 33318.828125 / 32992.875

There are not differences in images found by testdiff.
(0028381)
pkv (developer)
2014-03-20 10:40

The branch CR24639_1 is ready to be reviewed.

Part 2.
The contents dealing with the parallel computation of Vertex/Edge interferences.

Use the following commands to reproduce the problem:
#
source zve1.tcl

bclearobjects
baddcompound b1

# parallel computations:
bfillds -t
Tps: 1.03

# serial computations:
bfillds -t -s
Tps: 3.46
(0028382)
ifv (developer)
2014-03-20 11:04

Ok
(0028411)
mkv (tester)
2014-03-20 19:30

Dear BugMaster,

Branch CR24639_1 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 4c40db823f570fd52e2e050a4caeb11a16593b32

There are compilation errors on Linux platform:
http://jenkins-test-02.nnov.opencascade.com:8080/user/mnt/my-views/view/CR24639_1/job/mnt-CR24639_1-master_build_occt_linux/1/parsed_console/? [^]
../../../../src/BOPAlgo/BOPAlgo_Builder_2.cxx: In member function ‘void BOPAlgo_Builder::FillSameDomainFaces()’:
../../../../src/BOPAlgo/BOPAlgo_Builder_2.cxx:366: error: ‘class BOPTools_Set’ has no member named ‘AddEdges’
../../../../src/BOPAlgo/BOPAlgo_Builder_2.cxx:387: error: ‘class BOPTools_Set’ has no member named ‘AddEdges’
../../../../src/BOPAlgo/BOPAlgo_Builder_2.cxx:388: error: ‘class BOPTools_Set’ has no member named ‘AddEdges’
(0028436)
pkv (developer)
2014-03-24 09:45

The branch CR24639_2 is ready to be reviewed.

Modifications done to prevent compilation errors.
(0028457)
ifv (developer)
2014-03-25 11:08

Ok
(0028487)
mkv (tester)
2014-03-26 13:04
edited on: 2014-03-26 13:07

Dear BugMaster,

Branch CR24639_2 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 626c4fa5a396fc9eab988c67df5d0c29ceb391e2

Number of compiler warnings:

occt component :
Linux: 29 (29 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24639-2-master-occt/Debian60-64/bugs/modalg_5/bug24639.html [^]
http://occt-tests/CR24639-2-master-occt/Windows-32-VC9/bugs/modalg_5/bug24639.html [^]
bugs modalg_5(010) bug24639: OK

Testing on Linux:
Total MEMORY difference: 391559412 / 391531872
Total CPU difference: 50755.54999999993 / 51359.449999999655

Testing on Windows:
Total MEMORY difference: 415746572 / 420754760
Total CPU difference: 40534.375 / 35396.234375

There are no differences in images found by testdiff.

(0028572)
pkv (developer)
2014-04-01 08:27

The branch CR24639_3 is ready to be reviewed.

Part 3.
The contents dealing with the parallel computation of Vertex/Face interferences.

Use the following commands to obtain the results:
#
source zvf1.tcl

bclearobjects
baddcompound b1

# parallel computations:
bfillds -t
Tps: 1.68

bbuild r -t
Tps: 1.61

# serial computations:
bfillds -t -s
Tps: 5.46

bbuild r -t -s
Tps: 5.52
(0028578)
ifv (developer)
2014-04-01 09:47

Ok
(0028617)
mkv (tester)
2014-04-02 11:14

Dear BugMaster,

Branch CR24639_3 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 4f45128bbf183e18c8fbc3bd03985494fee38544

Number of compiler warnings:

occt component :
Linux: 27 (27 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24639-3-master-occt/Debian60-64/bugs/modalg_5/bug24639.html [^]
http://occt-tests/CR24639-3-master-occt/Windows-32-VC9/bugs/modalg_5/bug24639.html [^]
bugs modalg_5(010) bug24639: OK

Testing on Linux:
Total MEMORY difference: 394349764 / 393215468
Total CPU difference: 57914.709999999825 / 57187.419999999904

Testing on Windows:
Total MEMORY difference: 423563488 / 414274688
Total CPU difference: 37757.8125 / 42798.984375

There are no differences in images found by testdiff.
(0028731)
pkv (developer)
2014-04-08 13:16
edited on: 2014-04-08 13:18

The branch CR24639_4 is ready to be reviewed.

Part 4.
The contents dealing with the parallel computation of Edge/Face interferences.

Use the following commands to obtain the results:
#
source zef.tcl
# results:
parallel: Tps: 6.38
serial : Tps: 20.15

(0028741)
ifv (developer)
2014-04-08 14:52

Ok
(0028762)
apn (administrator)
2014-04-09 13:41
edited on: 2014-04-09 13:41

Dear BugMaster,

Branch CR24639_4 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 4b8ab7d43842353b3af9d6404450f976465e7adb

Number of compiler warnings:

occt component :
Linux: 21 (21 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
bugs modalg_5 bug24639 - OK
http://occt-tests/CR24639-4-master-occt/Debian60-64/bugs/modalg_5/bug24639.html [^]
http://occt-tests/CR24639-4-master-occt/Windows-32-VC9/bugs/modalg_5/bug24639.html [^]

Testing on Linux:
Total MEMORY difference: 351974032 / 352026040
Total CPU difference: 59630.55000000006 / 50789.29000000014

Testing on Windows:
Total MEMORY difference: 381419608 / 381244252
Total CPU difference: 38832.875 / 36679.046875

There are no differences in images found by testdiff.

(0028831)
pkv (developer)
2014-04-15 07:28

The branch CR24639_5 is ready to be reviewed.

Part 5.
The contents dealing with
5.1. Parallel computation of Face/Face interferences.
5.2. Parallel computation of Edge/Edge interferences (Post-Treatment Level).
5.3. Parallel intersection of bounding boxes (BOPDS_Iterator Level).

Use the following commands to obtain the results:
#
source zff.tcl
# results:
parallel: Tps: 3.16
serial : Tps: 12.18
(0028841)
ifv (developer)
2014-04-15 13:23

Ok
(0028906)
mkv (tester)
2014-04-16 19:09

Dear BugMaster,

Branch CR24639_5 (and products from GIT master) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 1d229bb0ad852d70c8f7d6d5f03ac179a7b52387

Number of compiler warnings:

occt component :
Linux: 18 (18 on master)
Windows: 0 (0 on master)
MacOS: 413 (413 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24639-5-master-occt/Debian60-64/bugs/modalg_5/bug24639.html [^]
http://occt-tests/CR24639-5-master-occt/Windows-32-VC9/bugs/modalg_5/bug24639.html [^]
bugs modalg_5(010) bug24639 - OK

Testing on Linux:
Total MEMORY difference: 354551600 / 352653700
Total CPU difference: 58713.180000000175 / 67343.38000000024

Testing on Windows:
Total MEMORY difference: 382038556 / 380703700
Total CPU difference: 36785.140625 / 39760.09375

There are no differences in images found by testdiff.
(0029213)
pkv (developer)
2014-05-06 14:10

The branch CR24639_6 is ready to be reviewed.

The flag of parallel processing is switched on by default.
(0029214)
ifv (developer)
2014-05-06 14:18

Ok
(0029256)
mkv (tester)
2014-05-08 14:53

Dear BugMaster,

Branch CR24639_6 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 491d1b6b2b8af4473dee42d26af3b1adeef779d2

Number of compiler warnings:

occt component :
Linux: 18 (18 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
http://occt-tests/CR24639-6-master-occt/Windows-32-VC9/bugs/modalg_5/bug24359.html [^]
bugs modalg_5(010) bug24359: FAILED

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 362555424 / 355559436
Total CPU difference: 56447.93999999977 / 52140.73999999994

Testing on Windows:
Total MEMORY difference: 383657992 / 380240312
Total CPU difference: 52140.03125 / 37718.5

There are no differences in images found by testdiff.
(0032138)
ifv (developer)
2014-09-25 13:55

This issue can be closed because task "Parallelization FillDS part of BO" is finished.
Branches CR24639_6 and CR24639_8 can be abandoned.
(0032139)
ifv (developer)
2014-09-25 13:56

Please close this issue
(0032393)
git (administrator)
2014-09-30 11:35

Branch CR24639_6 has been deleted by inv.

SHA-1: 491d1b6b2b8af4473dee42d26af3b1adeef779d2
(0032394)
git (administrator)
2014-09-30 11:35

Branch CR24639_8 has been deleted by inv.

SHA-1: d73b06aebf2193746b9e86b778e6319625c4981a

- Related Changesets
occt: master a942f2da
Timestamp: 2014-03-06 11:05:58
Author: abv
Committer: abv
Details ] Diff ]
0024639: Parallelization FillDS part of BO

Edge/Edge Interferences

Changes:
1. class BOPAlgo_PaveFiller
  - method:
void BOPAlgo_PaveFiller::PerformEE()
the chages provides the parallel computations of
Edge/Edge interferences.

   - auxiliary classes:
    BOPAlgo_EdgeEdge
    BOPAlgo_EdgeEdgeFunctor
    BOPAlgo_EdgeEdgeCnt
have been added.
The classes are auxiliary classes to provide the parallel computations
of Edge/Edge interferences.

2. class BOPTest
-method:
void BOPTest::PartitionCommands(Draw_Interpretor& theCommands)
- static function:
Standard_Integer bfillds(Draw_Interpretor& di,
                         Standard_Integer n,
                         const char** a)
The syntax of the command "bfillds" has been changed.
> bfillds [-s -t]
options:
-s - launch the algorithm in sequential mode
-t - display CPU time

Test case for issue CR24639
mod - src/BOPAlgo/BOPAlgo_PaveFiller_3.cxx Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_PaveFiller_6.cxx Diff ] File ]
mod - src/BOPTest/BOPTest_PartitionCommands.cxx Diff ] File ]
add - tests/bugs/modalg_5/bug24639 Diff ] File ]
occt: master 505abfb8
Timestamp: 2014-03-24 05:34:34
Author: pkv
Committer: bugmaster
Details ] Diff ]
0024639: Parallelization FillDS part of BO

Modifications to avoid compilation errors
mod - src/BOPAlgo/BOPAlgo_PaveFiller.cdl Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_PaveFiller_2.cxx Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_PaveFiller_3.cxx Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_PaveFiller_7.cxx Diff ] File ]
add - src/BOPAlgo/BOPAlgo_PaveFiller_9.cxx Diff ] File ]
mod - src/BOPAlgo/FILES Diff ] File ]
mod - src/BOPCol/BOPCol_TBB.hxx Diff ] File ]
mod - src/BOPInt/BOPInt_ShrunkRange.cdl Diff ] File ]
mod - src/BOPInt/BOPInt_ShrunkRange.cxx Diff ] File ]
mod - src/BOPTools/BOPTools_AlgoTools.cxx Diff ] File ]
mod - src/BOPTools/BOPTools_AlgoTools_2.cxx Diff ] File ]
occt: master a0a3f6ac
Timestamp: 2014-04-01 03:19:18
Author: pkv
Committer: apn
Details ] Diff ]
0024639: Parallelization FillDS part of BO

The contents dealing with the parallel computation of Vertex/Face interferences.
mod - src/BOPAlgo/BOPAlgo_Builder.cdl Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_Builder_2.cxx Diff ] File ]
rm - src/BOPAlgo/BOPAlgo_Builder_2Cnt.hxx Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_Builder_3.cxx Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_PaveFiller_4.cxx Diff ] File ]
mod - src/BOPAlgo/FILES Diff ] File ]
occt: master e30616a7
Timestamp: 2014-04-08 08:22:16
Author: pkv
Committer: apn
Details ] Diff ]
0024639: Parallelization FillDS part of BO

The contents dealing with the parallel computation of Vertex/Face interferences.
mod - src/BOPAlgo/BOPAlgo_PaveFiller_5.cxx Diff ] File ]
mod - src/IntTools/IntTools_EdgeFace.cdl Diff ] File ]
mod - src/IntTools/IntTools_EdgeFace.cxx Diff ] File ]
occt: master a2098360
Timestamp: 2014-04-15 03:19:00
Author: pkv
Committer: apn
Details ] Diff ]
0024639: Parallelization FillDS part of BO

The contents dealing with:
Parallel computation of Face/Face interferences;
Parallel computation of Edge/Edge interferences (Post-Treatment Level);
Parallel intersection of bounding boxes (BOPDS_Iterator Level).
mod - src/BOPAlgo/BOPAlgo_PaveFiller.cxx Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_PaveFiller_3.cxx Diff ] File ]
mod - src/BOPAlgo/BOPAlgo_PaveFiller_6.cxx Diff ] File ]
mod - src/BOPDS/BOPDS_Iterator.cdl Diff ] File ]
mod - src/BOPDS/BOPDS_Iterator.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-02-18 16:14 ifv New Issue
2014-02-18 16:14 ifv Assigned To => ifv
2014-02-20 11:37 ifv Assigned To ifv => pkv
2014-02-20 11:37 ifv Status new => assigned
2014-02-20 16:49 abv Relationship added related to 0024157
2014-03-04 11:58 pkv Status assigned => resolved
2014-03-04 11:59 pkv Note Added: 0028116
2014-03-04 12:00 pkv Assigned To pkv => ifv
2014-03-04 12:13 pkv Steps to Reproduce Updated View Revisions
2014-03-04 12:15 pkv Note Edited: 0028116 View Revisions
2014-03-04 12:15 pkv File Added: zedges.tcl
2014-03-04 16:19 ifv Note Added: 0028129
2014-03-04 16:19 ifv Status resolved => reviewed
2014-03-04 17:18 mkv Assigned To ifv => mkv
2014-03-05 14:32 mkv Note Added: 0028149
2014-03-05 14:32 mkv Test case number => bugs modalg_5(010) bug24639
2014-03-05 14:32 mkv Assigned To mkv => bugmaster
2014-03-05 14:32 mkv Status reviewed => tested
2014-03-06 11:39 apn Product Version => 6.7.0
2014-03-06 11:39 apn Target Version => 6.7.1
2014-03-11 14:41 abv Changeset attached => occt master a942f2da
2014-03-11 14:41 abv Assigned To bugmaster => abv
2014-03-11 14:41 abv Status tested => verified
2014-03-11 14:41 abv Resolution open => fixed
2014-03-20 10:34 pkv Assigned To abv => pkv
2014-03-20 10:34 pkv Status verified => assigned
2014-03-20 10:34 pkv Status assigned => resolved
2014-03-20 10:37 pkv File Added: zve1.tcl
2014-03-20 10:40 pkv Note Added: 0028381
2014-03-20 10:40 pkv Assigned To pkv => ifv
2014-03-20 11:04 ifv Note Added: 0028382
2014-03-20 11:04 ifv Status resolved => reviewed
2014-03-20 14:57 mkv Assigned To ifv => mkv
2014-03-20 19:30 mkv Note Added: 0028411
2014-03-20 19:31 mkv Assigned To mkv => pkv
2014-03-20 19:31 mkv Status reviewed => assigned
2014-03-24 09:43 pkv Status assigned => resolved
2014-03-24 09:45 pkv Note Added: 0028436
2014-03-24 09:45 pkv Assigned To pkv => ifv
2014-03-25 11:08 ifv Note Added: 0028457
2014-03-25 11:08 ifv Status resolved => reviewed
2014-03-25 14:20 mkv Assigned To ifv => mkv
2014-03-26 13:04 mkv Note Added: 0028487
2014-03-26 13:07 mkv Note Edited: 0028487 View Revisions
2014-03-26 13:09 mkv Assigned To mkv => bugmaster
2014-03-26 13:09 mkv Status reviewed => tested
2014-03-28 16:38 bugmaster Changeset attached => occt master 505abfb8
2014-03-28 16:38 bugmaster Status tested => verified
2014-04-01 08:20 pkv Status verified => assigned
2014-04-01 08:20 pkv Assigned To bugmaster => pkv
2014-04-01 08:24 pkv File Added: zvf.tcl
2014-04-01 08:27 pkv Note Added: 0028572
2014-04-01 08:27 pkv Status assigned => resolved
2014-04-01 08:27 pkv Assigned To pkv => ifv
2014-04-01 09:47 ifv Note Added: 0028578
2014-04-01 09:47 ifv Status resolved => reviewed
2014-04-01 19:27 mkv Assigned To ifv => mkv
2014-04-02 11:14 mkv Note Added: 0028617
2014-04-02 11:15 mkv Assigned To mkv => bugmaster
2014-04-02 11:15 mkv Status reviewed => tested
2014-04-04 17:03 apn Changeset attached => occt master a0a3f6ac
2014-04-04 17:03 apn Assigned To bugmaster => apn
2014-04-04 17:03 apn Status tested => verified
2014-04-08 13:15 pkv Assigned To apn => pkv
2014-04-08 13:15 pkv Status verified => assigned
2014-04-08 13:16 pkv File Added: zef.tcl
2014-04-08 13:16 pkv Note Added: 0028731
2014-04-08 13:17 pkv Status assigned => resolved
2014-04-08 13:17 pkv Assigned To pkv => ifv
2014-04-08 13:18 pkv Note Edited: 0028731 View Revisions
2014-04-08 14:52 ifv Note Added: 0028741
2014-04-08 14:52 ifv Status resolved => reviewed
2014-04-08 16:03 apn Assigned To ifv => apn
2014-04-09 13:41 apn Note Added: 0028762
2014-04-09 13:41 apn Note Edited: 0028762 View Revisions
2014-04-09 13:41 apn Assigned To apn => bugmaster
2014-04-09 13:41 apn Status reviewed => tested
2014-04-09 16:50 abv Target Version 6.7.1 => 6.8.0
2014-04-11 14:43 apn Changeset attached => occt master e30616a7
2014-04-11 14:43 apn Assigned To bugmaster => apn
2014-04-11 14:43 apn Status tested => verified
2014-04-15 07:26 pkv Assigned To apn => pkv
2014-04-15 07:26 pkv Status verified => assigned
2014-04-15 07:27 pkv File Added: zff.tcl
2014-04-15 07:28 pkv Note Added: 0028831
2014-04-15 07:29 pkv Status assigned => resolved
2014-04-15 07:29 pkv Assigned To pkv => ifv
2014-04-15 13:23 ifv Note Added: 0028841
2014-04-15 13:23 ifv Status resolved => reviewed
2014-04-15 14:21 kgv Relationship added related to 0024826
2014-04-15 14:59 mkv Assigned To ifv => mkv
2014-04-16 19:09 mkv Note Added: 0028906
2014-04-16 19:10 mkv Assigned To mkv => bugmaster
2014-04-16 19:10 mkv Status reviewed => tested
2014-04-18 16:02 apn Changeset attached => occt master a2098360
2014-04-18 16:02 apn Assigned To bugmaster => apn
2014-04-18 16:02 apn Status tested => verified
2014-05-06 14:09 pkv Assigned To apn => pkv
2014-05-06 14:09 pkv Status verified => assigned
2014-05-06 14:10 pkv Note Added: 0029213
2014-05-06 14:11 pkv Status assigned => resolved
2014-05-06 14:11 pkv Assigned To pkv => ifv
2014-05-06 14:18 ifv Note Added: 0029214
2014-05-06 14:18 ifv Status resolved => reviewed
2014-05-07 05:58 pkv Assigned To ifv => mkv
2014-05-08 14:53 mkv Note Added: 0029256
2014-05-08 14:54 mkv Assigned To mkv => pkv
2014-05-08 14:54 mkv Status reviewed => assigned
2014-09-25 09:54 aml Relationship added related to 0025269
2014-09-25 13:55 ifv Note Added: 0032138
2014-09-25 13:55 ifv Assigned To pkv => ifv
2014-09-25 13:55 ifv Status assigned => resolved
2014-09-25 13:56 ifv Note Added: 0032139
2014-09-25 13:56 ifv Status resolved => reviewed
2014-09-25 14:27 apv Assigned To ifv => mkv
2014-09-25 14:59 abv Status reviewed => verified
2014-09-30 11:35 git Note Added: 0032393
2014-09-30 11:35 git Note Added: 0032394
2014-11-11 12:44 aiv Fixed in Version => 6.8.0
2014-11-11 12:58 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker