MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024577Open CASCADE[OCCT] OCCT:Visualizationpublic2014-01-28 11:552017-09-29 16:28
Reporterapl 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0024577: Duplicating local selection of AIS_Trihedron
DescriptionThe AIS_Trihedron provides local selection modes in form of sensitives: center point, axes, plane triangles. For each of the mode corresponding sensitive entities created by AIS_Trihedron. The highlighting is provided by individual IOs owned by the trihedron's presentation. When displayed, these IOs become activated in selector by AIS_InteractiveContext, providing their own sensitives. Thus, there is a duplication of sensitives between the ones created by AIS_Thrihedron and the presentation used for highlighting.

The effect is seen for plane selection mode (3), when the AIS_Trihedron provides sensitive triangles with interior selection, while the highlighting entities also provides sensitive triangles, but with boundaries selection.

The quickest solution is to avoid loading the highlight presentation into selector. Better solution for such cases is to inherit and write proper SelectMgr_EntityOwner with custom highlighting.

//=======================================================================
//function : ComputeSelection
//purpose :
//=======================================================================
void AIS_Trihedron::ComputeSelection(...)
{
  case 3:
  {
    ...
    if (!anAISContext.IsNull())
      for (anIdx = 4; anIdx < 7; anIdx++)
      {
        anAISContext->Display (myShapes[anIdx], 1, -1, Standard_False);
        anAISContext->ClearPrs (myShapes[anIdx], 1, Standard_False);
      }
  }
}
Steps To ReproduceN/A
TagsNo tags attached.
Test case number
Attached Files

- Relationships
related to 0027958closedbugmaster Open CASCADE Visualization, AIS_Trihedron - add shaded presentation option 

-  Notes
(0068158)
kgv (developer)
2017-07-10 13:58

I suppose that the issue should be fixed within patch for 0027958 - could you please confirm?
(0068242)
apl (developer)
2017-07-13 10:17

Yes, the AIS_Trihedron does not create anymore distinct interactive objects for highlighting and so the issue is solved.
(0068243)
kgv (developer)
2017-07-13 10:22

Dear bugmaster,

please switch bug into VERIFIED state.
Test case is not needed.

- Issue History
Date Modified Username Field Change
2014-01-28 11:55 apl New Issue
2014-01-28 11:55 apl Assigned To => apl
2014-01-28 11:56 apl Status new => assigned
2014-01-28 11:57 apl Relationship added related to 0024564
2014-04-04 18:16 abv Target Version 6.7.1 => 6.8.0
2014-10-17 10:38 kgv Target Version 6.8.0 => 7.1.0
2016-10-25 09:49 kgv Target Version 7.1.0 => 7.2.0
2017-07-10 13:58 kgv Relationship added related to 0027958
2017-07-10 13:58 kgv Note Added: 0068158
2017-07-10 13:58 kgv Status assigned => feedback
2017-07-13 10:17 apl Assigned To apl => kgv
2017-07-13 10:17 apl Status feedback => resolved
2017-07-13 10:17 apl Steps to Reproduce Updated View Revisions
2017-07-13 10:17 apl Note Added: 0068242
2017-07-13 10:17 apl Steps to Reproduce Updated View Revisions
2017-07-13 10:22 kgv Note Added: 0068243
2017-07-13 10:22 kgv Assigned To kgv => bugmaster
2017-07-13 10:22 kgv Status resolved => reviewed
2017-07-13 10:22 kgv Steps to Reproduce Updated View Revisions
2017-07-13 11:05 bugmaster Status reviewed => verified
2017-07-13 11:05 bugmaster Resolution open => fixed
2017-09-29 16:18 aiv Fixed in Version => 7.2.0
2017-09-29 16:28 aiv Status verified => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker