MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024553Open CASCADE[OCCT] OCCT:Codingpublic2014-01-22 14:372016-12-09 16:37
Reporterdln 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0024553: Deleting obsolete/unused ".gxx" files from "GCPnts"
DescriptionFrom "GCPnts" next ".gxx" files were removed:

 - GCPnts_AbscissaPoint.gxx
 - GCPnts_QuasiUniformAbscissa.gxx
 - GCPnts_QuasiUniformDeflection.gxx
 - GCPnts_TangentialDeflection.gxx
 - GCPnts_UniformAbscissa.gxx
 - GCPnts_UniformDeflection.gxx

Because their ".cxx" analogues are already exist.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0024487closedabv Getting rid of generic CDL classes 

-  Notes
(0027600)
dln (developer)
2014-01-22 14:47

Changes are ready for review in CR24553 branch.
(0027603)
abv (manager)
2014-01-22 15:53

No remarks, please test
(0027605)
abv (manager)
2014-01-22 16:06

Wrong: these GXX files are used inside CXX files of the same package. That is, they cannot be simply removed.
(0028792)
dln (developer)
2014-04-11 12:53

Changes are ready for review in CR24553 branch.

What were done:

Next classes were converted to the template classes:

1) "GCPnts_QuasiUniformAbscissa"
2) "GCPnts_UniformAbscissa"
3) "GCPnts_AbscissaPoint"
4) "GCPnts_UniformDeflection"
5) "GCPnts_QuasiUniformDeflection"

And "GCPnts_TangentialDeflection" class was simplified to work only with 3D case. Also other changes were made in the other packages for correct compilation of the application.
(0055129)
git (administrator)
2016-06-17 11:36

Branch CR24553_1 has been created by abv.

SHA-1: d248e10f99aa3e378337dd103f5dee853ea9b4b4


Detailed log of new commits:

Author: abv
Date: Fri Jun 17 11:36:49 2016 +0300

    0024553: Deleting obsolete/unused ".gxx" files from "GCPnts"
    
    Extension of files GXX is changed to "pxx" to avoid them to be copied to inc folder.
    Code of inline functions contained in LXX files is merged to HXX files, LXX files are removed.
(0055130)
abv (manager)
2016-06-17 11:41

There seem to be no good reason in conversing GXX files in GCPnts package to plain C++ templates. These files define "generic" code for implementation of methods of the package, each of them is included twice by corresponding CXX file to generate code for 3d and 2d curves.

Conversion of these files to true templates is troublesome due to need to specify multiple arguments of the template. In the version contained in branch CR24553, this makes their use really tricky. Providing more elaborate version seems to not make much sense since these templates are intended only for two variants (2d and 3d), and current implementation looks reasonable in this context.

Branch CR24553_1 simply renames these GXX files to PXX, so that they will not be copied to inc folder. Also, LXX files are removed (merged to HXX).

Please review.
(0055197)
ifv (developer)
2016-06-17 15:29

Seems to be OK
(0055238)
mkv (tester)
2016-06-20 16:21

Dear BugMaster,
Branch CR24553_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: d248e10f99aa3e378337dd103f5dee853ea9b4b4

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 68 (68 on master)
Windows: 0 (0 on master)
MacOS : 1131

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 88745859 / 89153373 [-0.46%]
Total CPU difference: 19442.099999999937 / 19458.53999999997 [-0.08%]
products component :
Total MEMORY difference: 27241597 / 27412842 [-0.62%]
Total CPU difference: 5175.419999999984 / 5165.429999999985 [+0.19%]

Testing on Windows:
occt component :
Total MEMORY difference: 55900121 / 55903796 [-0.01%]
Total CPU difference: 18409.834010998835 / 18535.758018198954 [-0.68%]
products component :
Total MEMORY difference: 18650165 / 18614185 [+0.19%]
Total CPU difference: 5012.93613399995 / 4998.802443399952 [+0.28%]

There are no differences in images found by testdiff.
(0055239)
mkv (tester)
2016-06-20 16:22

Dear BugMaster,
Branch CR24553_1 is TESTED.
(0055428)
git (administrator)
2016-06-24 12:58

Branch CR24553_1 has been deleted by inv.

SHA-1: d248e10f99aa3e378337dd103f5dee853ea9b4b4
(0055438)
git (administrator)
2016-06-24 12:58

Branch CR24553 has been deleted by inv.

SHA-1: 2af37d711e97af58c15e0ee197e15b834dc5aa91

- Related Changesets
occt: master 9bf3ef83
Timestamp: 2016-06-17 08:36:49
Author: abv
Committer: bugmaster
Details ] Diff ]
0024553: Deleting obsolete/unused ".gxx" files from "GCPnts"

Extension of files GXX is changed to "pxx" to avoid them to be copied to inc folder.
Code of inline functions contained in LXX files is merged to HXX files, LXX files are removed.
mod - src/GCPnts/FILES Diff ] File ]
mod - src/GCPnts/GCPnts_AbscissaPoint.cxx Diff ] File ]
mod - src/GCPnts/GCPnts_AbscissaPoint.hxx Diff ] File ]
rm - src/GCPnts/GCPnts_AbscissaPoint.lxx Diff ] File ]
mod - src/GCPnts/GCPnts_QuasiUniformAbscissa.cxx Diff ] File ]
mod - src/GCPnts/GCPnts_QuasiUniformAbscissa.hxx Diff ] File ]
rm - src/GCPnts/GCPnts_QuasiUniformAbscissa.lxx Diff ] File ]
mod - src/GCPnts/GCPnts_QuasiUniformDeflection.cxx Diff ] File ]
mod - src/GCPnts/GCPnts_QuasiUniformDeflection.hxx Diff ] File ]
rm - src/GCPnts/GCPnts_QuasiUniformDeflection.lxx Diff ] File ]
mod - src/GCPnts/GCPnts_TangentialDeflection.cxx Diff ] File ]
mod - src/GCPnts/GCPnts_TangentialDeflection.hxx Diff ] File ]
rm - src/GCPnts/GCPnts_TangentialDeflection.lxx Diff ] File ]
mod - src/GCPnts/GCPnts_UniformAbscissa.cxx Diff ] File ]
mod - src/GCPnts/GCPnts_UniformAbscissa.hxx Diff ] File ]
rm - src/GCPnts/GCPnts_UniformAbscissa.lxx Diff ] File ]
mod - src/GCPnts/GCPnts_UniformDeflection.cxx Diff ] File ]
mod - src/GCPnts/GCPnts_UniformDeflection.hxx Diff ] File ]
rm - src/GCPnts/GCPnts_UniformDeflection.lxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-01-22 14:37 dln New Issue
2014-01-22 14:37 dln Assigned To => abv
2014-01-22 14:47 dln Note Added: 0027600
2014-01-22 14:50 dln Status new => resolved
2014-01-22 14:55 dln Relationship added child of 0024487
2014-01-22 15:53 abv Note Added: 0027603
2014-01-22 15:53 abv Assigned To abv => bugmaster
2014-01-22 15:53 abv Status resolved => reviewed
2014-01-22 16:06 abv Note Added: 0027605
2014-01-22 16:06 abv Assigned To bugmaster => dln
2014-01-22 16:06 abv Status reviewed => assigned
2014-04-04 18:16 abv Target Version 6.7.1 => 6.8.0
2014-04-11 12:53 dln Note Added: 0028792
2014-04-11 12:53 dln Assigned To dln => abv
2014-04-11 12:53 dln Status assigned => resolved
2014-09-11 10:49 abv Target Version 6.8.0 => 7.0.0
2015-12-14 22:39 abv Target Version 7.0.0 => 7.1.0
2016-06-17 11:36 git Note Added: 0055129
2016-06-17 11:41 abv Note Added: 0055130
2016-06-17 11:41 abv Assigned To abv => ifv
2016-06-17 15:29 ifv Note Added: 0055197
2016-06-17 15:29 ifv Assigned To ifv => bugmaster
2016-06-17 15:29 ifv Status resolved => reviewed
2016-06-17 16:42 mkv Assigned To bugmaster => mkv
2016-06-20 16:21 mkv Note Added: 0055238
2016-06-20 16:22 mkv Note Added: 0055239
2016-06-20 16:22 mkv Assigned To mkv => bugmaster
2016-06-20 16:22 mkv Status reviewed => tested
2016-06-20 16:22 mkv Test case number => Not needed
2016-06-24 12:41 bugmaster Changeset attached => occt master 9bf3ef83
2016-06-24 12:41 bugmaster Status tested => verified
2016-06-24 12:41 bugmaster Resolution open => fixed
2016-06-24 12:58 git Note Added: 0055428
2016-06-24 12:58 git Note Added: 0055438
2016-12-09 16:31 user533 Status verified => closed
2016-12-09 16:37 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker