MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024530Open CASCADE[OCCT] OCCT:Meshpublic2014-01-15 10:372014-05-05 13:38
Reporterabv 
Assigned Toapn 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 6.7.1Fixed in Version[OCCT] 6.7.1 
Summary0024530: TKMesh - remove unused package IntPoly
DescriptionPackage IntPoly (included in TKMesh toolkit) seems to be never used and looks meaningless. Its purpose seems to be building intersection of two shapes or shape and plane using shape triangulation, which is likely available in other places. The code had no changes since its creation in 1995. I propose it should be removed.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0027486)
abv (manager)
2014-01-15 10:38

Igor, please give your opinion on this (do you know if any project used this package?)
(0027488)
ifv (developer)
2014-01-15 11:02

I know nothing about using IntPoly in any projects, but as far as I know similar functionality - intersection of triangulations - sometimes is requested.
If we have similar functionality, may be it is worth to update package by new algorithms?
(0027495)
szv (manager)
2014-01-15 14:14

This functionality is repeated in OMF:
IntPoly_PlaneSection => OMFAlgo_PlaneIntersect
IntPoly_ShapeSection => OMFAlgo_MeshIntersect

IntPoly works with Poly_Triangulation, OMFAlgo works with OMFDS_Mesh.

I do not think that maintaining both is a good idea.
Since at least OMFAlgo_MeshIntersect is used by OMF Boolean Operations, it follows that IntPoly package could be removed.
(0027496)
ifv (developer)
2014-01-15 14:25

I agree with SZV
(0027870)
aml (developer)
2014-02-13 09:02

DC,

This package used in MeshTest/MeshTest.cxx file. If we want to use OMFAlgo instead of IntPoly, it should be included in OCCT deployment, but now i can't find it.
(0027871)
abv (manager)
2014-02-13 09:07

MeshTest is just a test tool for OCCT; testing useless functionality is senseless thus relevant commands from MeshTest should be simply removed. Please check if these commands are used in some tests.
(0027872)
aml (developer)
2014-02-13 09:47

Relevant commands not used in tests. Since that, branch CR24530 ready for review.
(0027873)
ifv (developer)
2014-02-13 10:51

OK
(0027877)
kgv (developer)
2014-02-13 11:54

Dear aml,

the first commit in patch should start from bug title "0024530: TKMesh - remove unused package IntPoly".

It is not enough to remove files in IntPoly folder - all references should be cleaned up as well, including src/TKMesh/PACKAGES and adm/UDLIST.

Please proceed.
(0027882)
aml (developer)
2014-02-13 12:38

Dear ifv,
Please review branch CR24530.
(0027885)
ifv (developer)
2014-02-13 13:15

Ok
(0027903)
mkv (tester)
2014-02-14 16:18

Dear BugMaster,

Branch CR24530 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 56c4cf82f1165202340953ec1d0e7bc5dfd8834e

Number of compiler warnings:

occt component :
Linux: 40 (40 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 380390912 / 381831144
Total CPU difference: 57369.31999999954 / 42213.76

Testing on Windows:
Total MEMORY difference: 428621768 / 431123492
Total CPU difference: 34287.90625 / 34130.65625

There are not differences in images found by testdiff.

- Related Changesets
occt: master 9bd37e12
Timestamp: 2014-02-13 05:39:50
Author: aml
Committer: apn
Details ] Diff ]
0024530: TKMesh - remove unused package IntPoly

Deletion of package IntPoly.
mod - adm/UDLIST Diff ] File ]
rm - src/IntPoly/IntPoly.cdl Diff ] File ]
rm - src/IntPoly/IntPoly_PlaneSection.cdl Diff ] File ]
rm - src/IntPoly/IntPoly_PlaneSection.cxx Diff ] File ]
rm - src/IntPoly/IntPoly_Pnt2dHasher.cdl Diff ] File ]
rm - src/IntPoly/IntPoly_Pnt2dHasher.cxx Diff ] File ]
rm - src/IntPoly/IntPoly_Pnt2dHasher.lxx Diff ] File ]
rm - src/IntPoly/IntPoly_PntHasher.cdl Diff ] File ]
rm - src/IntPoly/IntPoly_PntHasher.cxx Diff ] File ]
rm - src/IntPoly/IntPoly_PntHasher.lxx Diff ] File ]
rm - src/IntPoly/IntPoly_ShapeSection.cdl Diff ] File ]
rm - src/IntPoly/IntPoly_ShapeSection.cxx Diff ] File ]
mod - src/MeshTest/MeshTest.cxx Diff ] File ]
mod - src/TKMesh/PACKAGES Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-01-15 10:37 abv New Issue
2014-01-15 10:37 abv Assigned To => oan
2014-01-15 10:38 abv Note Added: 0027486
2014-01-15 10:38 abv Assigned To oan => ifv
2014-01-15 10:38 abv Status new => feedback
2014-01-15 11:02 ifv Note Added: 0027488
2014-01-15 14:14 szv Note Added: 0027495
2014-01-15 14:25 ifv Note Added: 0027496
2014-02-10 14:22 ifv Assigned To ifv => aml
2014-02-13 09:02 aml Note Added: 0027870
2014-02-13 09:02 aml Assigned To aml => ifv
2014-02-13 09:07 abv Note Added: 0027871
2014-02-13 09:07 abv Assigned To ifv => aml
2014-02-13 09:07 abv Status feedback => assigned
2014-02-13 09:47 aml Note Added: 0027872
2014-02-13 09:48 aml Assigned To aml => ifv
2014-02-13 09:48 aml Status assigned => resolved
2014-02-13 10:51 ifv Note Added: 0027873
2014-02-13 10:51 ifv Status resolved => reviewed
2014-02-13 10:59 mkv Assigned To ifv => mkv
2014-02-13 11:51 kgv Severity just a question => integration request
2014-02-13 11:51 kgv Summary Remove package IntPoly? => TKMesh - remove unused package IntPoly
2014-02-13 11:54 kgv Note Added: 0027877
2014-02-13 11:54 kgv Assigned To mkv => apl
2014-02-13 11:54 kgv Status reviewed => assigned
2014-02-13 11:55 kgv Assigned To apl => aml
2014-02-13 12:38 aml Note Added: 0027882
2014-02-13 12:38 aml Assigned To aml => ifv
2014-02-13 12:38 aml Status assigned => resolved
2014-02-13 13:15 ifv Note Added: 0027885
2014-02-13 13:15 ifv Status resolved => reviewed
2014-02-13 17:12 mkv Assigned To ifv => mkv
2014-02-14 16:18 mkv Note Added: 0027903
2014-02-14 16:18 mkv Test case number => Not needed
2014-02-14 16:18 mkv Assigned To mkv => bugmaster
2014-02-14 16:18 mkv Status reviewed => tested
2014-02-24 12:44 apn Changeset attached => occt master 9bd37e12
2014-02-24 12:44 apn Assigned To bugmaster => apn
2014-02-24 12:44 apn Status tested => verified
2014-02-24 12:44 apn Resolution open => fixed
2014-05-05 13:34 aiv Status verified => closed
2014-05-05 13:38 aiv Fixed in Version => 6.7.1


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker