MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024459Open CASCADE[OCCT] OCCT:Visualizationpublic2013-12-12 12:482013-12-19 14:00
Reporterapn 
Assigned Toabv 
PriorityurgentSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2008OS Version32 bit
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 6.7.0Fixed in Version[OCCT] 6.7.0 
Summary0024459: Exception during clearing object in test case v3d/raytrace/connected in DEBUG mode
DescriptionException appears during clearing object when vraytrace 0 on Windows in DEBUG mode on current master CR670-IR-master-occt-deb.

Test case v3d/raytrace/connected:
box b1 0 0 0 1 2 3
box b2 3 0 0 3 2 1
vinit View1
vactivate Driver1/Viewer1/View1
vactivate: the view is active already

vactivate: the view is active already

vclear
vsetdispmode 1
vraytrace 0
vaxo
vconnectsh b1c -3 0 0 1 0 0 0 0 1 b1 b2
vfit
vrotate 0.2 0.0 0.0
vclear
Remove b1c
An exception was caught 0068052C : OSD_Exception_ACCESS_VIOLATION: ACCESS VIOLATION at address 0xDDDDDDE1 during 'READ' operation

** Exception ** 0068052C : OSD_Exception_ACCESS_VIOLATION: ACCESS VIOLATION at address 0xDDDDDDE1 during 'READ' operation
TagsNo tags attached.
Test case numberv3d raytrace connected
Attached Files

- Relationships

-  Notes
(0027196)
abv (manager)
2013-12-12 19:03

This problem is caused by fix of #24391
(0027197)
dbp (developer)
2013-12-12 19:23

Dear kgv,

please check bug fix in branch CR24459.
(0027201)
kgv (developer)
2013-12-13 10:23

Please test the patch.

- Related Changesets
occt: master 6bf1bdbd
Timestamp: 2013-12-12 15:22:02
Author: abv
Committer: abv
Details ] Diff ]
0024459: Exception during clearing object in test case v3d/raytrace/connected in DEBUG mode
mod - src/PrsMgr/PrsMgr_Presentation3d.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-12-12 12:48 apn New Issue
2013-12-12 12:48 apn Assigned To => san
2013-12-12 12:48 apn Test case number => v3d raytrace connected
2013-12-12 12:52 apn Relationship added related to 0024353
2013-12-12 12:52 apn Status new => assigned
2013-12-12 13:13 apn Product Version => 6.7.0
2013-12-12 14:14 san Assigned To san => duv
2013-12-12 14:15 san Priority normal => urgent
2013-12-12 19:03 abv Relationship added child of 0024391
2013-12-12 19:03 abv Note Added: 0027196
2013-12-12 19:23 dbp Note Added: 0027197
2013-12-12 19:23 dbp Assigned To duv => kgv
2013-12-12 19:23 dbp Status assigned => resolved
2013-12-13 10:23 kgv Note Added: 0027201
2013-12-13 10:23 kgv Assigned To kgv => bugmaster
2013-12-13 10:23 kgv Status resolved => reviewed
2013-12-13 14:09 abv Changeset attached => occt master 6bf1bdbd
2013-12-13 14:09 abv Assigned To bugmaster => abv
2013-12-13 14:09 abv Status reviewed => verified
2013-12-13 14:09 abv Resolution open => fixed
2013-12-13 14:10 bugmaster Target Version => 6.7.0
2013-12-19 13:50 bugmaster Status verified => closed
2013-12-19 14:00 bugmaster Fixed in Version => 6.7.0


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker