MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024319Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2013-11-05 15:182017-10-19 18:50
Reportervro 
Assigned Togka 
PrioritynormalSeverityminor 
StatusassignedResolutionopen 
PlatformWindowsOSVC++ 2010OS Version32 bit
Product Version[OCCT] 6.6.0 
Target VersionFixed in Version 
Summary0024319: Sewing makes a solid transparent
DescriptionA sewing operation (a call to BRepBuilderAPI_Sewing)makes transparent a set of faces read from an IGES file (see an attached picture).
Steps To Reproduceigesread Rohteil_Pmod.igs s
sewing r s
vinit
vdisplay s
TagsNo tags attached.
Test case numberbugs modalg_7 bug24319
Attached Fileszip file icon Rohteil_Pmod.zip (22,536 bytes) 2013-11-05 15:18
png file icon sewWrong.png (33,671 bytes) 2013-11-05 15:19
? file icon sewOK.bmp (544,414 bytes) 2013-11-21 12:56

- Relationships
related to 0024421newifv Sewing changes orientations of some subshapes. 

-  Notes
(0026820)
nbv (developer)
2013-11-21 13:02

Dear Vladislav.

In sewOK.bmp attached file there is shape, which is got from current master. I think, it is OK.

Check it, please?

P.S.
Script:

igesread Rohteil_Pmod.igs s *
sewing r s
vinit
vdisplay s
vsetdispmode 1
(0026822)
nbv (developer)
2013-11-21 13:26

Sorry. Script is wrong.

In correct script it is necessary to write
   vdisplay r
(not s).
(0026987)
nbv (developer)
2013-11-28 17:55

Following fix can be used for correct drawing:

igesread Rohteil_Pmod.igs s *
sewing r s -c
vinit
vdisplay s
vsetdispmode 1

"-c" option switches off "Cutting mode".
(0027009)
nbv (developer)
2013-11-29 17:47

Dear vro!

Try to use above described workaround. Sewing works incorrect in this case.
(0027017)
vro (developer)
2013-12-02 08:15

Ok, thank you!
(0027018)
nbv (developer)
2013-12-02 09:17

No code changes required.
(0027020)
ifv (developer)
2013-12-02 10:03

Dear Bugmaster
please close this issue.
(0027026)
abv (manager)
2013-12-02 11:09

The problem is not solved, so there is no reason to close the issue.
The proposed "work-around" just avoids a problem on this particular case; as far as I can see no analysis has been done to understand the real cause of the bug.

It might be also useful to improve sewing so as to create solids from closed shells and orient them consistently (perhaps by option), so that they can be used without additional post-processing.
(0027027)
ifv (developer)
2013-12-02 11:17

Now there is issue 24421, which is directly dedicated to the corresponding problem of sewing algorithm.
(0027028)
nbv (developer)
2013-12-02 11:23

I agree, that the problem is not solved. "Sewing works incorrect in this case." (see http://tracker.dev.opencascade.org/view.php?id=24319#c27009 [^]). In related bug 0024421 I have tried to represent problem more restrictedly.

I think, problem is in bad orientation.

Therefore, this bug can be closed, in my opinion, if vro agrees to use workaround. But Sewing's problem should be solved. That's right.
(0071650)
mkv (tester)
2017-10-19 18:50

Not reproduced on the current master.

- Issue History
Date Modified Username Field Change
2013-11-05 15:18 vro New Issue
2013-11-05 15:18 vro Assigned To => ifv
2013-11-05 15:18 vro File Added: Rohteil_Pmod.zip
2013-11-05 15:19 vro File Added: sewWrong.png
2013-11-21 12:05 ifv Assigned To ifv => nbv
2013-11-21 12:05 ifv Status new => assigned
2013-11-21 12:56 nbv File Added: sewOK.bmp
2013-11-21 13:02 nbv Note Added: 0026820
2013-11-21 13:02 nbv Assigned To nbv => vro
2013-11-21 13:02 nbv Status assigned => feedback
2013-11-21 13:26 nbv Note Added: 0026822
2013-11-21 13:26 nbv Assigned To vro => nbv
2013-11-21 13:26 nbv Status feedback => assigned
2013-11-28 17:55 nbv Note Added: 0026987
2013-11-29 17:43 nbv Relationship added related to 0024421
2013-11-29 17:47 nbv Note Added: 0027009
2013-11-29 17:47 nbv Assigned To nbv => vro
2013-11-29 17:47 nbv Status assigned => feedback
2013-12-02 08:15 vro Note Added: 0027017
2013-12-02 08:15 vro Status feedback => resolved
2013-12-02 09:16 nbv Assigned To vro => ifv
2013-12-02 09:17 nbv Note Added: 0027018
2013-12-02 10:03 ifv Note Added: 0027020
2013-12-02 10:03 ifv Status resolved => reviewed
2013-12-02 10:08 mkv Assigned To ifv => bugmaster
2013-12-02 10:08 mkv Status reviewed => tested
2013-12-02 10:09 mkv Status tested => feedback
2013-12-02 11:09 abv Note Added: 0027026
2013-12-02 11:09 abv Assigned To bugmaster => gka
2013-12-02 11:09 abv Status feedback => assigned
2013-12-02 11:17 ifv Note Added: 0027027
2013-12-02 11:23 nbv Note Added: 0027028
2017-10-19 18:50 mkv Test case number => bugs modalg_7 bug24319
2017-10-19 18:50 mkv Note Added: 0071650


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker