MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024299Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2013-10-30 16:442014-02-06 11:14
Reporteremv 
Assigned Toemv 
PrioritynormalSeverityminor 
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version[OCCT] 6.6.0 
Target Version[OCCT] 6.7.1Fixed in Version[OCCT] 6.7.1 
Summary0024299: Wrong section curve
DescriptionThe intersection algorithm produces wrong section curve.

The problem has been detected in the test case bugs modalg_4 pro19653.
Steps To Reproducerestore [locate_data_file pro19653a.brep] b1
restore [locate_data_file pro19653b.brep] b2
explode b1 f
explode b2 f
mksurface s1 b1_1
mksurface s2 b2_1
intersect i s1 s2
# four curves created, but i_2 is not valid
xdistcs i_2 s1 0 1 10
# T=0. D=5.11591e-013
# T=0.111111 D=7.19085e-005
# T=0.222222 D=0.000121097
# T=0.333333 D=0.000149614
# T=0.444444 D=0.000159502
# T=0.555556 D=0.000152787
# T=0.666667 D=0.000131486
# T=0.777778 D=9.76002e-005
# T=0.888889 D=5.31176e-005
# T=1. D=3.76033e-008


TagsNo tags attached.
Test case numberbugs modalg_4(009) bug24299
Attached Files

- Relationships
related to 0024418assignedmsv Open CASCADE Modeling Algorithms - Wrong section curves when intersecting analytical surfaces 

-  Notes
(0027700)
nbv (developer)
2014-01-30 09:42

Dear Eugeny.

Please check, if branch CR24472 returns correct intersection line? If "YES", then bug can be considered as "Resolved".
(0027707)
emv (developer)
2014-01-30 17:50

The result seems to be correct.
(0027711)
nbv (developer)
2014-01-31 09:23
edited on: 2014-01-31 10:17

Dear Igor.

Please review branch CR24472. See http://tracker.dev.opencascade.org/view.php?id=24472#c27710 [^] before.

(0027713)
ifv (developer)
2014-01-31 11:24

Bad formatting of file IntPatch_PrmPrmIntersection.cxx
(0027716)
ifv (developer)
2014-01-31 11:31

Ok
(0027717)
nbv (developer)
2014-01-31 11:35
edited on: 2014-01-31 11:36

Corrected.

If all is OK, I set "duplicate of bug#24472". Test for this bug should be attached to CR24472 branch (for bug #24472). And no code change required.

(0027799)
apn (administrator)
2014-02-06 11:13

Closed as duplicate of CR24472. Test case bugs modalg_4(009) bug24299 is in branch CR24472.

- Issue History
Date Modified Username Field Change
2013-10-30 16:44 emv New Issue
2013-10-30 16:44 emv Assigned To => ifv
2013-11-14 16:18 ifv Assigned To ifv => nbv
2013-11-14 16:18 ifv Status new => assigned
2013-11-29 11:28 emv Relationship added related to 0024418
2014-01-29 17:17 nbv Relationship added related to 0024472
2014-01-30 09:42 nbv Note Added: 0027700
2014-01-30 09:42 nbv Assigned To nbv => emv
2014-01-30 09:42 nbv Status assigned => feedback
2014-01-30 17:50 emv Note Added: 0027707
2014-01-30 17:50 emv Assigned To emv => nbv
2014-01-30 17:50 emv Status feedback => resolved
2014-01-31 09:23 nbv Note Added: 0027711
2014-01-31 09:24 nbv Assigned To nbv => ifv
2014-01-31 10:17 nbv Note Edited: 0027711 View Revisions
2014-01-31 11:24 ifv Note Added: 0027713
2014-01-31 11:24 ifv Assigned To ifv => nbv
2014-01-31 11:24 ifv Status resolved => feedback
2014-01-31 11:29 nbv Assigned To nbv => ifv
2014-01-31 11:29 nbv Status feedback => resolved
2014-01-31 11:31 ifv Note Added: 0027716
2014-01-31 11:31 ifv Status resolved => reviewed
2014-01-31 11:35 nbv Note Added: 0027717
2014-01-31 11:35 nbv Relationship replaced duplicate of 0024472
2014-01-31 11:36 nbv Note Edited: 0027717 View Revisions
2014-01-31 11:56 mkv Assigned To ifv => mkv
2014-02-03 14:45 mkv Status reviewed => tested
2014-02-03 14:47 mkv Assigned To mkv => bugmaster
2014-02-04 17:10 mkv Test case number => bugs modalg_45(009) bug24299
2014-02-04 17:10 mkv Test case number bugs modalg_45(009) bug24299 => bugs modalg_4(009) bug24299
2014-02-05 12:53 abv Target Version => 6.7.1
2014-02-06 11:13 apn Note Added: 0027799
2014-02-06 11:14 apn Assigned To bugmaster => emv
2014-02-06 11:14 apn Status tested => closed
2014-02-06 11:14 apn Resolution open => duplicate
2014-02-06 11:14 apn Fixed in Version => 6.7.1


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker