MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024203Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2013-09-24 18:372014-05-05 13:37
Reportergka 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.6.0 
Target Version[OCCT] 6.7.1Fixed in Version[OCCT] 6.7.1 
Summary0024203: Command "sameparameter" in DRAW on attached edge set tolerance equal to 116.
DescriptionCommand "sameparameter" in DRAW on attached edge set tolerance equal to 116.
Steps To ReproduceDraw[31]> restore notspedge.brep e1
e1
Draw[32]> toler e1
Tolerance MAX=0.0047612081643267894 AVG=0.0030832977751849961 MIN=1.00000000000000
01e-005
FACE : MAX=0 AVG=0 MIN=0
EDGE : MAX=1.0000000000000001e-005 AVG=1.0000000000000001e-005 MIN=1.0000000000
000001e-005
VERTEX : MAX=0.0047612081643267894 AVG=0.0046199466627774941 MIN=0.00447868516122
81997

Draw[33]> samepar e1
Draw[34]> toler e1
Tolerance MAX=116.18676595408206 AVG=116.18676595408205 MIN=116.18676595408203
FACE : MAX=0 AVG=0 MIN=0
EDGE : MAX=116.18676595408203 AVG=116.18676595408203 MIN=116.18676595408203
VERTEX : MAX=116.18676595408206 AVG=116.18676595408206 MIN=116.18676595408206
TagsNo tags attached.
Test case numberbugs modalg_5(010) bug24203
Attached Files? file icon notspedge.brep (36,918 bytes) 2013-09-24 18:37

- Relationships
related to 0024174closedbugmaster Community [regression] BRepBuilderAPI_Sewing returns result with very high tolerance 

-  Notes
(0027213)
ifv (developer)
2013-12-13 17:26

attached edge has two pcurves for two different surfaces:
TShape # 1 : EDGE 1101000 04DDFD30
    +3 -2
    Tolerance : 1e-005
    - Curve 3D : 1, range : 0 1
    - PCurve : 1 on surface 1, range : 0 1
  UV Points : 0.375079880811, 1.52240782033 0.420358757176, 0.754028389245
    - PCurve : 2 on surface 2, range : 0 1
  UV Points : 1, 4.48241175 1, 1.467509658

pcurve 1 on surface 1 is "good" and has distance from 3d curve inside edge tolerance.
But pcurve 2 on surface 2 has huge distance from 3d curve. It can be illustrated by command computetolerance, which calculates real distances between 3d and 2d curves:

Draw[33]> computetolerance s
Tolerance de 04DDFD30 : 81.3307

Command sameparameter calculate real distance between 3d and all 2d curves (and increases them a bit), so 116 it is almost correct tolerance for this edge, if we take in account all pcurves on all surfaces.
(0027436)
nbv (developer)
2014-01-10 17:39

CR24203 is ready to review
(0027437)
nbv (developer)
2014-01-10 17:43

New result:

Draw[]> restore notspedge.brep e1
Draw[]> samepar e1
Draw[]> toler e1
Tolerance MAX=2.2681431145180113 AVG=2.2681431145180109 MIN=2.2681431145180104
FACE : MAX=0 AVG=0 MIN=0
EDGE : MAX=2.2681431145180104 AVG=2.2681431145180104 MIN=2.2681431145180104
VERTEX : MAX=2.2681431145180113 AVG=2.2681431145180113 MIN=2.2681431145180113
(0027438)
ifv (developer)
2014-01-10 18:27

Ok
(0027456)
mkv (tester)
2014-01-14 08:58

Dear BugMaster,

Branch CR24203 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 9f0aac8f469dfa8fdcfe5ad74eadf715d20aca51

Number of compiler warnings:

occt component :
Linux: 55 (55 on master)
Windows: 1 (1 on master)

products component :
Linux: 20 (20 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24203-master-occt/Windows-32-VC9/bugs/modalg_5/bug24203.html [^]
http://occt-tests/CR24203-master-occt/Debian60-64/bugs/modalg_5/bug24203.html [^]
bugs modalg_5(010) bug24203: OK

Testing on Linux:
Total MEMORY difference: 358054052 / 357072508
Total CPU difference: 43353.09000000021 / 42990.139999999854

Testing on Windows:
Total MEMORY difference: 413550920 / 412488216
Total CPU difference: 31122.65625 / 32601.78125

There are not differences in images found by testdiff.
(0027499)
nbv (developer)
2014-01-15 15:41

In new branch CR24203_1 resulting maximal tolerance of given edge is reduced to 0.19499639548485131.

Dear Igor. Please review it.
(0027500)
ifv (developer)
2014-01-15 15:49

Ok
(0027509)
mkv (tester)
2014-01-16 10:04

Dear BugMaster,

Branch CR24203_1 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: f5df7c3ee59ba3e4490f963204dbcb2b9b3f165b

Number of compiler warnings:

occt component :
Linux: 55 (55 on master)
Windows: 1 (1 on master)

products component :
Linux: 20 (20 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24203-1-master-occt/Debian60-64/bugs/modalg_5/bug24203.html [^]
http://occt-tests/CR24203-1-master-occt/Windows-32-VC9/bugs/modalg_5/bug24203.html [^]
bugs modalg_5(010) bug24203: OK

Testing on Linux:
Total MEMORY difference: 358040688 / 357015712
Total CPU difference: 44684.01000000037 / 42990.139999999854

Testing on Windows:
Total MEMORY difference: 413479364 / 412430976
Total CPU difference: 29576.15625 / 32600.859375

There are not differences in images found by testdiff.
(0027553)
mkv (tester)
2014-01-20 14:55

Dear BugMaster,

There is the message
Warning: ShapeFix_Edge: Exception in SameParameter
in follwing test cases for DEBUG mode

bugs step(014) bug24135
heal (013) V7 W9 ZA1
heal (015) U8 V3 V7 W9 ZA!
heal (017) U9 V3-V8 W4 W5 W8 W9 X1 Y4 Y5 Y8 Y9 Z1-Z4 Z8 Z9 ZA1 ZA5 ZB1 ZB5
(0027554)
nbv (developer)
2014-01-20 15:06

Dear Igor.

Please review Branch CR24203_2. Main changes in the file "Approx_SameParameter.cxx" and lines from 533 to 560.
(0027555)
ifv (developer)
2014-01-20 15:10

Ok
(0027647)
mkv (tester)
2014-01-27 11:47

Dear BugMaster,

Branch CR24203_2 (and products from GIT master) was compiled on Linux and Windows platforms and tested for OPTIMISE and DEBUG modes.
SHA-1: e64f29adfb6140e57f0b04156bf748ca8029c303

Number of compiler warnings:

occt component :
Linux: 48 (48 on master)
Windows: 1 (1 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24203-2-master-occt-deb/Debian60-64/bugs/modalg_5/bug24203.html [^]
http://occt-tests/CR24203-2-master-occt-deb/Windows-32-VC9/bugs/modalg_5/bug24203.html [^]
bugs modalg_5(010) bug24203: OK

Testing on Linux:
Total MEMORY difference: 372303980 / 366200776
Total CPU difference: 44281.76000000015 / 44011.91000000015

Testing on Windows:
Total MEMORY difference: 409319472 / 417207712
Total CPU difference: 33033.25 / 32470.0

There are not differences in images found by testdiff.

- Related Changesets
occt: master a86d3ec0
Timestamp: 2014-01-20 10:56:15
Author: nbv
Committer: bugmaster
Details ] Diff ]
0024203: Command "sameparameter" in DRAW on attached edge set tolerance equal to 116.

Main problem:
Algorithm of locale extrema, which is called by "sameparameter" command, cannot find extrema because extremal point is far from initial point. Therefore, reparametrization of edge's curve (for same-parameter) cannot be made properly.

Solve:
Using of global extrema (see Approx_SameParameter.cxx).

As the given edge contains two 2d-curves and the second from them is problem, for select needed curve, an interface of "mk2dcurve" DRAW-command is changed. Now there can be used an index of curve (by default, index = 1, as earlier), see help for more detail information.

Test "heal advanced Z3":
Now checkshape finds only two invalid subshapes. Earlier, it found four subshapes. I think it is not regression. Therefore, test case was changed.

Tolerance reducing.

test
mod - src/Approx/Approx_SameParameter.cxx Diff ] File ]
mod - src/BRepLib/BRepLib.cxx Diff ] File ]
mod - src/BRepTest/BRepTest_CurveCommands.cxx Diff ] File ]
mod - src/Extrema/Extrema_GLocateExtPC.gxx Diff ] File ]
add - tests/bugs/modalg_5/bug24203 Diff ] File ]
mod - tests/heal/data/advanced/Z3 Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-09-24 18:37 gka New Issue
2013-09-24 18:37 gka Assigned To => ifv
2013-09-24 18:37 gka File Added: notspedge.brep
2013-09-24 18:40 gka Relationship added related to 0024174
2013-12-13 17:26 ifv Note Added: 0027213
2013-12-13 17:26 ifv Assigned To ifv => gka
2013-12-13 17:26 ifv Status new => feedback
2014-01-09 10:21 ifv Assigned To gka => nbv
2014-01-09 10:21 ifv Status feedback => assigned
2014-01-10 17:39 nbv Note Added: 0027436
2014-01-10 17:39 nbv Assigned To nbv => ifv
2014-01-10 17:39 nbv Status assigned => resolved
2014-01-10 17:43 nbv Note Added: 0027437
2014-01-10 18:27 ifv Note Added: 0027438
2014-01-10 18:27 ifv Status resolved => reviewed
2014-01-13 14:34 mkv Assigned To ifv => mkv
2014-01-14 08:58 mkv Note Added: 0027456
2014-01-14 08:59 mkv Test case number => bugs modalg_5(010) bug24203
2014-01-14 08:59 mkv Assigned To mkv => bugmaster
2014-01-14 08:59 mkv Status reviewed => tested
2014-01-14 09:11 nbv Assigned To bugmaster => nbv
2014-01-14 09:11 nbv Status tested => feedback
2014-01-15 15:41 nbv Note Added: 0027499
2014-01-15 15:41 nbv Assigned To nbv => ifv
2014-01-15 15:41 nbv Status feedback => resolved
2014-01-15 15:49 ifv Note Added: 0027500
2014-01-15 15:49 ifv Status resolved => reviewed
2014-01-15 16:00 mkv Assigned To ifv => mkv
2014-01-16 10:04 mkv Note Added: 0027509
2014-01-16 10:05 mkv Assigned To mkv => bugmaster
2014-01-16 10:05 mkv Status reviewed => tested
2014-01-20 14:43 nbv Assigned To bugmaster => nbv
2014-01-20 14:43 nbv Status tested => assigned
2014-01-20 14:55 mkv Note Added: 0027553
2014-01-20 15:06 nbv Note Added: 0027554
2014-01-20 15:06 nbv Assigned To nbv => ifv
2014-01-20 15:06 nbv Status assigned => resolved
2014-01-20 15:10 ifv Note Added: 0027555
2014-01-20 15:10 ifv Status resolved => reviewed
2014-01-20 17:50 mkv Assigned To ifv => mkv
2014-01-27 11:47 mkv Note Added: 0027647
2014-01-27 11:48 mkv Assigned To mkv => bugmaster
2014-01-27 11:48 mkv Status reviewed => tested
2014-02-03 10:15 bugmaster Changeset attached => occt master a86d3ec0
2014-02-03 10:15 bugmaster Status tested => verified
2014-02-03 10:15 bugmaster Resolution open => fixed
2014-05-05 13:34 aiv Status verified => closed
2014-05-05 13:37 aiv Fixed in Version => 6.7.1


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker