MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024056Community[OCCT] OCCT:Modeling Algorithmspublic2013-07-02 21:302016-12-09 16:38
Reportermach22 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2012OS Version32bit
Product Version[OCCT] 6.6.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0024056: error LNK2019: unresolved external symbol
DescriptionTopOpeBRep_EdgesIntersector::Tolerance2(void)const

I have tried to use this method and I have the unresolved external symbol, from linking.
I have seen the TopOpeBRep_EdgesIntersector.hxx file where the Method Tolerance2() is defined but I can't find the implementation not in TopOpeBRep_EdgesIntersector.cxx, ixx, jxx or TopOpeBRep_EdgesIntersector_1.cxx

Is there a missing implementation for this method?
I have found some other similar cases, if is there a real problem with this method I can report these other cases.
Steps To Reproducetry calling the method

TopOpeBRep_EdgesIntersector edges;
double tol2 = edges.Tolerance2();
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0027688)
bugmaster (administrator)
2014-01-29 16:33

To reproduce problem creation of testing case is required
(0027842)
apn (administrator)
2014-02-11 16:31

Test case is not needed.
(0055734)
msv (developer)
2016-07-06 19:02

The classes TopOpeBRep* constitute the old set of Boolean operations that are not maintained in the current mainline.
Therefore in order to fix this bug it is needed simply to remove the method that has no implementation.
Dear Ilya, please take care of this.
(0055961)
git (administrator)
2016-07-15 18:09

Branch CR24056 has been created by isn.

SHA-1: 27746b4d2083836dbba4e672345deb86b6e0b88c


Detailed log of new commits:

Author: isn
Date: Fri Jul 15 17:39:25 2016 +0300

    0024056: error LNK2019: unresolved external symbol
    
    Clean out the TopOpeBRep* classes

Author: isn
Date: Thu Jul 14 17:17:22 2016 +0300

    remark

Author: isn
Date: Thu Jul 14 13:45:18 2016 +0300

    test cases

Author: isn
Date: Mon Jul 11 12:52:59 2016 +0300

    0027264: Weird difference between two BRepTools::Write() overloads
    
    Assume that the brep file contains DBRep_DrawableShape variable if the file header is absent
(0055966)
git (administrator)
2016-07-15 18:46

Branch CR24056_1 has been created by isn.

SHA-1: 3f6cc825d63f99a44124b41a1a4716ac8da4209e


Detailed log of new commits:

Author: isn
Date: Fri Jul 15 18:37:53 2016 +0300

    0024056: error LNK2019: unresolved external symbol
    
    Clean out the TopOpeBRep* classes
(0055967)
git (administrator)
2016-07-15 18:49

Branch CR24056 has been deleted by isn.

SHA-1: 27746b4d2083836dbba4e672345deb86b6e0b88c
(0055969)
isn (developer)
2016-07-15 19:01

i've removed some unimplemented functions from TopOpeBRep* classes
(0055971)
msv (developer)
2016-07-15 19:25

Reviewed.
(0056022)
apv (tester)
2016-07-19 13:45
edited on: 2016-07-19 13:46

Dear BugMaster,

Branch CR24056_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 27746b4d2083836dbba4e672345deb86b6e0b88c

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 1 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1122
New warning has been detected on MacOS:
http://jenkins-test-05.nnov.opencascade.com/view/CR24056_1-master/job/CR24056_1-master-OCCT-MacOS-opt-compile/1/warnings7Result/ [^]

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 89962235 / 90033000 [-0.08%]
Total CPU difference: 19286.219999999987 / 19191.60999999992 [+0.49%]

Testing on Windows:
Total MEMORY difference: 57425725 / 57431602 [-0.01%]
Total CPU difference: 18324.407863398785 / 18076.974677298753 [+1.37%]

(0056023)
apv (tester)
2016-07-19 13:47

Dear Ilya,

Branch CR24056_1 has been rejected due to:
- additional warnings
(0056029)
git (administrator)
2016-07-19 14:58

Branch CR24056_1 has been updated by msv.

SHA-1: 286dd365539d5ab1d8a8d1c9452f042e62d1a16f


Detailed log of new commits:

Author: msv
Date: Tue Jul 19 14:58:48 2016 +0300

    Remove unused private fields.

(0056030)
msv (developer)
2016-07-19 14:59

Ilya is on vacation.
(0056032)
msv (developer)
2016-07-19 14:59

Warning was eliminated.
(0056049)
apv (tester)
2016-07-20 12:48

Dear BugMaster,

Branch CR24056_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 286dd365539d5ab1d8a8d1c9452f042e62d1a16f

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 64
   Windows: 0
   MacOS: 1147

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 90381018 / 90034966 [+0.38%]
Total CPU difference: 19440.280000000046 / 19191.44999999992 [+1.30%]

Testing on Windows:
Total MEMORY difference: 57431869 / 57431602 [+0.00%]
Total CPU difference: 18067.349415598816 / 18076.974677298753 [-0.05%]
(0056097)
git (administrator)
2016-07-22 10:43

Branch CR24056_1 has been deleted by inv.

SHA-1: 286dd365539d5ab1d8a8d1c9452f042e62d1a16f

- Related Changesets
occt: master 0f1deae3
Timestamp: 2016-07-15 15:37:53
Author: isn
Committer: bugmaster
Details ] Diff ]
0024056: error LNK2019: unresolved external symbol

Clean out the TopOpeBRep* classes

Remove unused private fields.
mod - src/TopOpeBRep/FILES Diff ] File ]
mod - src/TopOpeBRep/TopOpeBRep_EdgesIntersector.hxx Diff ] File ]
mod - src/TopOpeBRep/TopOpeBRep_FacesFiller.hxx Diff ] File ]
rm - src/TopOpeBRep/TopOpeBRep_FacesFiller_VPonR.cxx Diff ] File ]
mod - src/TopOpeBRep/TopOpeBRep_GeomTool.hxx Diff ] File ]
mod - src/TopOpeBRepDS/FILES Diff ] File ]
rm - src/TopOpeBRepDS/TopOpeBRepDS_DSS.cxx Diff ] File ]
rm - src/TopOpeBRepDS/TopOpeBRepDS_DSS.hxx Diff ] File ]
mod - src/TopOpeBRepDS/TopOpeBRepDS_EXPORT.hxx Diff ] File ]
mod - src/TopOpeBRepDS/TopOpeBRepDS_HDataStructure.hxx Diff ] File ]
mod - src/TopOpeBRepDS/TopOpeBRepDS_repvg.hxx Diff ] File ]
mod - src/TopOpeBRepDS/TopOpeBRepDS_samdom.hxx Diff ] File ]
mod - src/TopOpeBRepTool/TopOpeBRepTool_2d.hxx Diff ] File ]
mod - src/TopOpeBRepTool/TopOpeBRepTool_mkTondgE.hxx Diff ] File ]
mod - src/TopOpeBRepTool/TopOpeBRepTool_TOPOLOGY.hxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-07-02 21:30 mach22 New Issue
2013-07-02 21:30 mach22 Assigned To => ifv
2014-01-29 16:33 bugmaster Note Added: 0027688
2014-01-29 16:33 bugmaster Assigned To ifv => apn
2014-01-29 16:33 bugmaster Status new => assigned
2014-02-11 16:31 apn Note Added: 0027842
2014-02-11 16:32 apn Test case number => Not needed
2014-02-11 16:32 apn Assigned To apn => ifv
2016-07-06 18:57 msv Assigned To ifv => msv
2016-07-06 19:02 msv Note Added: 0055734
2016-07-06 19:02 msv Assigned To msv => isn
2016-07-15 18:09 git Note Added: 0055961
2016-07-15 18:46 git Note Added: 0055966
2016-07-15 18:49 git Note Added: 0055967
2016-07-15 18:59 isn Assigned To isn => msv
2016-07-15 18:59 isn Status assigned => resolved
2016-07-15 19:01 isn Note Added: 0055969
2016-07-15 19:25 msv Note Added: 0055971
2016-07-15 19:25 msv Assigned To msv => bugmaster
2016-07-15 19:25 msv Status resolved => reviewed
2016-07-18 17:16 apv Assigned To bugmaster => apv
2016-07-19 13:45 apv Note Added: 0056022
2016-07-19 13:45 apv Assigned To apv => isn
2016-07-19 13:45 apv Status reviewed => assigned
2016-07-19 13:46 apv Note Edited: 0056022 View Revisions
2016-07-19 13:47 apv Note Added: 0056023
2016-07-19 14:58 git Note Added: 0056029
2016-07-19 14:59 msv Note Added: 0056030
2016-07-19 14:59 msv Assigned To isn => msv
2016-07-19 14:59 msv Status assigned => resolved
2016-07-19 14:59 msv Note Added: 0056032
2016-07-19 14:59 msv Assigned To msv => bugmaster
2016-07-19 14:59 msv Status resolved => reviewed
2016-07-19 16:04 apv Assigned To bugmaster => apv
2016-07-20 12:48 apv Note Added: 0056049
2016-07-20 12:48 apv Assigned To apv => bugmaster
2016-07-20 12:48 apv Status reviewed => tested
2016-07-22 10:23 bugmaster Changeset attached => occt master 0f1deae3
2016-07-22 10:23 bugmaster Status tested => verified
2016-07-22 10:23 bugmaster Resolution open => fixed
2016-07-22 10:43 git Note Added: 0056097
2016-07-25 14:44 bugmaster Target Version => 7.1.0
2016-12-09 16:31 user533 Status verified => closed
2016-12-09 16:38 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker