MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023934Open CASCADE[OCCT] OCCT:Codingpublic2013-04-25 13:322014-01-03 08:47
Reporterabv 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version32 bit
Product Version[OCCT] 6.6.0 
Target Version[OCCT] 6.7.0Fixed in Version[OCCT] 6.7.0 
Summary0023934: Compiler warnings in MS VC++ 10
DescriptionWhen building OCCT 6.6.0 with MS VC++ 10, the following compiler warnings are reported in addition to those shown by VC++ 9 (VS 2008):

Warning 5 warning C4013: 'exit' undefined; assuming extern returning int D:\OCCT660\ros\drv\ExprIntrp\lex.ExprIntrp.c 3182 TKAdvTools
Warning 2 warning C4013: 'ExprIntrperror' undefined; assuming extern returning int D:\PRODUCTS\flexbis-253-125\share\bison.simple TKAdvTools
Warning 3 warning C4013: 'ExprIntrplex' undefined; assuming extern returning int D:\PRODUCTS\flexbis-253-125\share\bison.simple TKAdvTools
Warning 8 warning C4013: 'free' undefined; assuming extern returning int D:\OCCT660\ros\drv\ExprIntrp\lex.ExprIntrp.c 3273 TKAdvTools
Warning 6 warning C4013: 'malloc' undefined; assuming extern returning int D:\OCCT660\ros\drv\ExprIntrp\lex.ExprIntrp.c 3245 TKAdvTools
Warning 4 warning C4013: 'read' undefined; assuming extern returning int D:\OCCT660\ros\drv\ExprIntrp\lex.ExprIntrp.c 2640 TKAdvTools
Warning 7 warning C4013: 'realloc' undefined; assuming extern returning int D:\OCCT660\ros\drv\ExprIntrp\lex.ExprIntrp.c 3263 TKAdvTools
Warning 1 warning C4244: '=' : conversion from 'std::streamsize' to 'Standard_Size', possible loss of data D:\OCCT660\ros\src\LDOM\LDOM_XmlReader.cxx 148 TKCDF
Warning 9 warning C4244: 'argument' : conversion from 'std::streamoff' to 'const Storage_Position', possible loss of data D:\OCCT660\ros\src\BinLDrivers\BinLDrivers_DocumentRetrievalDriver.cxx 268 TKBinL
Warning 10 warning C4244: 'initializing' : conversion from 'std::streamoff' to 'const Storage_Position', possible loss of data D:\OCCT660\ros\src\BinLDrivers\BinLDrivers_DocumentRetrievalDriver.cxx 500 TKBinL
Warning 14 warning C4244: 'initializing' : conversion from 'std::streamoff' to 'Standard_Size', possible loss of data D:\OCCT660\ros\src\BinMNaming\BinMNaming_NamedShapeDriver.cxx 301 TKBin
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0023947closedomy Open CASCADE Eliminate trivial compiler warnings in MSVC++ with warning level 4 
related to 0024177closedbugmaster Open CASCADE Eliminate CLang compiler warning -Wlogical-op-parentheses (&& within ||) 
related to 0024129closedabv Open CASCADE Eliminate remaining compiler warnings in MSVC++ 2008 32 bit with warning level 4 
related to 0024186closedbugmaster Open CASCADE Eliminate remaining compiler warnings in MSVC++ 2010 64 bit with warning level 4 

-  Notes
(0025552)
abv (manager)
2013-09-12 16:51

I have pushed changes in CR23934, please review. Note that this branch is based on CR24129_1.
(0025581)
omy (developer)
2013-09-16 09:59

Dear bugmaster,
I have no remarks. Please, test.
(0025587)
mkv (tester)
2013-09-16 12:42

Dear BugMaster,

Branch CR22934 was compiled on Linux platform.
SHA-1: 0483058ad222782d0ecfc02a68b3fe4874b6ac73

There is compilation error:
http://jenkins-test-02.nnov.opencascade.com:8080/user/mnt/my-views/view/CR23934/job/mnt-CR23934-master_build_occt_linux/1/parsed_console/? [^]
../../../../src/ViewerTest/ViewerTest_ViewerCommands.cxx:513: error: ‘theDisplayName’ was not declared in this scope
(0025591)
abv (manager)
2013-09-16 14:57

I have pushed fix for compiling on Linux to CR23934, please test
(0025614)
mkv (tester)
2013-09-18 08:47

Dear BugMaster,

Branch CR23934 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: d441bed86c1b395d042cf436ab8df3341a5ba31c

Number of compiler warnings:

occt component :
Linux: 763 (790 on master)
Windows: 186 (392 on master)

products component :
Linux: 190 (191 on master)
Windows: 287 (287 on master)

Regressions:
No regressions

Improvements:
No improvements

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 365812032 / 366619096
Total CPU difference: 44499.270000000775 / 44219.5200000011

Testing on Windows:
Total MEMORY difference: 427769908 / 428302712
Total CPU difference: 40551.421875 / 39177.890625

There are not differences in images found by testdiff.
(0025618)
abv (manager)
2013-09-18 09:15

I have rebased branch CR23934 on current master and prepared it for integration. It contains two commits: one for 0024129 and another for 0023934, both to be taken as-is.

- Related Changesets
occt: master 105aae76
Timestamp: 2013-09-18 05:13:42
Author: abv
Committer: abv
Details ] Diff ]
0023934: Compiler warnings in MS VC++ 10

Elimination of compiler warnings
- ExprIntrp: generated file ExprIntrp.tab.c and related WOK scripts removed from the sources
- ExprIntrp, StepFile: added missing declarations and casts; warnings caused by Flex and Bison code suppressed for MSVC compuler by #pragma
- OSD: dummy #includes added to files containing no code for Windows, to avoid warning on empty file
- PLib: piece of code contained in PLib_ChangeDim.gxx included explicitly in cxx and cleaned
- Other places: some casts added to avoid warnings
mod - src/ApproxInt/ApproxInt_ImpPrmSvSurfaces.gxx Diff ] File ]
mod - src/ApproxInt/ApproxInt_PrmPrmSvSurfaces.gxx Diff ] File ]
mod - src/Aspect/Aspect.cxx Diff ] File ]
mod - src/BinLDrivers/BinLDrivers_DocumentRetrievalDriver.cxx Diff ] File ]
mod - src/BinMNaming/BinMNaming_NamedShapeDriver.cxx Diff ] File ]
mod - src/BSplCLib/BSplCLib_2.cxx Diff ] File ]
mod - src/BSplCLib/BSplCLib_CurveComputation.gxx Diff ] File ]
mod - src/BSplSLib/BSplSLib.cxx Diff ] File ]
mod - src/ExprIntrp/ExprIntrp.lex Diff ] File ]
rm - src/ExprIntrp/ExprIntrp.tab.c Diff ] File ]
mod - src/ExprIntrp/ExprIntrp.yacc Diff ] File ]
rm - src/ExprIntrp/ExprIntrp_Replace.tcl Diff ] File ]
rm - src/ExprIntrp/ExprIntrp_WOKSteps.edl Diff ] File ]
mod - src/ExprIntrp/ExprIntrp_yacclex.cxx Diff ] File ]
mod - src/ExprIntrp/FILES Diff ] File ]
mod - src/Extrema/Extrema_GLocateExtCC.gxx Diff ] File ]
mod - src/Extrema/Extrema_GLocateExtCC2d.gxx Diff ] File ]
mod - src/Extrema/Extrema_GLocateExtPC.gxx Diff ] File ]
mod - src/Geom2dAPI/Geom2dAPI_InterCurveCurve.cxx Diff ] File ]
mod - src/Intf/Intf_InterferencePolygonPolyhedron.gxx Diff ] File ]
mod - src/LDOM/LDOM_XmlReader.cxx Diff ] File ]
mod - src/LProp/LProp_CLProps.gxx Diff ] File ]
mod - src/OpenGl/OpenGl_GraphicDriver_Export.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Text.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Workspace_2.cxx Diff ] File ]
mod - src/OSD/OSD_Cmailbox.c Diff ] File ]
mod - src/OSD/OSD_Csemaphore.c Diff ] File ]
mod - src/OSD/OSD_Csharedmemory.c Diff ] File ]
mod - src/OSD/OSD_MAllocHook.cxx Diff ] File ]
mod - src/PLib/FILES Diff ] File ]
mod - src/PLib/PLib.cxx Diff ] File ]
rm - src/PLib/PLib_ChangeDim.gxx Diff ] File ]
mod - src/QANCollection/QANCollection4.cxx Diff ] File ]
mod - src/StepFile/recfile.pc Diff ] File ]
mod - src/StepFile/step.lex Diff ] File ]
mod - src/StepFile/step.yacc Diff ] File ]
mod - src/TCollection/TCollection_ExtendedString.cxx Diff ] File ]
mod - src/TopOpeBRepDS/TopOpeBRepDS_Curve.cxx Diff ] File ]
mod - src/TopOpeBRepTool/TopOpeBRepTool_CORRISO.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-04-25 13:32 abv New Issue
2013-04-25 13:32 abv Assigned To => bugmaster
2013-07-01 14:04 omy Assigned To bugmaster => omy
2013-07-01 14:04 omy Status new => assigned
2013-07-03 17:01 omy Relationship added related to 0023947
2013-09-12 16:51 abv Note Added: 0025552
2013-09-12 16:51 abv Status assigned => resolved
2013-09-16 09:59 omy Note Added: 0025581
2013-09-16 09:59 omy Assigned To omy => bugmaster
2013-09-16 09:59 omy Status resolved => reviewed
2013-09-16 10:10 omy Relationship added related to 0024177
2013-09-16 12:42 mkv Note Added: 0025587
2013-09-16 12:44 mkv Test case number => Not needed
2013-09-16 12:44 mkv Assigned To bugmaster => abv
2013-09-16 12:44 mkv Status reviewed => assigned
2013-09-16 14:57 abv Note Added: 0025591
2013-09-16 14:57 abv Assigned To abv => bugmaster
2013-09-16 14:57 abv Status assigned => resolved
2013-09-16 14:57 abv Status resolved => reviewed
2013-09-16 15:45 bugmaster Assigned To bugmaster => mkv
2013-09-18 08:47 mkv Note Added: 0025614
2013-09-18 08:47 mkv Assigned To mkv => bugmaster
2013-09-18 08:47 mkv Status reviewed => tested
2013-09-18 09:11 abv Relationship added related to 0024129
2013-09-18 09:15 abv Note Added: 0025618
2013-09-18 09:56 omy Relationship added related to 0024186
2013-09-20 15:44 abv Changeset attached => occt master 105aae76
2013-09-20 15:44 abv Assigned To bugmaster => abv
2013-09-20 15:44 abv Status tested => verified
2013-09-20 15:44 abv Resolution open => fixed
2013-12-19 13:52 bugmaster Status verified => closed
2013-12-19 13:57 bugmaster Fixed in Version => 6.7.0
2014-01-03 08:47 abv Relationship added duplicate of 0022214
2014-01-11 11:58 abv Category OCCT Release:BUILD => OCCT:Coding


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker