View Issue Details

IDProjectCategoryView StatusLast Update
0023860CommunityOCCT:Modeling Algorithmspublic2022-08-16 16:17
ReporterAaron Michalk Assigned Tovmigunov  
PrioritynormalSeveritycrash 
Status feedbackResolutionunable to reproduce 
PlatformAOSL 
Product Version6.5.4 
Target Version7.7.0 
Summary0023860: Bad memory access intersecting two nearly coincident cylindrical faces
DescriptionExecuting the following code results in an access violation in Release on Windows and MacOS. It throws an exception in debug.
Steps To Reproduce        gp_Ax3 axes1(gp_Pnt(1031.3339148728076, -113.25868616662650, 56.152387686082520),
                        gp_Dir(-0.86602540378443815, 0.50000000000000089, 0.00000000000000000),
                        gp_Dir(-0.50000000000000089, -0.86602540378443815, 0.00000000000000000));
        Handle(Geom_CylindricalSurface) surface1(new Geom_CylindricalSurface(axes1, 76.499999999999986));
        gp_Ax3 axes2(gp_Pnt(1017.0706583606553, -103.24955863669388, 56.152387686082548),
                        gp_Dir(0.86602540378443915, -0.49999999999999933, 0.00000000000000000),
                        gp_Dir(0.49999999999999933, 0.86602540378443915, 0.00000000000000000));
        Handle(Geom_CylindricalSurface) surface2(new Geom_CylindricalSurface(axes2, 76.499999999999986));
        BRep_Builder builder;
        TopoDS_Face face1;
        TopoDS_Face face2;
        builder.MakeFace(face1, surface1, Precision::Confusion());
        builder.MakeFace(face2, surface2, Precision::Confusion());
        IntTools_FaceFace intersection;
        intersection.SetParameters(false, true, true, Precision::Confusion());
        intersection.Perform(face1, face2);
TagsNo tags attached.
Test case number

Activities

msv

2021-11-25 12:07

developer   ~0105416

It is needed to create a test case.

git

2022-06-29 10:04

administrator   ~0109355

Branch CR23860 has been created by vmigunov.

SHA-1: f5a092b6cf73141df8a7a322b024ea9534c75e2c


Detailed log of new commits:

Author: vmigunov
Date: Wed Jun 29 09:58:57 2022 +0300

    0023860: Bad memory access intersecting two nearly coincident cylindrical faces
    
    Test of 2 nearly coincident cylindrical faces intersection is added

git

2022-07-04 11:16

administrator   ~0109526

Branch CR23860 has been updated forcibly by vmigunov.

SHA-1: 337415de745a0d340776aab23b9a1f0cdb17b09d

vmigunov

2022-07-05 09:04

developer   ~0109551

See branch CR23860

azv

2022-07-05 11:08

administrator   ~0109558

No need to convert curves to edges:
mkedge e1 c_1
mkedge e2 c_2


Check of picture for each edge is redundant:
checkview -display e1 -2d -path ${imagedir}/${test_image}_e1.png
checkview -display e2 -2d -path ${imagedir}/${test_image}_e2.png

Both edges could be shown at once, you may use
xwd ${imagedir}/${test_image}.png


Also, I would expect the check of some numeric values of the result, at least the number of curves, and probably some other values of those curves.

git

2022-08-09 13:23

administrator   ~0110152

Branch CR23860 has been updated forcibly by vmigunov.

SHA-1: 3a7aca33c4d5c8e401e5528310b79636c603e091

vmigunov

2022-08-09 13:24

developer   ~0110153

Done. See branch CR23860.

msv

2022-08-09 13:57

developer   ~0110154

@akaftasev, please make review of this patch.

akaftasev

2022-08-11 10:17

developer   ~0110181

Last edited: 2022-08-11 10:17

Please, use construction 'puts "REQUIRED ALL"' in case with bad but expected function behavior.
In this case, nessesary to use another tcl constructions like:
set r [expr]
if {$r != val} { puts "error" }

git

2022-08-11 12:51

administrator   ~0110186

Branch CR23860 has been updated forcibly by vmigunov.

SHA-1: 208a9cbcc9ad2a1b36ed57a3e0f30f25f2397b68

vmigunov

2022-08-11 12:51

developer   ~0110187

Done. See branch CR23860.

msv

2022-08-11 15:36

developer   ~0110191

@vmigunov please don't forget to change status to resolved and assign to a person for review.

akaftasev

2022-08-11 15:39

developer   ~0110192

Branch for integrate CR23860

msv

2022-08-11 15:59

developer   ~0110193

It is needed to pass false in the first parameter of the call to intersection.SetParameters. It is not so when we use bopcurves command.

msv

2022-08-11 16:00

developer   ~0110194

Please also rerun tests on jenkins.

git

2022-08-11 17:47

administrator   ~0110196

Branch CR23860 has been updated forcibly by vmigunov.

SHA-1: c31210f0f675bdcf8376f0d375f0b895c740a677

vmigunov

2022-08-12 08:36

developer   ~0110206

Last edited: 2022-08-12 11:01

Done. See http://jenkins-test-occt.nnov.opencascade.com/view/CR23860-master-vmigunov/view/COMPARE/

msv

2022-08-12 12:09

developer   ~0110209

Please add new option -noapprox instead of -2d12.

git

2022-08-12 12:30

administrator   ~0110210

Branch CR23860 has been updated forcibly by vmigunov.

SHA-1: a0c6a637fa6c41e90b21a5a78d06ec341aa8295c

vmigunov

2022-08-15 13:13

developer   ~0110236

Done. See http://jenkins-test-occt/view/CR23860-master-vmigunov/view/COMPARE/

ifv

2022-08-16 15:35

developer   ~0110246

Branch CR23860 seems to be valid

kgv

2022-08-16 16:15

developer   ~0110247

Last edited: 2022-08-16 16:17

@vmigunov,

please put a clear resolution of the bug here and into git commit.
From the current discussion and patch it is completely unclear what has been done and for which purpose.
Was bug solved by some other patch?
In which OCCT version it was last reproducible if any?

Issue History

Date Modified Username Field Change
2013-03-26 21:24 Aaron Michalk New Issue
2013-03-26 21:24 Aaron Michalk Assigned To => abv
2013-09-22 13:17 abv Assigned To abv => ifv
2013-09-22 13:17 abv Status new => assigned
2013-09-22 13:17 abv Category OCCT:Foundation Classes => OCCT:Modeling Algorithms
2021-11-25 11:42 ifv Status assigned => resolved
2021-11-25 11:42 ifv Resolution open => unable to reproduce
2021-11-25 12:07 msv Note Added: 0105416
2021-11-25 12:07 msv Status resolved => assigned
2022-06-24 14:58 azv Assigned To ifv => vmigunov
2022-06-24 14:58 azv Target Version => 7.7.0
2022-06-29 10:04 git Note Added: 0109355
2022-07-04 11:16 git Note Added: 0109526
2022-07-04 19:05 vmigunov Assigned To vmigunov => azv
2022-07-05 09:04 vmigunov Status assigned => resolved
2022-07-05 09:04 vmigunov Note Added: 0109551
2022-07-05 11:08 azv Assigned To azv => vmigunov
2022-07-05 11:08 azv Status resolved => assigned
2022-07-05 11:08 azv Note Added: 0109558
2022-08-09 13:23 git Note Added: 0110152
2022-08-09 13:24 vmigunov Note Added: 0110153
2022-08-09 13:24 vmigunov Status assigned => resolved
2022-08-09 13:45 vmigunov Assigned To vmigunov => Aaron Michalk
2022-08-09 13:46 vmigunov Assigned To Aaron Michalk => msv
2022-08-09 13:57 msv Assigned To msv => akaftasev
2022-08-09 13:57 msv Note Added: 0110154
2022-08-11 10:17 akaftasev Assigned To akaftasev => vmigunov
2022-08-11 10:17 akaftasev Status resolved => assigned
2022-08-11 10:17 akaftasev Note Added: 0110181
2022-08-11 10:17 akaftasev Note Edited: 0110181
2022-08-11 12:51 git Note Added: 0110186
2022-08-11 12:51 vmigunov Note Added: 0110187
2022-08-11 15:35 msv Assigned To vmigunov => akaftasev
2022-08-11 15:35 msv Status assigned => resolved
2022-08-11 15:36 msv Note Added: 0110191
2022-08-11 15:39 akaftasev Assigned To akaftasev => bugmaster
2022-08-11 15:39 akaftasev Status resolved => reviewed
2022-08-11 15:39 akaftasev Note Added: 0110192
2022-08-11 15:58 vmigunov Assigned To bugmaster => vmigunov
2022-08-11 15:58 vmigunov Status reviewed => assigned
2022-08-11 15:59 msv Note Added: 0110193
2022-08-11 16:00 msv Note Added: 0110194
2022-08-11 17:47 git Note Added: 0110196
2022-08-12 08:36 vmigunov Note Added: 0110206
2022-08-12 08:37 vmigunov Assigned To vmigunov => msv
2022-08-12 08:37 vmigunov Status assigned => resolved
2022-08-12 11:01 vmigunov Note Edited: 0110206
2022-08-12 12:09 msv Note Added: 0110209
2022-08-12 12:09 msv Assigned To msv => vmigunov
2022-08-12 12:09 msv Status resolved => assigned
2022-08-12 12:30 git Note Added: 0110210
2022-08-15 13:13 vmigunov Note Added: 0110236
2022-08-15 13:14 vmigunov Assigned To vmigunov => ifv
2022-08-15 13:14 vmigunov Status assigned => resolved
2022-08-16 15:35 ifv Assigned To ifv => bugmaster
2022-08-16 15:35 ifv Status resolved => reviewed
2022-08-16 15:35 ifv Note Added: 0110246
2022-08-16 16:15 kgv Note Added: 0110247
2022-08-16 16:15 kgv Assigned To bugmaster => vmigunov
2022-08-16 16:15 kgv Status reviewed => feedback
2022-08-16 16:16 kgv Note Edited: 0110247
2022-08-16 16:17 kgv Note Edited: 0110247