View Issue Details

IDProjectCategoryView StatusLast Update
0023854Open CASCADEOCCT:Visualizationpublic2020-10-08 11:02
Reportersan Assigned Tobugmaster  
PrioritynormalSeverityfeature 
Status closedResolutionduplicate 
PlatformAOSL 
Summary0023854: Possibility to apply individual transformation to Graphic3d_Group instance
DescriptionCurrently, it is possible to apply a 3D transformation to the geometrical primitives contained in a Graphic3d_Structure instance as a whole.

However, it is sometimes necessary to apply a 3D transformation to the contents of a specific Graphic3d_Group inside the graphic structure - e.g. in case if the portion of geometry displayed by the group comes with its own non-identity transformation matrix.

For this purpose, it would be helpful to extend Graphic3d_Group API by methods to set/get the group's transformation, and to apply this transformation at OpenGl package level implementing it as an OpenGl_Element sub-class. The group's transformation should be relative to the graphic structure transformation.
TagsNo tags attached.
Test case numberNot needed

Relationships

duplicate of 0027919 closedbugmaster Visualization - support multiple transformation persistence groups within single presentation 

Activities

abv

2013-04-04 20:44

manager   ~0024003

test

git

2020-06-08 10:12

administrator   ~0092506

Branch CR23854 has been created by nds.

SHA-1: 90c3cbae8186a83cecf2115692e744172413b4b2


Detailed log of new commits:

Author: nds
Date: Mon Jun 8 10:09:58 2020 +0300

    0023854: Possibility to apply individual transformation to Graphic3d_Group instance
    
    (cherry picked from commit e50bf38102e562ae74c9c1fdfd13145e072b4615)

git

2020-10-08 11:02

administrator   ~0095815

Branch CR23854 has been deleted by inv.

SHA-1: 90c3cbae8186a83cecf2115692e744172413b4b2

Issue History

Date Modified Username Field Change
2013-03-22 17:59 san New Issue
2013-03-22 17:59 san Assigned To => san
2013-03-22 18:40 san Description Updated
2013-04-04 20:44 abv Note Added: 0024003
2016-09-29 13:06 kgv Relationship added duplicate of 0027919
2017-07-27 15:38 mkv Test case number => Not needed
2017-07-27 15:38 mkv Assigned To san => bugmaster
2017-07-27 15:38 mkv Status new => closed
2017-07-27 15:38 mkv Resolution open => duplicate
2020-06-08 10:12 git Note Added: 0092506
2020-10-08 11:02 git Note Added: 0095815