MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023849Community[OCCT] OCCT:Modeling Algorithmspublic2013-03-22 00:352013-04-29 15:24
ReporterPawel 
Assigned Toemv 
PriorityimmediateSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2008OS Version32 bit
Product Version[OCCT] 6.5.5 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0023849: BOP regression (1) - BRepAlgoAPI_Common
DescriptionAlthough the sample shapes - both are valid - (see attachment) do not overlap a common part is detected by the algorithm.

It seems to me that the distance between both shapes has something to do with the problem because when the shapes are far enough from each other no common part is detected.

The problem exists on the current master (Head: 0022812: Bad performance meshing a face based on extrusion of huge b-spline curve).

I also have a master compiled on 27.02.2013 and the (new) BOP works OK so it seems the problem was introduced after 27.02.
Steps To Reproducepload ALL
restore plane.brep s1
restore segment.brep s2
bop s1 s2
bopcommon result
checkshape result
Additional information
and documentation updates
Set the lower bound for the refined tolerance value in 2d classification algorithm.
TagsNo tags attached.
Test case numberbugs modalg_5(010) bug23849_1, bug23849_2, bug23849_3
Attached Fileszip file icon sample_pair1.zip (420,484 bytes) 2013-03-22 00:35
zip file icon sample_pair2.zip (414,890 bytes) 2013-03-22 00:42
zip file icon test_cases.zip (759 bytes) 2013-03-22 14:35

- Relationships
related to 0021762closedemv Open CASCADE Integration new Boolean Operation algorithm to OCC 

-  Notes
(0023844)
abv (manager)
2013-03-22 07:38

Please fix asap; this is regression caused by one of the very recent integrations (it is Ok on CR23820)
(0023850)
emv (developer)
2013-03-22 12:13

This regression caused by the integration of the fix for the issue 23777.
(0023862)
emv (developer)
2013-03-22 14:34

Git branch CR23849 is ready to be reviewed.
Test cases are attached.
bug23894 - original test case (on BOP algorithm);
bug23849_1 - test case on 2d classifier algorithm.
(0023863)
pkv (developer)
2013-03-22 14:35

No remarks
(0023864)
kgv (developer)
2013-03-22 14:40

Dear emv,

could you please comment why magic number 1.e-7 is used within the patch instead of it's named equivalent Precision::Confusion()?
(0023865)
emv (developer)
2013-03-22 14:56

1.e-7 replaced by Precision::Confusion().
(0023870)
Pawel (developer)
2013-03-22 16:59

The patch solves the problem.
(0023875)
mkv (tester)
2013-03-22 19:44
edited on: 2013-03-22 19:55

Dear BugMaster,

Branch CR23849 (and products from GIT master) was compiled on Linux and Windows platforms and tested without rebase.
SHA-1: 62830ca87e40e80c8d55d62b9f55c5692aa2b7a6

Number of compiler warnings:

occt component :
Linux: 3 (3 on master)
Windows: 11 (11 on master)

products component :
Linux: 0 (0 on master)
Windows: 50 (50 on master)

Regressions:
No regressions

Improvements:
No improvements

Testing cases:
bugs modalg_5(010) bug23849_1, bug23849_2, bug23849_3 - OK.

Testing on Linux:
Total MEMORY difference: 243633904 / 241816752
Total CPU difference: 16438.40000000011 / 14998.290000000103

Testing on Windows:
Total MEMORY difference: 347734376 / 350384140
Total CPU difference: 20103.640625 / 22701.96875

There are not serious differences in images found by testdiff.


- Related Changesets
occt: master ce101cac
Timestamp: 2013-03-22 10:19:48
Author: emv
Details ] Diff ]
0023849: BOP regression (1) - BRepAlgoAPI_Common.
Fix for the bug.
Set the lower bound for the refined tolerance value in 2d classification algorithm.
mod - src/BRepClass/BRepClass_Intersector.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-03-22 00:35 Pawel New Issue
2013-03-22 00:35 Pawel Assigned To => bugmaster
2013-03-22 00:35 Pawel File Added: sample_pair1.zip
2013-03-22 00:37 Pawel Relationship added related to 0021762
2013-03-22 00:37 Pawel Description Updated View Revisions
2013-03-22 00:40 Pawel Description Updated View Revisions
2013-03-22 00:42 Pawel File Added: sample_pair2.zip
2013-03-22 00:43 Pawel Summary BOP regression (1) => BOP regression (1) - BRepAlgoAPI_Common
2013-03-22 07:38 abv Note Added: 0023844
2013-03-22 07:38 abv Assigned To bugmaster => emv
2013-03-22 07:38 abv Status new => assigned
2013-03-22 07:38 abv Priority normal => immediate
2013-03-22 07:38 abv Target Version => 6.6.0
2013-03-22 12:08 emv Relationship added child of 0023777
2013-03-22 12:13 emv Note Added: 0023850
2013-03-22 14:34 emv Note Added: 0023862
2013-03-22 14:34 emv Assigned To emv => pkv
2013-03-22 14:34 emv Status assigned => resolved
2013-03-22 14:34 emv Additional Information Updated View Revisions
2013-03-22 14:35 pkv Note Added: 0023863
2013-03-22 14:35 emv File Added: test_cases.zip
2013-03-22 14:35 pkv Assigned To pkv => mkv
2013-03-22 14:35 pkv Status resolved => reviewed
2013-03-22 14:40 kgv Note Added: 0023864
2013-03-22 14:56 emv Note Added: 0023865
2013-03-22 16:59 Pawel Note Added: 0023870
2013-03-22 19:44 mkv Note Added: 0023875
2013-03-22 19:55 mkv Note Edited: 0023875 View Revisions
2013-03-22 19:57 mkv Test case number => bugs modalg_5(010) bug23849_1, bug23849_2, bug23849_3
2013-03-22 19:57 mkv Assigned To mkv => bugmaster
2013-03-22 19:57 mkv Status reviewed => tested
2013-03-25 18:39 emv Changeset attached => occt master ce101cac
2013-03-25 18:39 emv Assigned To bugmaster => emv
2013-03-25 18:39 emv Status tested => verified
2013-03-25 18:39 emv Resolution open => fixed
2013-04-23 13:35 user533 Status verified => closed
2013-04-29 15:24 user533 Fixed in Version => 6.6.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker