View Issue Details

IDProjectCategoryView StatusLast Update
0023804Open CASCADEOCCT:Visualizationpublic2014-11-11 12:52
Reportersan Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
PlatformWindowsOSVC++ 2010 
Product Version6.6.0 
Target Version6.8.0Fixed in Version6.8.0 
Summary0023804: Unexpected color modulation during texture mapping
DescriptionAIS_TexturedShape seems to always create Graphic3d_AspectFillArea3d instance with some default material attributes (brass).
As the result, unexpected modulate effect is observed between the texel color and material color (for brass ambient color is yellow - see attached screenshot), even if some different color is specified for the interactive object.

Another minor issue is that there is no way in DRAW to disable color modulation for AIS_TexturedShape. It makes sense to improve vtexture or related command(s).
Steps To Reproducepload ALL
box b 100 100 100
vinit
vdisplay b
vfit
vsetdispmode b 1
vsetmaterial b plastic
vsetcolor b ANTIQUEWHITE
# After this line, the textured shape appears with yellow ambient color
vtexture b 3
# This line has no effect
vsetcolor b ANTIQUEWHITE
TagsNo tags attached.
Test case numberbugs vis(004) bug23804

Attached Files

  • yellow_modulation.png (142,064 bytes)

Relationships

related to 0003038 closeddbp Blue component of RGB ambient light seems to be ignored. 
related to 0024855 closedapn Revision of parameters of standard materials 

Activities

san

2013-02-27 17:55

developer  

yellow_modulation.png (142,064 bytes)

san

2013-02-27 20:35

developer   ~0023510

Seems to be the same as good old 0003038

dbp

2014-04-25 10:15

developer   ~0029066

Dear kgv,

please review the patch in branch CR23804.

kgv

2014-04-25 15:32

developer   ~0029079

Patch is ready for testing in branch CR23804_1.

mkv

2014-05-06 13:02

tester   ~0029211

Dear BugMaster,

Branch CR23804_1 (and products from GIT master) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 18da1c3e3db9968c39550f3bb0f4165a634d8d21

Number of compiler warnings:

occt component :
Linux: 18 (18 on master)
Windows: 0 (0 on master)
MacOS: 351 (351 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
http://occt-tests/CR24804-1-master-occt/Debian60-64/bugs/vis/bug23804.html
bugs vis(004) bug23804: OK

Testing on Linux:
Total MEMORY difference: 355037844 / 355768204
Total CPU difference: 58961.61 / 55245.89999999973

Testing on Windows:
Total MEMORY difference: 378887436 / 381791492
Total CPU difference: 33721.640625 / 43080.4375

There are no differences in images found by testdiff.

Related Changesets

occt: master 7389f96d

2014-05-08 07:26:39

dbp


Committer: bugmaster Details Diff
0023804: Visualization - unexpected color modulation during texture mapping

AIS_TexturedShape - use material set to the Drawer, not default undefined one

Test case for issue CR23804
Affected Issues
0023804
mod - src/AIS/AIS_TexturedShape.cxx Diff File
mod - src/AIS/AIS_TexturedShape.hxx Diff File
add - tests/bugs/vis/bug23804 Diff File

Issue History

Date Modified Username Field Change
2013-02-27 17:55 san New Issue
2013-02-27 17:55 san Assigned To => san
2013-02-27 17:55 san File Added: yellow_modulation.png
2013-02-27 18:11 san Severity major => minor
2013-02-27 18:11 san Summary Unexpected modulate effect of texture mapping => Unexpected color modulation during texture mapping
2013-02-27 18:11 san Description Updated
2013-02-27 20:35 san Relationship added related to 0003038
2013-02-27 20:35 san Note Added: 0023510
2013-12-12 10:59 san Target Version 6.7.0 => 6.7.1
2014-02-05 14:41 kgv Status new => assigned
2014-04-04 18:16 abv Target Version 6.7.1 => 6.8.0
2014-04-17 14:44 san Relationship added related to 0024855
2014-04-22 18:56 san Assigned To san => dbp
2014-04-25 10:15 dbp Note Added: 0029066
2014-04-25 10:15 dbp Assigned To dbp => kgv
2014-04-25 10:15 dbp Status assigned => resolved
2014-04-25 15:32 kgv Note Added: 0029079
2014-04-25 15:32 kgv Assigned To kgv => bugmaster
2014-04-25 15:32 kgv Status resolved => reviewed
2014-04-25 17:55 mkv Assigned To bugmaster => mkv
2014-05-06 13:02 mkv Note Added: 0029211
2014-05-06 13:03 mkv Test case number => bugs vis(004) bug23804
2014-05-06 13:03 mkv Assigned To mkv => bugmaster
2014-05-06 13:03 mkv Status reviewed => tested
2014-05-12 16:20 bugmaster Changeset attached => occt master 7389f96d
2014-05-12 16:20 bugmaster Status tested => verified
2014-05-12 16:20 bugmaster Resolution open => fixed
2014-11-11 12:47 aiv Fixed in Version => 6.8.0
2014-11-11 12:52 aiv Status verified => closed