MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023687Community[OCCT] OCCT:Data Exchangepublic2013-01-04 14:522013-04-29 15:21
ReporterPawel 
Assigned ToPawel 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.4 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0023687: Two opposite conditions. The second condition is always false in ifselect_shareout.cxx
DescriptionIn lines 44, 45

 if (!modifier.IsNull()) {
    if (modifier.IsNull()) return Standard_False;

the second check is always 'false'.

The second if-clause can either be deleted or checked as first but I'm not sure about the logic (should the method return 'Standard_False' if there is no modifier?).
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0022902)
abv (manager)
2013-01-04 17:24

I suggest line 45 should be removed: this is safe as it will keep existing behavior, while recovering the complete logic of this tool seems to be not worth the candle
(0022904)
Pawel (developer)
2013-01-04 18:20

Branch CR23687 pushed. Please review.
(0022906)
abv (manager)
2013-01-04 18:26

No remarks, please test
(0022949)
mkv (tester)
2013-01-11 18:30

Dear BugMaster,

Branch CR23687 (and products from GIT master) was compiled on Linux and
Windows platforms and tested.

Regressions:
Not detected

Improvements:
Not detected

Testing cases:
Not needed

- Related Changesets
occt: master e1db25a9
Timestamp: 2013-01-04 14:18:34
Author: Pawel
Details ] Diff ]
0023687: Two opposite conditions. The second condition is always false in ifselect_shareout.cxx

Deleted if-condition that was always false.
mod - src/IFSelect/IFSelect_ShareOut.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-01-04 14:52 Pawel New Issue
2013-01-04 14:52 Pawel Assigned To => bugmaster
2013-01-04 17:24 abv Note Added: 0022902
2013-01-04 18:20 Pawel Note Added: 0022904
2013-01-04 18:20 Pawel Status new => resolved
2013-01-04 18:26 abv Note Added: 0022906
2013-01-04 18:26 abv Status resolved => reviewed
2013-01-11 18:30 mkv Note Added: 0022949
2013-01-11 18:30 mkv Test case number => Not needed
2013-01-11 18:30 mkv Status reviewed => tested
2013-01-21 18:29 Pawel Changeset attached => occt master e1db25a9
2013-01-21 18:29 Pawel Assigned To bugmaster => Pawel
2013-01-21 18:29 Pawel Status tested => verified
2013-01-21 18:29 Pawel Resolution open => fixed
2013-04-23 13:36 user533 Status verified => closed
2013-04-29 15:21 user533 Fixed in Version => 6.6.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker