MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023684Community[OCCT] OCCT:Foundation Classespublic2013-01-02 23:492013-04-29 15:22
ReporterRoman Lygin 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.4 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0023684: TCollection_HExtendedString::String() returns a copy instead of const reference
DescriptionTCollection_HExtendedString::String()returns a copy of TCollection_ExtendedString instead of const reference.
Note that TCollection_HAsciiString::String() does return a const reference.
Steps To ReproduceSee enclosed test case. The same case for TCollection_HAsciiString/TCollection_AsciiString does pass.
TagsNo tags attached.
Test case numberNot needed
Attached Filescxx file icon TCollection_HExtendedString.cxx (291 bytes) 2013-01-02 23:49

- Relationships

-  Notes
(0022894)
Roman Lygin (developer)
2013-01-02 23:57

The fix pushed into the git repository - see CR23684.
(0022895)
abv (manager)
2013-01-03 08:36

No remarks, please test
(0022962)
mkv (tester)
2013-01-15 10:50

Dear BugMaster,

There are compilation errors on Linux:
http://jenkins-test-01.nnov.opencascade.com/user/mnt/my-views/view/CR23684/job/mnt-CR23684-master_build_occt_linux/1/parsed_console/? [^]

../../../src/TCollection/TCollection_HExtendedString.cxx:282:
 error: prototype for 'TCollection_ExtendedString
TCollection_HExtendedString::String() const' does not match any in class
 'TCollection_HExtendedString'

../../../inc/TCollection_HExtendedString.hxx:178:
 error: candidate is: const TCollection_ExtendedString&
TCollection_HExtendedString::String() const
(0022973)
kgv (developer)
2013-01-15 21:57

Trivial compilation error should be fixed now in the branch CR23684.
(0022974)
Roman Lygin (developer)
2013-01-15 23:25

Folks, sorry for extra headache for you and thanks for quickly resolving this on your own. As explained in an another recent commit, not all header changes go via compilation in my environment (due to already excessive list of multiple supported configurations). Hence these hiccups. Will try to pay more attention moving forward.
(0023013)
mkv (tester)
2013-01-17 20:34

Dear BugMaster,

Branch CR23684 (and products from GIT master) was compiled on Linux and
Windows platforms and tested.

Regressions:
Not detected

Improvements:
Not detected

Testing cases:
Not needed
(0023048)
bugmaster (administrator)
2013-01-21 18:57

Fix has been integrated into master of occt repository

- Issue History
Date Modified Username Field Change
2013-01-02 23:49 Roman Lygin New Issue
2013-01-02 23:49 Roman Lygin Assigned To => abv
2013-01-02 23:49 Roman Lygin File Added: TCollection_HExtendedString.cxx
2013-01-02 23:57 Roman Lygin Note Added: 0022894
2013-01-02 23:57 Roman Lygin Status new => resolved
2013-01-03 08:36 abv Note Added: 0022895
2013-01-03 08:36 abv Assigned To abv => bugmaster
2013-01-03 08:36 abv Status resolved => reviewed
2013-01-11 19:09 mkv Assigned To bugmaster => mkv
2013-01-15 10:50 mkv Note Added: 0022962
2013-01-15 10:51 mkv Test case number => Not needed
2013-01-15 10:51 mkv Assigned To mkv => Roman Lygin
2013-01-15 10:51 mkv Status reviewed => assigned
2013-01-15 21:57 kgv Note Added: 0022973
2013-01-15 21:57 kgv Assigned To Roman Lygin => bugmaster
2013-01-15 21:57 kgv Status assigned => resolved
2013-01-15 21:57 kgv Status resolved => reviewed
2013-01-15 23:25 Roman Lygin Note Added: 0022974
2013-01-16 10:51 mkv Assigned To bugmaster => mkv
2013-01-17 20:34 mkv Note Added: 0023013
2013-01-17 20:34 mkv Assigned To mkv => bugmaster
2013-01-17 20:34 mkv Status reviewed => tested
2013-01-21 18:57 bugmaster Note Added: 0023048
2013-01-21 18:57 bugmaster Status tested => verified
2013-01-21 18:57 bugmaster Resolution open => fixed
2013-02-20 10:19 bugmaster Target Version => 6.6.0
2013-04-23 13:35 user533 Status verified => closed
2013-04-29 15:22 user533 Fixed in Version => 6.6.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker