MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023639Open CASCADE[OCCT] OCCT:Application Frameworkpublic2012-12-13 16:392016-12-09 16:39
Reporterabv 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2008OS Version32 bit
Product Version[OCCT] 6.6.0 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0023639: Exception on attempt to save to XmlOcaf format
DescriptionIn DRAW, after pload ALL is called, saving to XmlOcaf format seem to be not working. Note that it works well in pload only OCAF and MODELING. Tried both Windows and Linux.
Steps To Reproducepload ALL
NewDocument D XmlOcaf
box b 10 10 10
SetShape D 0:1:1 b
SaveAs D /tmp/b.xml

To be used the next script:
pload FULL
NewDocument D XmlOcaf
box b 10 10 10
SetShape D 0:1:1 b
SaveAs D /tmp/b.xml
TagsNo tags attached.
Test case numberbugs caf bug26290_compatibility, bug26290_newattribute_1, bug26290_newattribute_2; caf basic M4; caf named_shape E1 - E9; caf named_shape F1 - F9
Attached Files

- Relationships
related to 0025812closedabv Open CASCADE Replace dynamic loading mechanism of OCAF persistence with dynamic-link one 

-  Notes
(0022726)
szy (developer)
2012-12-17 15:51

It is duplication of 0016133.
See its description.
(0022751)
abv (manager)
2012-12-18 19:00

This problem needs to be avoided, even if this is not critical
(0039668)
szy (developer)
2015-04-14 12:37

Incorrect Draw reproducer.
To test OCAF persistence (native formats: std, cbf, xml) another Draw
command should be used:
'pload FULL' instead of 'pload ALL'
XmlOcaf format is managed by AppStd_Application.
At the same time 'pload ALL' uses XCAFApp_Application.
(0039671)
szy (developer)
2015-04-14 14:00

Additional information.
The source of the problem is in Draw features.
DRAW can't manage two applications in one interactive session.
The key 'ALL' (used by pload command) loads sequentially the next components:
"MODELING, OCAFKERNEL, DATAEXCHANGE".
The last two libraries use different applications with different initialization and different Document structure and used set of attributes.
So, this string of resources leads to potential conflict.
OCAFKERNEL and DATAEXCHANGE resources shouldn't use in one session.
So, if the current issue supposes to perform test of standard XmlOCAF format,
the command 'pload FULL' should be used only.
If author of XDE supposed to manage both formats by one Application (XCAF_Application) it should be managed inside this application.
(0039672)
abv (manager)
2015-04-14 14:09

To be clear: I wish to be able to have XCAF and OCAF documents supported in the same environment (DRAW), while being not dependent on each other. This is where existing architecture of OCAF fails. I suppose the same problem will appear in NewGEOM when (if?) they start using plugins, as soon as plugin may have its own OCAF entities and format.
(0039680)
szy (developer)
2015-04-14 15:20
edited on: 2015-04-14 15:52

It is not a problem of OCAF architecture. Rather It is the problem of DRAW architecture.
OCAF architecture allows to have different documents in one session or if you want in one Draw environment. But both documents should be used by one Application. At the moment it is not the case.
In addition to be clear. The exception itself is result of a mistake in 'XCAF' format description. Application method Formats() specifies 4 formats. 'XCAF' resource file specifies only 3 formats (XmlOcaf is missed). Adding 'XmlOcaf' to 'XCAF' removes the exception. But it is not a solution as it just hides the problem. XCAF_Application by default initializes a Document with attributes specific to XDE (and not known by Standard schema). As result during save they are ignored, but standard attributes (like Names) specifying different levels of XDE document (Colors, Materials and etc.) will be kept. I don't think that it good because these attributes are not expected in standard schema.

(0039685)
mpv (developer)
2015-04-14 15:50

Just a note: in NewGEOM several formats or not-standard attributes or custom formats in OCAF are not used and not planned for the current moment.
(0059965)
git (administrator)
2016-11-08 05:15

Branch CR23639 has been created by abv.

SHA-1: f89cd3970037acd6bcd09635575ae50257a96bcd


Detailed log of new commits:

Author: abv
Date: Tue Nov 8 05:08:22 2016 +0300

    0023639: Exception on attempt to save to XmlOcaf format
    
    Variant FULL is removed from the options of DRAW command pload; ALL can be used in all cases
(0059966)
abv (manager)
2016-11-08 05:16

The original problem has been fixed by 0025812. I have pushed additional correction, removing option FULL for pload command -- it is not needed anymore. Please review.
(0059981)
mpv (developer)
2016-11-08 10:34

Branch CR23639 reviewed without remarks, ready for testing.
(0060004)
abv (manager)
2016-11-08 13:53

Note that compilation is not needed (all changes are in DRAW scripts) and testing can be limited to execution of changed tests only
(0060176)
mkv (tester)
2016-11-10 13:15

Dear BugMaster,
Branch CR23639 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: f89cd3970037acd6bcd09635575ae50257a96bcd

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 63 (63 on master)
Windows: 0 (0 on master)
MacOS : 1117

Testing cases:
http://occt-tests/CR23639-master-OCCT/Debian70-64/ [^]
http://occt-tests/CR23639-master-OCCT/Windows-64-VC10/ [^]
bugs caf bug26290_compatibility: OK
bugs caf bug26290_newattribute_1: OK
bugs caf bug26290_newattribute_2: OK
caf basic M4: OK
caf named_shape E1: OK
caf named_shape E2: OK
caf named_shape E3: OK
caf named_shape E4: OK
caf named_shape E5: OK
caf named_shape E6: OK
caf named_shape E7: OK
caf named_shape E8: OK
caf named_shape E9: OK
caf named_shape F1: OK
caf named_shape F2: OK
caf named_shape F3: OK
caf named_shape F4: OK
caf named_shape F5: OK
caf named_shape F6: OK
caf named_shape F7: OK
caf named_shape F8: OK
caf named_shape F9: OK
(0060177)
mkv (tester)
2016-11-10 13:15

Dear BugMaster,
Branch CR23639 is TESTED.

(0061228)
git (administrator)
2016-12-07 11:30

Branch CR23639 has been deleted by kgv.

SHA-1: f89cd3970037acd6bcd09635575ae50257a96bcd

- Related Changesets
occt: master 7a1b96cb
Timestamp: 2016-11-08 02:08:22
Author: abv
Committer: apn
Details ] Diff ]
0023639: Exception on attempt to save to XmlOcaf format

Variant FULL is removed from the options of DRAW command pload; ALL can be used in all cases
mod - src/DrawResources/DrawPlugin Diff ] File ]
mod - tests/bugs/caf/bug26290_compatibility Diff ] File ]
mod - tests/bugs/caf/bug26290_newattribute_1 Diff ] File ]
mod - tests/bugs/caf/bug26290_newattribute_2 Diff ] File ]
mod - tests/caf/basic/M4 Diff ] File ]
mod - tests/caf/named_shape/E1 Diff ] File ]
mod - tests/caf/named_shape/E2 Diff ] File ]
mod - tests/caf/named_shape/E3 Diff ] File ]
mod - tests/caf/named_shape/E4 Diff ] File ]
mod - tests/caf/named_shape/E5 Diff ] File ]
mod - tests/caf/named_shape/E6 Diff ] File ]
mod - tests/caf/named_shape/E7 Diff ] File ]
mod - tests/caf/named_shape/E8 Diff ] File ]
mod - tests/caf/named_shape/E9 Diff ] File ]
mod - tests/caf/named_shape/F1 Diff ] File ]
mod - tests/caf/named_shape/F2 Diff ] File ]
mod - tests/caf/named_shape/F3 Diff ] File ]
mod - tests/caf/named_shape/F4 Diff ] File ]
mod - tests/caf/named_shape/F5 Diff ] File ]
mod - tests/caf/named_shape/F6 Diff ] File ]
mod - tests/caf/named_shape/F7 Diff ] File ]
mod - tests/caf/named_shape/F8 Diff ] File ]
mod - tests/caf/named_shape/F9 Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-12-13 16:39 abv New Issue
2012-12-13 16:39 abv Assigned To => szy
2012-12-17 15:49 szy Relationship added duplicate of 0016133
2012-12-17 15:50 szy Status new => assigned
2012-12-17 15:51 szy Note Added: 0022726
2012-12-17 15:51 szy Assigned To szy => abv
2012-12-17 15:51 szy Status assigned => resolved
2012-12-18 19:00 abv Note Added: 0022751
2012-12-18 19:00 abv Status resolved => assigned
2013-02-26 15:50 abv Target Version 6.6.0 => 6.7.0
2013-10-15 20:43 abv Target Version 6.7.0 => Unscheduled
2015-01-28 16:52 abv Assigned To abv => dln
2015-01-28 16:52 abv Target Version Unscheduled => 6.9.0
2015-02-10 15:07 ibs Relationship added related to 0025812
2015-04-14 12:37 szy Note Added: 0039668
2015-04-14 12:37 szy Assigned To dln => szy
2015-04-14 12:37 szy Status assigned => resolved
2015-04-14 12:37 szy Steps to Reproduce Updated View Revisions
2015-04-14 12:37 szy Assigned To szy => vro
2015-04-14 14:00 szy Note Added: 0039671
2015-04-14 14:09 abv Note Added: 0039672
2015-04-14 15:20 szy Note Added: 0039680
2015-04-14 15:50 mpv Note Added: 0039685
2015-04-14 15:52 szy Note Edited: 0039680 View Revisions
2015-04-16 23:52 abv Target Version 6.9.0 => 7.1.0
2015-04-30 09:43 vro Assigned To vro => abv
2016-11-06 21:37 abv Status resolved => feedback
2016-11-08 05:15 git Note Added: 0059965
2016-11-08 05:16 abv Note Added: 0059966
2016-11-08 05:16 abv Assigned To abv => mpv
2016-11-08 05:16 abv Status feedback => resolved
2016-11-08 10:34 mpv Note Added: 0059981
2016-11-08 10:34 mpv Assigned To mpv => bugmaster
2016-11-08 10:34 mpv Status resolved => reviewed
2016-11-08 13:53 abv Note Added: 0060004
2016-11-09 12:49 mkv Assigned To bugmaster => mkv
2016-11-10 13:15 mkv Note Added: 0060176
2016-11-10 13:15 mkv Note Added: 0060177
2016-11-10 13:15 mkv Assigned To mkv => bugmaster
2016-11-10 13:15 mkv Status reviewed => tested
2016-11-10 13:15 mkv Test case number => bugs caf bug26290_compatibility, bug26290_newattribute_1, bug26290_newattribute_2; caf basic M4; caf named_shape E1 - E9; caf named_shape F1 - F9
2016-11-18 16:37 apn Changeset attached => occt master 7a1b96cb
2016-11-18 16:37 apn Assigned To bugmaster => apn
2016-11-18 16:37 apn Status tested => verified
2016-11-18 16:37 apn Resolution open => fixed
2016-12-07 11:30 git Note Added: 0061228
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker