MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023575Open CASCADE[OCCT] OCCT:Modeling Datapublic2012-11-23 09:242018-02-19 10:50
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2008OS Version32 bit
Product Version[OCCT] 6.5.4 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.0.0 
Summary0023575: Bounding box for a planar edge has non-zero dimension in direction orthogonal to an edge plane
DescriptionThe problem is caused by fix on #566: bounding box computed for a curve is computed by evaluating fixed set of points on a curve and then extended by some heuristic value, which leads e.g. to bounding box of planar curve having non-zero dimension in direction orthogonal to the plane.
Steps To ReproduceThe commands:

bsplinecurve c 3 2 0 4 1 4 0 0 0 1 0 1 0 1 1 1 0 1 1 0 0 1
mkedge e c
bounding e

produce this result:

-0.15023140314433286 -0.15023140314433286 -0.15023140314433286 1.150231403144332
8 0.90023140314433281 0.15023140314433286

the expected dimensions are:

0. 0. 0. 1. 1. 0.
TagsNo tags attached.
Test case numberbugs moddata_3 bug23575
Attached Files

- Relationships

-  Notes
(0022371)
abv (manager)
2012-11-23 13:37

Tests executed on current master with reverted fix for #566 show only one regression (checkshape faulty: InvalidSameParameterFlag) on

sewing tol_100 J3

There are also some differences in images, notably on sewing tol_100 C5, but none of them seems real problem. CPU and memory usage seem to remained the same
(0059102)
msv (developer)
2016-10-25 16:34

On current master, the computed bounding box looks like this:
Draw[8]> bounding e
-9.9999999999999995e-008 -9.9999999999999995e-008 -9.9999999999999995e-008 1.0000001000000001 0.90023140314433281 
9.9999999999999995e-008

The added value 1e-7 in both +Z and -Z directions is expected, as the method of box computation adds a gap equal to the shape tolerance.

So, I think this bug can be closed.
(0059667)
abv (manager)
2016-11-01 06:33

I agree, this seems to be somehow fixed since OCCT 7.0.0. Please add a test case and close the issue.
(0067413)
git (administrator)
2017-06-14 16:43

Branch CR23575_1 has been created by apv.

SHA-1: 641bc30dfce1b1cf4be0d9a41617c9c6f61b0ee0


Detailed log of new commits:

Author: apv
Date: Wed Jun 14 16:42:49 2017 +0300

    0023575: Bounding box for a planar edge has non-zero dimension in direction orthogonal to an edge plane
    # Test case bugs/moddata_3/bug23575 creation
(0067845)
git (administrator)
2017-07-03 08:45

Branch CR23575 has been deleted by kgv.

SHA-1: d901a42970bec0041fc9093f12a88b8150aaeb51
(0067846)
git (administrator)
2017-07-03 08:45

Branch CR23575_1 has been deleted by kgv.

SHA-1: 641bc30dfce1b1cf4be0d9a41617c9c6f61b0ee0

- Related Changesets
occt: master 4201bf79
Timestamp: 2017-06-14 13:42:49
Author: apv
Committer: bugmaster
Details ] Diff ]
0023575: Bounding box for a planar edge has non-zero dimension in direction orthogonal to an edge plane
# Test case bugs/moddata_3/bug23575 creation
add - tests/bugs/moddata_3/bug23575 Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-11-23 09:24 abv New Issue
2012-11-23 09:24 abv Assigned To => jgv
2012-11-23 10:01 abv Steps to Reproduce Updated View Revisions
2012-11-23 13:37 abv Note Added: 0022371
2012-11-23 17:06 abv Assigned To jgv => abv
2012-11-23 17:06 abv Status new => assigned
2012-11-23 17:07 abv Relationship added related to 0000566
2013-03-02 09:52 abv Target Version 6.6.0 => 6.7.0
2013-10-15 20:57 abv Target Version 6.7.0 => 6.7.1
2014-04-04 18:44 abv Relationship added related to 0023511
2014-04-28 10:55 abv Target Version 6.7.1 => 6.8.0
2014-09-26 11:51 abv Target Version 6.8.0 => 7.1.0
2016-10-25 16:34 msv Note Added: 0059102
2016-10-25 16:34 msv Status assigned => resolved
2016-10-25 16:34 msv Resolution open => unable to reproduce
2016-10-25 16:34 msv Status resolved => feedback
2016-11-01 06:33 abv Note Added: 0059667
2016-11-01 06:33 abv Assigned To abv => apn
2016-11-01 06:33 abv Fixed in Version => 7.0.0
2016-11-01 06:33 abv Target Version 7.1.0 => 7.0.0
2016-11-01 06:33 abv Steps to Reproduce Updated View Revisions
2017-06-14 13:06 bugmaster Assigned To apn => apv
2017-06-14 16:43 git Note Added: 0067413
2017-06-14 16:44 apv Test case number => bugs moddata_3 bug23575
2017-06-14 16:44 apv Assigned To apv => bugmaster
2017-06-14 16:44 apv Status feedback => tested
2017-06-16 17:17 bugmaster Changeset attached => occt master 4201bf79
2017-06-16 17:17 bugmaster Status tested => verified
2017-06-16 17:17 bugmaster Resolution unable to reproduce => fixed
2017-07-03 08:45 git Note Added: 0067845
2017-07-03 08:45 git Note Added: 0067846
2018-02-19 10:50 abv Status verified => closed
2018-02-19 10:50 abv Target Version 7.0.0 => 7.2.0


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker