MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023366Community[OCCT] OCCT:Modeling Algorithmspublic2012-08-02 16:252013-04-29 15:24
ReporterPawel 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2008OS Version32 bit
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0023366: Cut operation produces invalid shape
DescriptionCut operation produces an invalid shape.
Steps To Reproducepload ALL
restore finalTool.brep s1
restore IntersectionSegment.brep s2
bop s1 s2
bopcut cutresult
checkshape cutresult
TagsNo tags attached.
Test case numberbugs modalg_5 bug23366
Attached Fileszip file icon test_shapes.zip (295,675 bytes) 2012-08-02 16:25

- Relationships
related to 0021762closedemv Open CASCADE Integration new Boolean Operation algorithm to OCC 

-  Notes
(0023556)
abv (manager)
2013-03-01 22:37

The problem is not reproduced on current Git master; I guess it is fixed by 0021762. Pawel, could you please check on your side?
(0023558)
Pawel (developer)
2013-03-02 00:19

Hello Andrey,

yes, the problem is not reproduced on current master and can be closed.
(0023559)
abv (manager)
2013-03-02 08:09

Pawel, thanks a lot for prompt commenting!
Igor, please switch the issue to verified.
(0023581)
bugmaster (administrator)
2013-03-05 10:13

Dear MKV,

Please create testing case and switch status to tested.
(0023673)
apn (administrator)
2013-03-12 15:58

Branch CR23366 was created from current state of master. The problem is fixed.
Test case - bugs/modalg_5/bug23366 - OK
Branch contains only test case and will be integrated.

- Related Changesets
occt: master a1cd0db6
Timestamp: 2013-03-12 11:57:07
Author: apn
Details ] Diff ]
0023366: Cut operation produces invalid shape

Added test case for issue 23366.
add - tests/bugs/modalg_5/bug23366 Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-08-02 16:25 Pawel New Issue
2012-08-02 16:25 Pawel Assigned To => bugmaster
2012-08-02 16:25 Pawel File Added: test_shapes.zip
2012-08-17 16:39 bugmaster Assigned To bugmaster => emv
2012-08-17 16:39 bugmaster Status new => assigned
2012-10-23 15:27 abv Target Version 6.5.4 => 6.6.0
2013-03-01 22:32 abv Relationship added related to 0021762
2013-03-01 22:37 abv Note Added: 0023556
2013-03-01 22:37 abv Assigned To emv => Pawel
2013-03-01 22:37 abv Status assigned => feedback
2013-03-02 00:19 Pawel Note Added: 0023558
2013-03-02 00:19 Pawel Status feedback => assigned
2013-03-02 00:19 Pawel Assigned To Pawel => abv
2013-03-02 00:19 Pawel Status assigned => resolved
2013-03-02 08:09 abv Note Added: 0023559
2013-03-02 08:09 abv Assigned To abv => bugmaster
2013-03-02 08:09 abv Status resolved => feedback
2013-03-05 10:12 bugmaster Assigned To bugmaster => mkv
2013-03-05 10:13 bugmaster Note Added: 0023581
2013-03-12 15:58 apn Note Added: 0023673
2013-03-12 15:58 apn Test case number => bugs modalg_5 bug23366
2013-03-12 15:58 apn Assigned To mkv => bugmaster
2013-03-12 15:58 apn Status feedback => tested
2013-03-18 20:48 apn Changeset attached => occt master a1cd0db6
2013-03-18 20:48 apn Assigned To bugmaster => apn
2013-03-18 20:48 apn Status tested => verified
2013-03-18 20:48 apn Resolution open => fixed
2013-04-23 13:35 user533 Status verified => closed
2013-04-29 15:24 user533 Fixed in Version => 6.6.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker