MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023362Community[OCCT] OCCT:DRAWpublic2012-07-28 00:452012-11-16 13:17
ReporterRoman Lygin 
Assigned Tosan 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 6.5.4Fixed in Version[OCCT] 6.5.4 
Summary0023362: Adding DRAW command vsetinteriorstyle
DescriptionAdding a DRAW command to set Aspect_InteriorStyle into shading aspect.
The syntax is made consistent with vsetwidth, and other vset* commands.

(This is also a prerequisite for reproducer of an upcoming bug report)
TagsNo tags attached.
Test case numberchl 935 J0
Attached Files? file icon J0 (636 bytes) 2012-08-02 14:53

- Relationships
parent of 0023363closedsan Community [Regression] Lost gradient background when switching to the hollow interior style 

-  Notes
(0021176)
Roman Lygin (developer)
2012-07-28 00:56

Pushed into Git repository as CR23362 branch.
(0021178)
san (developer)
2012-07-30 09:16

Branch CR23362 reviewed without remarks, ready for testing.
(0021179)
san (developer)
2012-07-30 09:30

Please, integrate this patch with priority as it blocks testing of 0023363.
(0021185)
san (developer)
2012-07-30 14:39
edited on: 2012-07-30 14:45

Dear Roman,

Could you please clean up the legacy French comments in the source code of the new command?
And please make sure your branch is based on recent master branch, this is important due to recent changes in OCCT source tree structure.

(0021194)
Roman Lygin (developer)
2012-07-31 22:03

Sergey:

- French comments translated to English (original version was for the sake of consistency with other vset* commands).
- The initial fix was already applied to master.

Assigning back to you for review.
(0021198)
apn (administrator)
2012-08-02 14:51

Dear BugMaster,
Branch CR23362_1 was created from branches CR23362 and CR23363. It contains changes of both branches.

Branch CR23362_1 (and products from GIT master) was compiled on Linux and Windows platforms and tested.

Regression:
Not detected

Improvements:
Not detected

Testing case:
chl 935 J0 - OK

- Related Changesets
occt: master 99c56d44
Timestamp: 2012-08-03 07:35:36
Author: san
Details ] Diff ]
0023362: Adding DRAW command vsetinteriorstyle

Adding DRAW command vsetinteriorstyle
- Translated French comments to English
mod - src/ViewerTest/ViewerTest.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-07-28 00:45 Roman Lygin New Issue
2012-07-28 00:45 Roman Lygin Assigned To => mkv
2012-07-28 00:56 Roman Lygin Note Added: 0021176
2012-07-30 09:10 san Relationship added parent of 0023363
2012-07-30 09:14 san Status new => resolved
2012-07-30 09:16 san Note Added: 0021178
2012-07-30 09:16 san Status resolved => reviewed
2012-07-30 09:30 san Note Added: 0021179
2012-07-30 09:45 kgv Relationship added related to 0023225
2012-07-30 14:39 san Note Added: 0021185
2012-07-30 14:39 san Assigned To mkv => Roman Lygin
2012-07-30 14:39 san Status reviewed => assigned
2012-07-30 14:45 san Note Edited: 0021185 View Revisions
2012-07-31 22:03 Roman Lygin Note Added: 0021194
2012-07-31 22:04 Roman Lygin Assigned To Roman Lygin => san
2012-07-31 22:04 Roman Lygin Status assigned => resolved
2012-08-02 14:51 apn Note Added: 0021198
2012-08-02 14:51 apn Test case number => chl 935 J0
2012-08-02 14:51 apn Assigned To san => bugmaster
2012-08-02 14:51 apn Status resolved => reviewed
2012-08-02 14:52 apn Status reviewed => tested
2012-08-02 14:53 apn File Added: J0
2012-08-06 16:35 san Changeset attached => occt master 99c56d44
2012-08-06 16:35 san Assigned To bugmaster => san
2012-08-06 16:35 san Status tested => verified
2012-08-06 16:35 san Resolution open => fixed
2012-10-01 14:29 bugmaster Target Version => 6.5.4
2012-11-16 13:14 bugmaster Fixed in Version => 6.5.4
2012-11-16 13:17 bugmaster Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker