MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023351Community[OCCT] OCCT:DRAWpublic2012-07-26 13:262012-11-16 13:17
ReporterPawel 
Assigned Toomy 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 6.5.4Fixed in Version[OCCT] 6.5.4 
Summary0023351: The use of 'if (A) {...} else if (A) {...}' pattern was detected.
DescriptionIn test TestTopOpe_BOOPCommands.cxx
lines 90 and 110
lines 137 and 157

Was this intended?
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0021724)
omy (developer)
2012-10-11 14:58

Fix is integrated to branch CR23351 (see commit message for details). Please review
(0021744)
oan (developer)
2012-10-12 11:40

I have no comments, please test
(0021749)
abv (manager)
2012-10-12 12:58

In the last commit, I suppose that "if (typ != TopAbs_SHAPE)" could be replaced by "else"
(0021777)
omy (developer)
2012-10-16 09:28

I suppose there's no need to replace "if (typ != TopAbs_SHAPE)" by "else" because it will be necessary to change function logic a little and may cause some additional problems.
(0021779)
mkv (tester)
2012-10-16 10:21
edited on: 2012-10-16 10:21

Dear BugMaster,
Branch CR23351 (and master from occt-products) was compiled on Linux and Windows platforms and tested.

Regressions:
Not detected

Improvements:
Not detected

Testing cases:
Not needed


- Related Changesets
occt: master 7da2a6ab
Timestamp: 2012-10-19 14:09:57
Author: omy
Details ] Diff ]
0023351: The use of 'if (A) {...} else if (A) {...}' pattern was detected.
Got rid of duplicated code.
Got rid of redundant conditions' checks in Standard_Integer TOPOC(Draw_Interpretor& interpretor,Standard_Integer na,const char** a) function.
mod - src/TestTopOpe/TestTopOpe_BOOPCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-07-26 13:26 Pawel New Issue
2012-07-26 13:26 Pawel Assigned To => bugmaster
2012-08-17 16:42 bugmaster Assigned To bugmaster => emv
2012-08-17 16:42 bugmaster Status new => assigned
2012-10-09 10:17 oan Assigned To emv => omy
2012-10-11 14:58 omy Note Added: 0021724
2012-10-11 15:00 omy Assigned To omy => oan
2012-10-11 15:15 omy Status assigned => resolved
2012-10-12 11:40 oan Note Added: 0021744
2012-10-12 11:40 oan Status resolved => reviewed
2012-10-12 12:58 abv Note Added: 0021749
2012-10-12 17:47 mkv Assigned To oan => mkv
2012-10-16 09:28 omy Note Added: 0021777
2012-10-16 10:21 mkv Note Added: 0021779
2012-10-16 10:21 mkv Note Edited: 0021779 View Revisions
2012-10-16 10:22 mkv Test case number => Not needed
2012-10-16 10:22 mkv Assigned To mkv => bugmaster
2012-10-16 10:22 mkv Status reviewed => tested
2012-10-23 20:41 omy Changeset attached => occt master 7da2a6ab
2012-10-23 20:45 omy Assigned To bugmaster => omy
2012-10-23 20:45 omy Status tested => verified
2012-10-23 20:45 omy Resolution open => fixed
2012-11-16 13:14 bugmaster Fixed in Version => 6.5.4
2012-11-16 13:17 bugmaster Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker