MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023282Community[OCCT] OCCT:Meshpublic2012-07-14 18:242013-04-29 15:24
ReporterRoman Lygin 
Assigned Tomkv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0023282: Wrong triangulation on cone
DescriptionFor cone with angle from around 90 to 180 the produced triangulation is wrong, see screenshots.
The issue is reproduced with versions 6.5.0-6.5.3.
If to specify an angle 181 (in the DRAW reproducer) then the triangulation is correct.
Steps To Reproducepcone p 50 0 100 18
#pcone p 50 0 100 90 - is also bad
#pcone p 50 0 100 181 - is fine
vdisplay p
vsetdispmode p 1
triangles p
TagsNo tags attached.
Test case numberbugs modalg_5(010) bug23282_1, bug23282_2
Attached Filespng file icon cone-tri1.png (44,360 bytes) 2012-07-14 18:24
png file icon cone-tri2.png (138,092 bytes) 2012-07-14 18:25

- Relationships
duplicate of 0022818closedoan Wrong triangulation of Revolution surface with slice angle <= 180 degree 

-  Notes
(0023930)
oan (developer)
2013-03-29 11:16
edited on: 2013-03-29 11:16

Dear Bugmaster,
this bug has been fixed in the context of 0022818.

Please create test cases and close it, if the results are Ok.

(0023986)
mkv (tester)
2013-04-03 18:02

Dear Bugmaster,

Test cases bugs modalg_5(010) bug23282_1, bug23282_2 was created, tested and pushed into git-branch CR23282.
These test cases are OK.

- Related Changesets
occt: master 0691a5bb
Timestamp: 2013-04-03 13:12:53
Author: mkv
Details ] Diff ]
0023282: Wrong triangulation on cone
Adding test cases for this fix
add - tests/bugs/modalg_5/bug23282_1 Diff ] File ]
add - tests/bugs/modalg_5/bug23282_2 Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-07-14 18:24 Roman Lygin New Issue
2012-07-14 18:24 Roman Lygin Assigned To => jgv
2012-07-14 18:24 Roman Lygin File Added: cone-tri1.png
2012-07-14 18:25 Roman Lygin File Added: cone-tri2.png
2012-11-09 10:46 abv Relationship added duplicate of 0022818
2012-11-09 10:47 abv Category OCCT:Modeling Algorithms => OCCT:Mesh
2013-03-29 11:16 oan Note Added: 0023930
2013-03-29 11:16 oan Note Edited: 0023930 View Revisions
2013-03-29 11:16 oan Assigned To jgv => bugmaster
2013-03-29 11:16 oan Status new => resolved
2013-03-29 11:17 oan Status resolved => reviewed
2013-03-29 18:14 mkv Assigned To bugmaster => mkv
2013-04-03 18:02 mkv Note Added: 0023986
2013-04-03 18:03 mkv Test case number => bugs modalg_5(010) bug23282_1, bug23282_2
2013-04-03 18:03 mkv Assigned To mkv => bugmaster
2013-04-03 18:03 mkv Status reviewed => tested
2013-04-04 19:49 abv Target Version => 6.6.0
2013-04-05 16:39 mkv Changeset attached => occt master 0691a5bb
2013-04-05 16:39 mkv Assigned To bugmaster => mkv
2013-04-05 16:39 mkv Status tested => verified
2013-04-05 16:39 mkv Resolution open => fixed
2013-04-23 13:35 user533 Status verified => closed
2013-04-29 15:24 user533 Fixed in Version => 6.6.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker