MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023242Open CASCADE[OCCT] OCCT:Foundation Classespublic2012-07-04 10:362013-01-16 14:28
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionduplicate 
PlatformMacOSMac OS XOS Version10.7.4
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0023242: OSD_FontMgr in TKernel cause dependence on optional component in system (XLib library)
DescriptionXLib (XQuartz implementation) is an optional component in Mac OS X.
But foundation classes should not depend on optional libraries.

This is suggested to:
- Move OSD_FontMgr class outside TKernel (into TKService for example).
- Implement fonts registration on Mac OS X using native APIs.
TagsNo tags attached.
Test case number
Attached Files

- Relationships
duplicate of 0023466closeddbv Move OSD_FontMgr class outside TKernel 
child of 0023049closedbugmaster Optimize packaging and dependencies of visualization libraries 

-  Notes
(0022956)
kgv (developer)
2013-01-14 13:56
edited on: 2013-01-14 14:13

All tasks implemented within 0023466 and 0023415 patches

(0022980)
bugmaster (administrator)
2013-01-16 14:28

All tasks implemented within fix for 0023466 and 0023415 issues

- Issue History
Date Modified Username Field Change
2012-07-04 10:36 kgv New Issue
2012-07-04 10:36 kgv Assigned To => dbv
2012-08-17 09:24 kgv Relationship added child of 0023049
2012-10-02 11:10 abv Target Version 6.5.4 => 6.6.0
2012-10-09 12:02 dbv Relationship added parent of 0023466
2013-01-14 13:55 kgv Relationship replaced duplicate of 0023466
2013-01-14 13:56 kgv Note Added: 0022956
2013-01-14 13:56 kgv Status new => resolved
2013-01-14 13:56 kgv Resolution open => duplicate
2013-01-14 14:13 kgv Assigned To dbv => bugmaster
2013-01-14 14:13 kgv Status resolved => feedback
2013-01-14 14:13 kgv Note Edited: 0022956 View Revisions
2013-01-16 14:28 bugmaster Note Added: 0022980
2013-01-16 14:28 bugmaster Status feedback => closed
2013-01-16 14:28 bugmaster Fixed in Version => 6.6.0


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker