View Issue Details

IDProjectCategoryView StatusLast Update
0023237Open CASCADEOCCT:Foundation Classespublic2020-09-30 22:36
Reporterabv Assigned Toomy 
PrioritynormalSeverityminor 
Status closedResolutionfixed 
PlatformLinuxOSCentOS 64 bit 
Product Version6.5.3 
Target Version6.6.0Fixed in Version6.6.0 
Summary0023237: OSD_PerfMeter reports wrong (zero) times
DescriptionWhen running on Linux CentOS 64-bit (gcc (GCC) 3.4.6 20060404 (Red Hat 3.4.6-11)), report printed by perf_print_all_meters() is wrong: all CPU times are zero (should be ~ 6 sec in total in my case):

          Perf meter results : enters seconds ´┐Żec/enter
OCCFace::ProjPnt 1, face 0x20092e00 : 40 0.00 0.00
OCCFace::ProjPnt 1, face 0x20091260 : 40 0.00 0.05
OCCFace::ProjPnt 1, face 0x20083160 : 60 0.00 0.03
OCCFace::ProjPnt 1, face 0x200859b8 : 40 0.00 0.05
OCCFace::ProjPnt 1, face 0x2008f238 : 20 0.00 0.05
OCCFace::ProjPnt 1, face 0x2008d1e8 : 20 0.00 0.05
OCCFace::ProjPnt 1, face 0x2007d018 : 20 0.00 0.05
OCCFace::ProjPnt 1, face 0x2008b410 : 2049 0.00 0.07
Boundary test : 5732 0.00 0.01
OCCFace::ProjPnt 1, face 0x2008b1d8 : 307 0.00 0.33
OCCFace::ProjPnt 1, face 0x2008cab8 : 273 0.00 0.16
OCCFace::ProjPnt 1, face 0x2008a830 : 351 0.00 0.18
OCCFace::ProjPnt 1, face 0x2007f0e8 : 482 0.00 0.17
OCCFace::ProjPnt 1, face 0x2008a160 : 355 0.00 0.21
OCCFace::ProjPnt 1, face 0x20077098 : 1915 0.00 0.06

Chrono OCCFace::ProjPoint 1: 6.37 sec
TagsNo tags attached.
Test case numberbugs fclasses(002) bug23237

Relationships

related to 0029451 closedbugmaster Information Message Alert to debug an algorithm or object functionality 

Activities

omy

2012-11-02 13:02

developer   ~0022069

Dear abv,
Fix is is integrated into branch CR23237.
Please, review.

abv

2012-11-02 14:09

manager   ~0022075

No remarks, please test

mkv

2012-11-06 14:11

tester   ~0022100

Dear BugMaster,
Branch CR23237 (and master from occt GIT master) was compiled on Linux and Windows platforms and tested.

Regressions:
Not detected

Improvements:
Not detected

mkv

2012-11-06 15:37

tester   ~0022105

Dear omy,
It is necessary to create test case in QABugs package.

omy

2012-11-15 10:13

developer   ~0022250

Dear abv,
I have added a new testcase into QABugs package.
Please, review.

abv

2012-11-19 12:07

manager   ~0022292

Some remarks:

1. Instead of creating a new file QABugs_20.cxx, consider adding the new code to existing QABugs_19.cxx (which has only 2 commands defined so far).

2. In implementation of test functions in QABugs, please make locally used functions static (or put them to anonymous namespace) to avoid exposing them outside of this file.

3. In implementation of test function in QABugs, use word "Error" instead of "FAIL" to indicate failure.

4. Remark from kgv: in OSD_PerhMeter.h, please consider use of existing macro Standard_EXPORTEXTERNC instead of locally defined OSD_PM_EXPORT; this will also allow to avoid common "extern "C" block.

omy

2012-11-20 10:01

developer   ~0022301

Dear abv,
I've made fixes you mentioned above.
Please, review.

omy

2012-11-23 12:59

developer   ~0022369

The branch was built on Linux CentOS 5.5-64.
The testcase returns Error without fix
and returns OK with the fix.

abv

2012-11-27 13:55

manager   ~0022393

I have rebased the fix on current master and submitted to new branch CR23237_3. The test is corrected to use Boolean operation on shapes instead of computing Fibonacci numbers, as the latter is too fast for timers to produce adequate results. Also added necessary corrections in QANCollection*.h files. Please check on Linux

mkv

2012-11-28 17:05

tester   ~0022416

Dear BugMaster,
Branch CR23237_3 (and products from GIT master) was compiled on Linux and Windows platforms.
There are compilation errors on Linux:

../../../src/QABugs/QABugs_19.cxx: In function 'Standard_Integer OCC23237(Draw_Interpretor&, Standard_Integer, const char**)':
../../../src/QABugs/QABugs_19.cxx:122: error: conversion from 'BRepPrimAPI_MakeBox' to 'TopoDS_Shape' is ambiguous
../../../inc/BRepPrimAPI_MakeBox.hxx:79: note: candidates are: BRepPrimAPI_MakeBox::operator TopoDS_Solid()
../../../inc/BRepPrimAPI_MakeBox.hxx:76: note: BRepPrimAPI_MakeBox::operator TopoDS_Shell()
../../../inc/BRepBuilderAPI_MakeShape.hxx:55: note: BRepBuilderAPI_MakeShape::operator TopoDS_Shape() const
../../../src/QABugs/QABugs_19.cxx:123: error: conversion from 'BRepPrimAPI_MakeSphere' to 'TopoDS_Shape' is ambiguous
../../../inc/BRepPrimAPI_MakeOneAxis.hxx:52: note: candidates are: BRepPrimAPI_MakeOneAxis::operator TopoDS_Solid()
../../../inc/BRepPrimAPI_MakeOneAxis.hxx:49: note: BRepPrimAPI_MakeOneAxis::operator TopoDS_Shell()
../../../inc/BRepPrimAPI_MakeOneAxis.hxx:46: note: BRepPrimAPI_MakeOneAxis::operator TopoDS_Face()
../../../inc/BRepBuilderAPI_MakeShape.hxx:55: note: BRepBuilderAPI_MakeShape::operator TopoDS_Shape() const

abv

2012-11-29 06:58

manager   ~0022428

Please indicate version of GCC that produce these errors.

The code is refactored hoping to eliminate the problem, see branch CR23237_3

bugmaster

2012-11-29 10:33

administrator   ~0022429

CR23237_3 was tested on Mandriva 2010
> gcc --version
gcc (GCC) 4.4.1

mkv

2012-11-30 15:33

tester   ~0022484

Dear BugMaster,
Branch CR23237_3 (and products from GIT master) was compiled on Linux and Windows platforms and tested.

Regressions:
Not detected

Improvements:
Not detected

Testing cases:
bugs fclasses(002) bug23237 - OK.

Related Changesets

occt: master c2ae831c

2012-11-30 12:17:28

omy

Details Diff
0023237: OSD_PerfMeter reports wrong (zero) times

Commit details:
1) in OSD_PerfMeter, use static functions of OSD_Chronometer class for time measurements instead of specific code to avoid incorrect results on CentOS (due to wrong valus of CLK_TCK);
2) changed definition of OSD_PerfMeter from .c to .cxx to avoid problems with C-functions;
3) fixed OSD_PerfMeter.h for building on Unix systems;
4) removed platform-specific #defines;
5) added test case for OSD_PerfMeter as bugs fclasses bug23237;
6) Removed DebugTools package (duplicates OSD_PerfMeter)
7) Avoid compiler (GCC) error casting BRepPrimAPI_Make* instances to TopoDS_Shape
Affected Issues
0023237
rm - src/DebugTools/DebugTools.h Diff File
rm - src/DebugTools/FILES Diff File
rm - src/DebugTools/Perf.cxx Diff File
mod - src/OSD/FILES Diff File
mod - src/OSD/OSD_PerfMeter.h Diff File
mod - src/QABugs/QABugs_19.cxx Diff File
mod - src/QANCollection/QANCollection1.cxx Diff File
mod - src/QANCollection/QANCollectionTest.cxx Diff File
mod - src/QANCollection/QANCollection_PerfArrays.hxx Diff File
mod - src/QANCollection/QANCollection_PerfLists.hxx Diff File
mod - src/QANCollection/QANCollection_PerfMaps.hxx Diff File
mod - src/QANCollection/QANCollection_PerfSparseArray.hxx Diff File
mod - src/TKQADraw/PACKAGES Diff File
add - tests/bugs/fclasses/bug23237 Diff File

Issue History

Date Modified Username Field Change
2012-07-03 11:56 abv New Issue
2012-07-03 11:56 abv Assigned To => abv
2012-10-18 12:56 abv Assigned To abv => omy
2012-10-18 15:02 omy Status new => assigned
2012-10-29 13:03 abv Target Version 6.5.4 => 6.6.0
2012-11-02 13:02 omy Note Added: 0022069
2012-11-02 13:02 omy Assigned To omy => abv
2012-11-02 13:02 omy Status assigned => resolved
2012-11-02 14:09 abv Note Added: 0022075
2012-11-02 14:09 abv Assigned To abv => bugmaster
2012-11-02 14:09 abv Status resolved => reviewed
2012-11-02 15:50 mkv Assigned To bugmaster => mkv
2012-11-06 14:11 mkv Note Added: 0022100
2012-11-06 14:11 mkv Assigned To mkv => abv
2012-11-06 14:11 mkv Status reviewed => feedback
2012-11-06 15:24 abv Description Updated
2012-11-06 15:37 mkv Note Added: 0022105
2012-11-06 15:38 mkv Assigned To abv => omy
2012-11-06 15:38 mkv Status feedback => assigned
2012-11-15 10:13 omy Note Added: 0022250
2012-11-15 10:13 omy Assigned To omy => abv
2012-11-15 10:13 omy Status assigned => resolved
2012-11-19 12:07 abv Note Added: 0022292
2012-11-19 12:07 abv Assigned To abv => omy
2012-11-19 12:07 abv Status resolved => assigned
2012-11-20 10:01 omy Note Added: 0022301
2012-11-20 10:01 omy Assigned To omy => abv
2012-11-20 10:01 omy Status assigned => resolved
2012-11-23 12:59 omy Note Added: 0022369
2012-11-27 13:55 abv Note Added: 0022393
2012-11-27 14:37 abv Assigned To abv => bugmaster
2012-11-27 14:37 abv Status resolved => reviewed
2012-11-27 16:50 mkv Assigned To bugmaster => mkv
2012-11-28 17:05 mkv Note Added: 0022416
2012-11-28 17:05 mkv Assigned To mkv => omy
2012-11-28 17:05 mkv Status reviewed => assigned
2012-11-29 06:58 abv Note Added: 0022428
2012-11-29 06:58 abv Status assigned => resolved
2012-11-29 06:58 abv Assigned To omy => mkv
2012-11-29 06:58 abv Status resolved => reviewed
2012-11-29 10:33 bugmaster Note Added: 0022429
2012-11-30 15:33 mkv Note Added: 0022484
2012-11-30 15:33 mkv Test case number => bugs fclasses(002) bug23237
2012-11-30 15:33 mkv Assigned To mkv => bugmaster
2012-11-30 15:33 mkv Status reviewed => tested
2012-12-04 13:21 omy Changeset attached => occt master c2ae831c
2012-12-04 13:21 omy Assigned To bugmaster => omy
2012-12-04 13:21 omy Status tested => verified
2012-12-04 13:21 omy Resolution open => fixed
2012-12-10 17:16 omy Changeset attached => occt master c2ae831c
2013-04-23 13:37 aiv Status verified => closed
2013-04-29 15:21 aiv Fixed in Version => 6.6.0
2020-09-30 22:36 kgv Relationship added related to 0029451