MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023177Community[OCCT] OCCT:Modeling Algorithmspublic2012-05-27 09:022017-09-29 16:25
ReporterRoman Lygin 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0023177: Intersection of plane and torus misses a result and never produces analytical result
DescriptionTwo issues:
1. Missing solution
2. Unlike other elementary-elementary cases, torus/plane seems to never recognize analytical cases (e.g. circle or ellipse) and always produce B-Spline
Steps To Reproducetorus t 100 10
plane p1 0 0 0 0 1 0
intersect r1 t p1
#only one solution is produced not two, and it is b-spline, not circle

plane p2 0 0 0 1 0 0
intersect r2 t p2
#two solutions are produced, and both are b-splines, not circles

plane p3 5 0 0 1 0 0
intersect r3 t p3
#two solutions are produced, and both are b-splines, not ellipses
TagsNo tags attached.
Test case numberbugs modalg_6 bug23177_1, bug23177_2
Attached Files

- Relationships

-  Notes
(0020609)
abv (manager)
2012-05-31 08:15

The first problem is confirmed: one curve is missing. Note that DRAW command intersect should output list of objects it produced.

For the second and third problems, I have serious doubts. First, strictly speaking, intersection of torus and plane is never an ellipse: it is either a circle or a more complex curve. Recognition of special degenerated cases like example 2 (when plane is aligned with axes of the torus) to produce circle(s) instead of b-spline(s) would require additional effort and introduce (unnecessary) complexity.
(0020627)
Roman Lygin (developer)
2012-05-31 22:38

Andrey, my error on ellipse section - please disregard that. Indeed, it's either circles or other types
(a few quick links - http://isolatium.uhh.hawaii.edu/m206L/student/torus/torus.htm, [^] http://mathworld.wolfram.com/ToricSection.html, [^] http://en.wikipedia.org/wiki/Villarceau_circles [^])

Anyway, having an analytical solution is good for downstream algorithms which will use result of intersection.
It *will* require additional effort but "complexity" will be consistent with other supported cases in IntAna (cylinders, cones, spheres,...).
(0066690)
abv (manager)
2017-05-28 19:10

The described problems have been fixed: it works as expected since OCCT 6.9.1. I suggest we should add a test case and close the issue.
(0066728)
msv (developer)
2017-05-29 15:42

Dear Nikolay, please create a test case for this bug.
(0066821)
git (administrator)
2017-05-29 17:37

Branch CR23177 has been created by nbv.

SHA-1: 5cf58879059fb35e871369667c8a973c6046e109


Detailed log of new commits:

Author: nbv
Date: Mon May 29 17:35:06 2017 +0300

    0023177: Intersection of plane and torus misses a result and never produces analytical result
    
    Creation of the test case.
(0066822)
nbv (developer)
2017-05-29 17:37

Dear Mikhail,

Please review CR23177 branch.
(0066839)
msv (developer)
2017-05-29 19:00

Reviewed.
Mote that there is no need to compile occt and perform all tests.
(0066866)
apv (tester)
2017-05-30 12:25

Dear BugMaster,

Please integrate branch CR23177 into the occt git-repository master.
(0066991)
git (administrator)
2017-06-02 10:45

Branch CR23177 has been deleted by inv.

SHA-1: 5cf58879059fb35e871369667c8a973c6046e109

- Related Changesets
occt: master 75b9688a
Timestamp: 2017-05-29 14:35:06
Author: nbv
Committer: bugmaster
Details ] Diff ]
0023177: Intersection of plane and torus misses a result and never produces analytical result

Creation of the test case.
add - tests/bugs/modalg_6/bug23177_1 Diff ] File ]
add - tests/bugs/modalg_6/bug23177_2 Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-05-27 09:02 Roman Lygin New Issue
2012-05-27 09:02 Roman Lygin Assigned To => jgv
2012-05-31 08:15 abv Note Added: 0020609
2012-05-31 08:15 abv Status new => assigned
2012-05-31 22:38 Roman Lygin Note Added: 0020627
2017-05-28 19:10 abv Note Added: 0066690
2017-05-28 19:10 abv Assigned To jgv => bugmaster
2017-05-28 19:10 abv Status assigned => feedback
2017-05-29 15:42 msv Note Added: 0066728
2017-05-29 15:42 msv Assigned To bugmaster => nbv
2017-05-29 15:42 msv Status feedback => assigned
2017-05-29 17:37 git Note Added: 0066821
2017-05-29 17:37 nbv Note Added: 0066822
2017-05-29 17:37 nbv Assigned To nbv => msv
2017-05-29 17:37 nbv Status assigned => resolved
2017-05-29 19:00 msv Note Added: 0066839
2017-05-29 19:00 msv Assigned To msv => bugmaster
2017-05-29 19:00 msv Status resolved => reviewed
2017-05-29 19:21 apv Assigned To bugmaster => apv
2017-05-30 07:19 emv Relationship added related to 0024470
2017-05-30 12:08 apv Test case number => bugs modalg_6 bug23177_1, bug23177_2
2017-05-30 12:25 apv Note Added: 0066866
2017-05-30 12:25 apv Assigned To apv => bugmaster
2017-05-30 12:25 apv Status reviewed => tested
2017-06-01 09:57 bugmaster Target Version => 7.2.0
2017-06-02 10:28 bugmaster Changeset attached => occt master 75b9688a
2017-06-02 10:28 bugmaster Status tested => verified
2017-06-02 10:28 bugmaster Resolution open => fixed
2017-06-02 10:45 git Note Added: 0066991
2017-09-29 16:18 user533 Fixed in Version => 7.2.0
2017-09-29 16:25 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker