MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023146Community[OCCT] OCCT:Modeling Algorithmspublic2012-05-06 19:522012-11-16 13:18
ReporterQbProg 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version32 bit
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 6.5.4Fixed in Version[OCCT] 6.5.4 
Summary0023146: Suspicious if (4)
Descriptionsrc\ShapeFix\ShapeFix_Face.cxx , line 592

 if(iter.Value().Orientation() != TopAbs_FORWARD ||
           iter.Value().Orientation() != TopAbs_REVERSED) {

the result is always true
---
also at line 1707

(wi.Value().Orientation() != TopAbs_FORWARD || wi.Value().Orientation() != TopAbs_REVERSED))

always true
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
duplicate of 0023303closedPawel Expression always true in ShapeFix_Face.cxx 
child of 0023132closedomy Suspicious code snippets 

-  Notes
(0021756)
omy (developer)
2012-10-12 15:38

Dear BugMaster,
This issue has already been fixed. Please, validate and close.
(0021815)
mkv (tester)
2012-10-17 12:12

Dear BugMaster,
This issue has already been fixed (see, example, IR-2012-10-16-master-occt).
(0021860)
bugmaster (administrator)
2012-10-19 18:41

Problem was already fixed during work on OCCT 6.5.4

- Issue History
Date Modified Username Field Change
2012-05-06 19:52 QbProg New Issue
2012-05-06 19:52 QbProg Assigned To => jgv
2012-05-07 09:19 abv Relationship added child of 0023132
2012-05-07 09:24 abv Assigned To jgv => dbv
2012-05-07 09:24 abv Status new => assigned
2012-05-07 09:25 abv Target Version => 6.5.4
2012-07-17 16:57 Pawel Relationship added duplicate of 0023303
2012-10-09 18:43 oan Assigned To dbv => omy
2012-10-11 15:09 omy Note Added: 0021725
2012-10-11 15:12 omy Assigned To omy => oan
2012-10-11 15:14 omy Note Added: 0021726
2012-10-11 15:14 omy Status assigned => resolved
2012-10-12 15:29 omy Note Deleted: 0021726
2012-10-12 15:38 omy Note Deleted: 0021725
2012-10-12 15:38 omy Note Added: 0021756
2012-10-12 15:42 oan Assigned To oan => omy
2012-10-12 15:44 oan Status resolved => reviewed
2012-10-12 15:57 omy Assigned To omy => bugmaster
2012-10-17 12:12 mkv Note Added: 0021815
2012-10-17 12:12 mkv Test case number => Not needed
2012-10-17 12:12 mkv Status reviewed => tested
2012-10-19 18:41 bugmaster Note Added: 0021860
2012-10-19 18:41 bugmaster Status tested => verified
2012-10-19 18:41 bugmaster Fixed in Version => 6.5.4
2012-10-19 18:41 bugmaster Resolution open => fixed
2012-11-16 13:18 bugmaster Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker