MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023062Open CASCADE[OCCT] OCCT:DRAWpublic2012-04-03 12:432019-09-04 23:49
Reporterepa 
Assigned Toika 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.3.1 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0023062: Incorrect display of edge in draw axo viewer
DescriptionIncorrect display of edge in draw axo viewer
Steps To Reproduce- display attached edge in draw(restore ...; axo; fit) Complete circle is displayed
- explode it on vertices
- display it is View3D(vdisplay a)
Result in draw axo view is not correct
TagsNo tags attached.
Test case numberbugs vis bug23062
Attached Files? file icon ProblemWire.brep (63,593 bytes) 2012-04-03 12:43

- Relationships
parent of 0028144closedkgv Modeling Data, GeomAdaptor_Curve - regression in comparison of version OCCT654 

-  Notes
(0022884)
ika (developer)
2012-12-28 16:18

Periodic curves were handled incorrect, it was fixed.
Git branch CR23062 is ready to be reviewed.

Dear GKA,
Please review.
(0022891)
gka (developer)
2012-12-29 16:29

Branch CR23062 is ready to test
(0023097)
mkv (tester)
2013-01-23 17:34

Dear BugMaster,

Branch CR23062 (and products from GIT master) was compiled on Linux and
Windows platforms and tested.

Regressions:
Not detected

Improvements:
Not detected

Testing cases:
bugs vis bug23062 - OK.

- Related Changesets
occt: master f34eec8f
Timestamp: 2013-01-25 10:49:08
Author: ika
Details ] Diff ]
0023062: Incorrect display of edge in draw axo viewer

Update first and last parameters of intervals, because they should be at same period like other values.
mod - src/GeomAdaptor/GeomAdaptor_Curve.cxx Diff ] File ]
mod - tests/bugs/end Diff ] File ]
add - tests/bugs/vis/bug23062 Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-04-03 12:43 epa New Issue
2012-04-03 12:43 epa Assigned To => mkv
2012-04-03 12:43 epa File Added: ProblemWire.brep
2012-04-03 12:43 epa Assigned To mkv => abv
2012-04-03 15:17 kgv Product Version => 6.3.1
2012-04-03 15:17 kgv Target Version => 6.5.4
2012-10-18 12:58 abv Assigned To abv => ika
2012-10-20 10:43 abv Status new => assigned
2012-10-23 18:41 abv Target Version 6.5.4 => 6.6.0
2012-12-28 16:18 ika Note Added: 0022884
2012-12-28 16:18 ika Assigned To ika => gka
2012-12-28 16:18 ika Status assigned => resolved
2012-12-29 16:29 gka Note Added: 0022891
2012-12-29 16:29 gka Status resolved => reviewed
2013-01-11 19:11 mkv Assigned To gka => mkv
2013-01-23 17:34 mkv Note Added: 0023097
2013-01-23 17:34 mkv Test case number => bugs vis bug23062
2013-01-23 17:34 mkv Assigned To mkv => bugmaster
2013-01-23 17:34 mkv Status reviewed => tested
2013-01-28 18:06 ika Changeset attached => occt master f34eec8f
2013-01-28 18:07 ika Assigned To bugmaster => ika
2013-01-28 18:07 ika Status tested => verified
2013-01-28 18:07 ika Resolution open => fixed
2013-04-23 13:36 aiv Status verified => closed
2013-04-29 15:21 aiv Fixed in Version => 6.6.0
2019-09-04 23:49 kgv Relationship added parent of 0028144


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker