MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023025Community[OCCT] OCCT:Modeling Algorithmspublic2012-03-19 16:042017-07-31 17:46
ReporterRoberto Ciarloni 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version64 bit
Product Version[OCCT] 6.5.1 
Target VersionFixed in Version[OCCT] 6.9.0 
Summary0023025: OCC exception is raised when making an extrusion with draft angle from a simple line
DescriptionThe bug is visible making an extrusion with draft angle from a simple line, in debug mode: R is (0.0, 0.0, 0.0) and an OCC exception is raised. When not in debug mode, the execution loops.
Steps To ReproduceYou can reproduce the problem creating an extrusion with draft angle (0.2 radiants or other) from the curves in attached u.brep.

--------------------------
WRONG SCRIPT

restore u.brep
draft rr u 1 1 0 0.2 100
#Standard_ConstructionError: BRepFill_Draft

--

GOOD SCRIPT

restore u.brep
explode u e
wire w u_1 u_2 u_3

draft rr w 0 0 1 0.2 100
# Result is OK

checkshape rr
This shape seems to be valid
TagsNo tags attached.
Test case numberbugs moddata_3 bug23025
Attached Files? file icon U.brep (1,171 bytes) 2012-03-19 16:04
cxx file icon BRepFill_Draft.cxx (24,280 bytes) 2012-03-19 16:10

- Relationships

-  Notes
(0020041)
Roberto Ciarloni (reporter)
2012-03-19 16:09

Fix in attachment
 old code:
for (ii=2; ii<=Nb; ii++) {
    gp_Vec R(Centre, Pnts(ii));
    Angle += Ref.AngleWithRef(R, Normal);
    Ref = R;
}
return (Angle >= 0);

new code:
for (ii=2; ii<=Nb; ii++) {
    gp_Vec R(Centre, Pnts(ii));
    if (R.Magnitude() <= gp::Resolution())
      return (Angle + 10000. * RealEpsilon() >= 0);
    Angle += Ref.AngleWithRef(R, Normal);
    Ref = R;
}
return (Angle + 10000. * RealEpsilon() >= 0);
(0068446)
nbv (developer)
2017-07-19 18:10

I have checked the situation on the current MASTER.

1. File U.brep contains compound of edges (not a wire). As result, BRepFill_Draft does not work with such data. See WRONG SCRIPT in Steps To Reproduce.

2. The algorithm works properly if we enter wire to it. See GOOD SCRIPT.

So, the problem is not reproduced on the current MASTER. The bug can be closed.
(0068447)
nbv (developer)
2017-07-19 18:11

Dear Mikhail,

Please process this issue to close it.
(0068459)
msv (developer)
2017-07-19 21:56

Please close as not reproduced.
(0068596)
git (administrator)
2017-07-21 17:00

Branch CR23025 has been created by mkv.

SHA-1: 0a147a3b56afed17a033f5fbeb397be74ae3b24f


Detailed log of new commits:

Author: mkv
Date: Fri Jul 21 17:00:38 2017 +0300

    Test for 0023025: OCC exception is raised when making an extrusion with draft angle from a simple line
(0068597)
mkv (tester)
2017-07-21 17:01

Dear BugMaster,
problem described in issue is not reproduced on current state of OCCT.
(0068925)
git (administrator)
2017-07-31 17:46

Branch CR23025 has been deleted by kgv.

SHA-1: 0a147a3b56afed17a033f5fbeb397be74ae3b24f

- Issue History
Date Modified Username Field Change
2012-03-19 16:04 Roberto Ciarloni New Issue
2012-03-19 16:04 Roberto Ciarloni Assigned To => jgv
2012-03-19 16:04 Roberto Ciarloni File Added: U.brep
2012-03-19 16:09 Roberto Ciarloni Note Added: 0020041
2012-03-19 16:10 Roberto Ciarloni File Added: BRepFill_Draft.cxx
2012-03-19 17:09 szy Severity block => integration request
2017-07-19 18:04 nbv Steps to Reproduce Updated View Revisions
2017-07-19 18:10 nbv Note Added: 0068446
2017-07-19 18:11 nbv Note Added: 0068447
2017-07-19 18:11 nbv Assigned To jgv => msv
2017-07-19 18:11 nbv Status new => resolved
2017-07-19 18:22 mkv Priority urgent => normal
2017-07-19 21:56 msv Note Added: 0068459
2017-07-19 21:56 msv Assigned To msv => bugmaster
2017-07-19 21:56 msv Status resolved => feedback
2017-07-20 21:19 bugmaster Assigned To bugmaster => mkv
2017-07-21 17:00 git Note Added: 0068596
2017-07-21 17:01 mkv Assigned To mkv => bugmaster
2017-07-21 17:01 mkv Note Added: 0068597
2017-07-21 17:02 mkv Test case number => bugs moddata_3 bug23025
2017-07-21 17:03 mkv Status feedback => tested
2017-07-31 11:12 bugmaster Status tested => closed
2017-07-31 11:12 bugmaster Resolution open => fixed
2017-07-31 11:12 bugmaster Fixed in Version => 6.9.0
2017-07-31 17:46 git Note Added: 0068925


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker