MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023001Open CASCADE[OCCT] OCCT:Visualizationpublic2012-02-21 15:542012-03-29 17:26
Reporterapl 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version 
Target Version[OCCT] 6.5.3Fixed in Version[OCCT] 6.5.3 
Summary0023001: Mistake in OpenGl_FrameBuffer::IsValidDepthBuffer
DescriptionThis issue is found in updated OpenGl_GraphicDriver.
Invalid comparsion that leads to print error in std::cerr when destroying OpenGl_FrameBuffer.

myGlTextureId != NO_RENDERBUFFER;

myGlDepthRBId should be used instead
Steps To Reproducepload MODELING AISV
vinit
box b 10 10 10
vdisplay b
vprintview 300 400 C:/test5.bmp

Error message in console:
OpenGl_FrameBuffer::Release() called with invalid OpenGl_Context!
TagsNo tags attached.
Test case numberchl 934 T6
Attached Files? file icon T6 (942 bytes) 2012-02-28 17:11

- Relationships
related to 0022337closedbugmaster Community V3d_View::Print crashes in OCCT 6.5.0 
related to 0023003closedabv Open CASCADE Photos of AIS Viewer are corrupted on Windows if tests are executed remotely 
related to 0023015closedapl Open CASCADE TKOpenGl redesign regression in text printing 

-  Notes
(0019700)
apl (developer)
2012-02-21 16:35

Dear Sergey,

Could you please review the branch http://svn/svn/occt/branches/OCC23301 [^] ?

The error message was also reproduced in OpenGl_GraphicDriver::Print operation because the allocated frame buffer wasn't released correctly.
(0019702)
apl (developer)
2012-02-21 16:53

Sorry, please check the branch http://svn/svn/occt/branches/OCC23001 [^]
(0019704)
san (developer)
2012-02-21 17:17
edited on: 2012-02-21 17:18

The SVN branch reviewed without remarks, ready for testing.

Dear bugmaster,

Please, check that the test case chl 934 A9 verifies stderr contents!
This issue is clearly a regression resulted from the test case ignoring stderr output of vprintview command.

(0019705)
san (developer)
2012-02-21 17:21

Also please check the test cases using vdump command, its stderr output should also be checked.
(0019734)
mkv (tester)
2012-02-22 15:41

Dear BugMaster,
Workbench KAS:dev:mkv-23001-occt was created from SVN branch http://svn/svn/occt/branches/OCC23001 [^]
(and mkv-23001-products from trunk) and compiled on Linux platform.

There are not regressions in mkv-23001-products regarding to KAS:dev:products-20120217-opt

See results in /QADisk/occttests/results/KAS/dev/mkv-23001-products_21022012/lin
See reference results in /QADisk/occttests/results/KAS/dev/products-20120217-opt_17022012/lin
See test cases in /QADisk/occttests/tests/ED
N.B. In order to launch testing case you can make use the following instructions
http://doc/doku.php?id=occt:certification [^]
(0019777)
san (developer)
2012-02-24 17:31

Reminder sent to: apl

Dear APL,

QA team experience some strange effects when testing your patch, could you please contact them and analyze the effects?
I see one major difference from a normal working mode: they use "remote desktop" connection from one Windows station to another.
(0019807)
mkv (tester)
2012-02-28 17:11

Dear BugMaster,
Workbench KAS:dev:mkv-23001-occt was created from SVN branch http://svn/svn/occt/branches/OCC23001 [^]
and compiled on WNT platform.

Test case for this bug is chl/934/T6.

It is OK if we use local Windows station.

It is KO if we use "remote desktop" connection from one Windows station to another.
There are difference messages, for example:
"Save to file operation failed. This operation may fail
if you don't have enough available memory, then you can
use smaller dimensions for the output file"
(0020057)
apl (developer)
2012-03-21 12:32

Dear Bugmaster,

The problems with remote desktop related to Microsoft GL context limitations for remote desktop connection.

Printing operation fails due to unavailable GL "Frame buffer objects" extension.

The similar issue and possible solutions clearly described in 0023003. For example, Mesa3D software implementation can be used.
(0020067)
mkv (tester)
2012-03-21 16:10

Dear BugMaster,
SVN branch http://svn/svn/occt/branches/OCC23001 [^] has been moved to GIT CR23001 one.
(0020085)
bugmaster (administrator)
2012-03-22 11:05

Integrated into master

- Related Changesets
occt: master 96352003
Timestamp: 2012-03-21 11:59:42
Author: apl
Committer: bugmaster
Details ] Diff ]
0023001: Mistake in OpenGl_FrameBuffer::IsValidDepthBuffer
mod - src/OpenGl/OpenGl_FrameBuffer.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_Workspace_2.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-02-21 15:54 apl New Issue
2012-02-21 15:54 apl Assigned To => apl
2012-02-21 16:33 apl Status new => assigned
2012-02-21 16:35 apl Note Added: 0019700
2012-02-21 16:35 apl Assigned To apl => san
2012-02-21 16:35 apl Status assigned => resolved
2012-02-21 16:53 apl Note Added: 0019702
2012-02-21 17:12 apl Steps to Reproduce Updated View Revisions
2012-02-21 17:15 san Relationship added related to 0022337
2012-02-21 17:17 san Note Added: 0019704
2012-02-21 17:17 san Assigned To san => bugmaster
2012-02-21 17:17 san Status resolved => reviewed
2012-02-21 17:18 san Note Edited: 0019704 View Revisions
2012-02-21 17:21 san Note Added: 0019705
2012-02-21 17:23 mkv Assigned To bugmaster => mkv
2012-02-22 15:41 mkv Note Added: 0019734
2012-02-24 17:31 san Note Added: 0019777
2012-02-28 17:11 mkv File Added: T6
2012-02-28 17:11 mkv Note Added: 0019807
2012-02-28 17:12 mkv Assigned To mkv => apl
2012-02-28 17:12 mkv Status reviewed => assigned
2012-03-21 12:22 apl Relationship added related to 0023015
2012-03-21 12:32 apl Note Added: 0020057
2012-03-21 12:32 apl Status assigned => resolved
2012-03-21 12:32 apl Assigned To apl => bugmaster
2012-03-21 12:32 apl Status resolved => reviewed
2012-03-21 12:33 apl Relationship added related to 0023003
2012-03-21 14:21 mkv Assigned To bugmaster => mkv
2012-03-21 16:10 mkv Note Added: 0020067
2012-03-21 16:11 mkv Test case number => chl 934 T6
2012-03-21 16:11 mkv Assigned To mkv => bugmaster
2012-03-21 16:11 mkv Status reviewed => tested
2012-03-22 11:02 bugmaster Target Version => 6.5.3
2012-03-22 11:05 bugmaster Note Added: 0020085
2012-03-22 11:05 bugmaster Status tested => verified
2012-03-22 11:05 bugmaster Resolution open => fixed
2012-03-22 11:05 bugmaster Assigned To bugmaster => apl
2012-03-29 17:26 bugmaster Changeset attached => occt master 96352003


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker