MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022974Open CASCADE[OCCT] OCCT:Visualizationpublic2012-02-02 13:582014-05-05 13:38
Reportervro 
Assigned Toaba 
PrioritylowSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2005OS Version32 bit
Product Version[OCCT] 6.5.0 
Target Version[OCCT] 6.7.1Fixed in Version[OCCT] 6.7.1 
Summary0022974: A crash on dragging a dimension for an object with a big coordinate
DescriptionA diameter or a radius dimension crashes on attempt to drag it if a coordinate of the dimension is very great, for example X = 1e18 mm.
Steps To ReproduceA scenario to reproduce:
1. Create a circle with radius = 1 and X = 1e18;
2. Display a diameter or a radius dimension in the viewer 3d;
3. Drag the dimension by mouse -> Crash.

The test case for diameter and radius dimensions:

vpoint p1 0 0 30
vpoint p2 30 0 0
vpoint p3 60 0 30
vcircle circle p1 p2 p3 0
# create radius dimension
vdimension radius name=dim circle
# For diameter dimension use command below
#vdimension diameter name=dim circle

vdisplay dim

vzoom 0.05
vpan -150 150

vmovedim dim
# press ctrl and press new text position
vfit
TagsNo tags attached.
Test case numberNo opportunity to create test case
Attached Files

- Relationships
parent of 0023159closedvro Community Draw commands vradiusdim and vdiameterdim on Linux don't work (crash) 

-  Notes
(0019359)
vro (developer)
2012-02-02 15:15

Dear Kirill,
Review please my changes in 22974.
There are some minor changes in:
AIS_RadiusDimension.cxx
AIS_DiameterDimension.cxx
DsgPrs_DiameterPresentation.cxx
Select3D_SensitiveTriangulation.cxx
There are just small checks on validity of data (null vector, colinear vectors, ...).
(0019363)
kgv (developer)
2012-02-02 16:47

2vro, please avoid meaningless commit description like 'A fix of the bug' and emotional comments in it like 'Code duplication is removed. Thank you! :-)'!

Dear Bugmaster, please test the patch.
(0019432)
apn (administrator)
2012-02-07 13:28
edited on: 2012-02-07 15:29

Dear BugMaster,
 Workbench KAS:dev:apn-22974-occt was created from SVN branch http://svn/svn/occt/branches/22974 [^]
 (and apn-22974-products from trunk) and compiled on Linux and WIndows platforms.
 
 There are not regressions in apn-22974-products regarding to KAS:dev:products-20120203-opt
 
Unstable test cases:
che 003 C3
chl 929 L5
 
Commands "vradiusdim" and "vdiameterdim" dont'work. That's why we don't have any opportunity to reproduce and check this fix.

 See results in /QADisk/occttests/results/KAS/dev/ apn-22974-products_06022012/lin
 See reference results in /QADisk/occttests/results/KAS/dev/products-20120203-opt_03022012/lin
 See test cases in /QADisk/occttests/tests/ED

(0019519)
bugmaster (administrator)
2012-02-10 17:34

Fix will not be verified till DRAW command vradiusdim, vdiameterdim and etc will be debugged.
(0019716)
bugmaster (administrator)
2012-02-22 11:31

Vlad,

DRAW command vradiusdim, vdiameterdim and etc must be debugged in order to check fix
(0019718)
vro (developer)
2012-02-22 11:35

Dear bugmaster,

What time in HRMT might I use to perform this job?
(0019737)
san (developer)
2012-02-22 16:13

Usually it is the same as for the bug correction itself. Creation/debugging of necessary DRAW commands is always implied.
(0019922)
abv (manager)
2012-03-12 07:40

Dear Vlad,

Please finalize the fix during this week to ensure it can be taken to OCCT 6.5.3
(0019963)
vro (developer)
2012-03-14 10:21

The draw-command vradiusdim is corrected. The modified file ViewerTest_ViewerCommands.cxx is put into a branch http://svn/svn/occt/branches/22974 [^]
(0020522)
abv (manager)
2012-05-12 17:29

Please move the changes to Git and correct comparisons of vector to zero in AIS_DiameterDimension.cxx:193 and DsgPrs_DiameterPresentation.cxx:60: square distance should be compared to squared tolerance
(0020525)
vro (developer)
2012-05-14 12:13

The branch is successfully moved to Git + the comparison operation is corrected.
(0020526)
vro (developer)
2012-05-14 12:15

The branch name in Git is CR22974.
(0020528)
abv (manager)
2012-05-14 15:14

No remarks, please test
(0020535)
apn (administrator)
2012-05-15 12:06

Dear BugMaster,
        Workbench KAS:dev:apn-22974-1-occt was created from git branch CR22974(and apn-22974-1-products from svn trunk) and compiled on Linux platform.
    
        There are not regressions in apn-22974-1-products regarding to KAS:dev:products-20120415-opt
       
        There are not improvements in apn-22974-1-products regarding to KAS:dev:products-20120415-opt
   
        Draw commands vradiusdim, vdiameterdim and etc still crash on dragging a dimension for an object even with a small coordinate
    
        See results in /QADisk/occttests/results/KAS/dev/apn-22974-1-products_14052012/lin
        See reference results in /QADisk/occttests/results/KAS/dev/products-20120415-opt_13042012/lin
        See test cases in /QADisk/occttests/tests/ED
(0020538)
vro (developer)
2012-05-16 10:11

Selection of circles is corrected so that the draw-commands vradiusdim and vdiameterdim are able to select the edges for visualization of the dimensions.
(0020616)
vro (developer)
2012-05-31 09:43

The bug depends on 23159. Just it is fixed, testing will be possible.
(0024207)
vro (developer)
2013-04-18 15:10

More than an year has passed since this bug was registered. Even more, the fix was put immediately the same date, but... the fix is not integrated into Open CASCADE yet. What do we wait, the end of the world?
(0024208)
abv (manager)
2013-04-18 15:39

Vlad, the last report by apn (0022974:0020535) indicate that the reported problem has not been fixed ("commands vradiusdim, vdiameterdim and etc still crash"), and you indicated in 0022974:0020616 that this fix requires 0023159. The latter has not been fixed yet due to low priority. If this issue is important for you, you are welcome to provide the fix.
(0027853)
aba (developer)
2014-02-12 11:53

Dear Bugmaster,

This issue was fixed in the scope of the issue 0024412.

Please test it.
(0028055)
bugmaster (administrator)
2014-02-27 18:05

The issue was fixed in the scope of the issue 0024412.

- Issue History
Date Modified Username Field Change
2012-02-02 13:58 vro New Issue
2012-02-02 13:58 vro Assigned To => vro
2012-02-02 15:15 vro Note Added: 0019359
2012-02-02 15:15 vro Assigned To vro => kgv
2012-02-02 15:15 vro Status new => resolved
2012-02-02 16:47 kgv Note Added: 0019363
2012-02-02 16:47 kgv Assigned To kgv => bugmaster
2012-02-02 16:47 kgv Status resolved => reviewed
2012-02-07 13:28 apn Note Added: 0019432
2012-02-07 15:29 apn Note Edited: 0019432 View Revisions
2012-02-07 15:30 apn Test case number => No opportunity to create test case
2012-02-07 15:30 apn Status reviewed => tested
2012-02-10 17:34 bugmaster Note Added: 0019519
2012-02-22 11:31 bugmaster Note Added: 0019716
2012-02-22 11:31 bugmaster Assigned To bugmaster => vro
2012-02-22 11:31 bugmaster Status tested => feedback
2012-02-22 11:35 vro Note Added: 0019718
2012-02-22 11:35 vro Status feedback => assigned
2012-02-22 16:13 san Note Added: 0019737
2012-03-12 07:40 abv Note Added: 0019922
2012-03-12 07:40 abv Status assigned => feedback
2012-03-14 10:21 vro Note Added: 0019963
2012-03-14 10:21 vro Status feedback => assigned
2012-03-14 10:21 vro Assigned To vro => bugmaster
2012-03-14 10:21 vro Status assigned => resolved
2012-05-12 17:17 mkv Assigned To bugmaster => abv
2012-05-12 17:29 abv Note Added: 0020522
2012-05-12 17:29 abv Assigned To abv => vro
2012-05-12 17:29 abv Status resolved => assigned
2012-05-14 12:13 vro Note Added: 0020525
2012-05-14 12:14 vro Assigned To vro =>
2012-05-14 12:14 vro Assigned To => abv
2012-05-14 12:15 vro Note Added: 0020526
2012-05-14 15:10 vro Status assigned => resolved
2012-05-14 15:14 abv Note Added: 0020528
2012-05-14 15:14 abv Assigned To abv => vro
2012-05-14 15:14 abv Status resolved => reviewed
2012-05-14 16:58 apn Assigned To vro => apn
2012-05-15 12:06 apn Note Added: 0020535
2012-05-15 12:07 apn Assigned To apn => vro
2012-05-15 12:07 apn Status reviewed => assigned
2012-05-16 10:11 vro Note Added: 0020538
2012-05-16 16:26 vro Relationship added parent of 0023159
2012-05-31 09:42 abv Target Version 6.5.3 => 6.5.4
2012-05-31 09:43 vro Note Added: 0020616
2012-09-03 09:18 vro Assigned To vro => san
2012-10-02 14:56 bugmaster Project Internal => Open CASCADE
2012-10-21 11:41 abv Target Version 6.5.4 => 6.6.0
2013-02-26 18:43 san Target Version 6.6.0 => 6.7.0
2013-04-18 15:10 vro Note Added: 0024207
2013-04-18 15:39 abv Note Added: 0024208
2013-11-28 16:16 san Relationship added related to 0024412
2013-11-28 16:17 san Target Version 6.7.0 => 6.7.1
2013-11-29 18:41 san Assigned To san => aba
2013-11-29 18:42 san Relationship added related to 0024133
2014-02-12 11:50 aba Steps to Reproduce Updated View Revisions
2014-02-12 11:53 aba Note Added: 0027853
2014-02-12 11:53 aba Assigned To aba => bugmaster
2014-02-12 11:53 aba Status assigned => feedback
2014-02-27 18:05 bugmaster Assigned To bugmaster => aba
2014-02-27 18:05 bugmaster Status feedback => tested
2014-02-27 18:05 bugmaster Note Added: 0028055
2014-02-27 18:05 bugmaster Status tested => verified
2014-02-27 18:05 bugmaster Resolution open => fixed
2014-05-05 13:34 aiv Status verified => closed
2014-05-05 13:38 aiv Fixed in Version => 6.7.1


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker