MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022886Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2012-01-09 20:082019-09-29 12:35
Reporteryfr 
Assigned Tobugmaster 
PrioritynormalSeverityblock 
StatusverifiedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.1 
Target Version[OCCT] 7.4.0Fixed in Version 
Summary0022886: Modeling Algorithms - Bug in boolean
Descriptionrestore solid1
restore solid2
bcommon r solid1 solid2
=> Result is wrong

note: common r solid1 solid2 works
Steps To Reproducetest bugs modalg_7 bug22886
TagsNo tags attached.
Test case numberbugs modalg_7 bug22886
Attached Files? file icon solid2 (3,524 bytes) 2012-01-09 20:08
? file icon solid1 (777,364 bytes) 2012-01-09 20:10

- Relationships

-  Notes
(0068254)
git (administrator)
2017-07-13 13:28

Branch CR22886 has been created by mkv.

SHA-1: 01c48ac84c5e346418162f7ba8e395f99b49f00f


Detailed log of new commits:

Author: mkv
Date: Thu Jul 13 13:28:20 2017 +0300

    Test for 0022886: Bug in boolean
(0068255)
mkv (tester)
2017-07-13 13:41

Dear BugMaster,
Problem is reproduced on the current master.
Please integrate branch CR22886 into the occt git-repository master.
After integration issue status should be changed to assigned. Responsible person is MSV.
(0079341)
emv (developer)
2018-09-24 09:10

The current difference between results is that one contains one degenerated edge more (produced by the modern algorithm) than the other.
This degenerated edge passed from the original face - not artificially created. Probably it should be removed from the face, because it has a very small range - [0.641352744887779, 0.641352751431434]. So, lets keep the issue open until the deeper analysis.
(0087344)
msv (developer)
2019-09-20 09:36

The current master produces the valid result, though the number of shapes is different from obsolete algorithm of common.

So, I propose to update test case and get rid of using common command in it.
(0087348)
git (administrator)
2019-09-20 10:11

Branch CR22886 has been updated forcibly by emv.

SHA-1: aeb0f26099bef807b91a256a95e3e535584c30ce
(0087351)
emv (developer)
2019-09-20 11:32

Dear Mikhail, could you please review the branch CR22886?
Test results:
http://occt-tests/CR22886-master-emv-OCCT/Windows-64-VC14/bugs/modalg_7/bug22886.html [^]
http://occt-tests/CR22886-master-emv-OCCT/Debian80-64/bugs/modalg_7/bug22886.html [^]
(0087366)
msv (developer)
2019-09-20 14:26

Reviewed.
(0087598)
git (administrator)
2019-09-29 12:35

Branch CR22886 has been deleted by inv.

SHA-1: aeb0f26099bef807b91a256a95e3e535584c30ce

- Related Changesets
occt: master 1f99e088
Timestamp: 2019-09-20 07:05:49
Author: emv
Committer: bugmaster
Details ] Diff ]
0022886: Bug in Boolean

Updating test case as the problem is not reproduced anymore.
mod - tests/bugs/modalg_7/bug22886 Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-01-09 20:08 yfr New Issue
2012-01-09 20:08 yfr Assigned To => jgv
2012-01-09 20:08 yfr File Added: solid2
2012-01-09 20:10 yfr File Added: solid1
2017-07-13 13:28 git Note Added: 0068254
2017-07-13 13:29 mkv Test case number => bugs modalg_7 bug22886
2017-07-13 13:41 mkv Note Added: 0068255
2017-07-13 13:41 mkv Assigned To jgv => bugmaster
2017-07-13 13:41 mkv Status new => feedback
2017-07-13 13:42 mkv Status feedback => tested
2017-07-14 12:30 bugmaster Assigned To bugmaster => msv
2017-07-14 12:30 bugmaster Status tested => assigned
2018-09-24 09:10 emv Note Added: 0079341
2019-09-20 09:34 msv Assigned To msv => emv
2019-09-20 09:34 msv Target Version => 7.5.0*
2019-09-20 09:36 msv Note Added: 0087344
2019-09-20 10:11 git Note Added: 0087348
2019-09-20 11:32 emv Note Added: 0087351
2019-09-20 11:32 emv Assigned To emv => msv
2019-09-20 11:32 emv Status assigned => resolved
2019-09-20 11:32 emv Steps to Reproduce Updated View Revisions
2019-09-20 12:24 kgv Summary Bug in boolean => Modeling Algorithms - Bug in boolean
2019-09-20 14:26 msv Note Added: 0087366
2019-09-20 14:26 msv Assigned To msv => bugmaster
2019-09-20 14:26 msv Status resolved => reviewed
2019-09-20 14:26 msv Target Version 7.5.0* => 7.4.0
2019-09-21 18:13 bugmaster Changeset attached => occt master 1f99e088
2019-09-21 18:13 bugmaster Status reviewed => verified
2019-09-21 18:13 bugmaster Resolution open => fixed
2019-09-29 12:35 git Note Added: 0087598


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker