MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022787Open CASCADE[OCCT] OCCT:Visualizationpublic2011-10-31 17:592012-03-12 10:51
Reportersan 
Assigned Tosan 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.2 
Target VersionFixed in Version[OCCT] 6.5.3 
Summary0022787: Clipping planes should not clip "non-clippable" scene parts
DescriptionThis problem has been discovered by SZV.

When gradient or textured background is used in a 3D view, the active clipping planes (V3d_Plane) sometimes seem to clip the background rectangle. This should be investigated more carefully, and most likely OpenGL clipping planes should be disabled temporarily in TelClearBackground() function in OpenGl_view.cxx.

Over-/under-layers should be non-clippable, too. For this, most likely OpenGl_togl_begin_layer_mode.cxx should be amended by the code disabling OpenGL clipping planes temporarily.
TagsNo tags attached.
Test case number
Attached Files

- Relationships
related to 0022819closedbugmaster Open CASCADE Redesign of OpenGl driver 

-  Notes
(0019763)
san (developer)
2012-02-23 19:02

Resolved by patch for #22906
(0019764)
san (developer)
2012-02-23 19:02

Dear bugmaster,

Please close this issue as duplicate of #22906.
(0019928)
bugmaster (administrator)
2012-03-12 10:36

Issue is closed as duplicate of 0022906

- Issue History
Date Modified Username Field Change
2011-10-31 17:59 san New Issue
2011-10-31 17:59 san Assigned To => san
2012-02-23 18:56 san Relationship added related to 0022819
2012-02-23 18:57 san Note Added: 0019762
2012-02-23 18:59 san Relationship added duplicate of 0022906
2012-02-23 18:59 san Note Deleted: 0019762
2012-02-23 19:02 san Note Added: 0019763
2012-02-23 19:02 san Status new => resolved
2012-02-23 19:02 san Note Added: 0019764
2012-02-23 19:02 san Assigned To san => bugmaster
2012-02-23 19:02 san Status resolved => reviewed
2012-03-12 10:36 bugmaster Note Added: 0019928
2012-03-12 10:36 bugmaster Status reviewed => closed
2012-03-12 10:36 bugmaster Assigned To bugmaster => san
2012-03-12 10:36 bugmaster Resolution open => fixed
2012-03-12 10:51 bugmaster Fixed in Version => 6.5.3


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker