MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022727Community[OCCT] OCCT:Modeling Algorithmspublic2011-09-20 12:002012-03-29 17:26
Reporterszy 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.1 
Target Version[OCCT] 6.5.3Fixed in Version[OCCT] 6.5.3 
Summary0022727: Fillet not produces a result
DescriptionPost from the Forum - http://www.opencascade.org/org/forum/thread_21841/. [^]
"1. I have used fillet making function "BRepFilletAPI_MakeFillet" for some time now and it seems that there are many instances it fails to create a fillet. Can anybody comment on the reliability of this function?
For example, I have attached a Brep file here and am unable to put a fillet in the common edge. Is there something wrong with my shape or is it a shortcoming of the makefillet function that I can't make a fillet there? How can I fix this?"

 ==> Bounding box is : DX=0.0545873 mm, DY=0.05459825 mm, DZ=0.0299319 mm.

"2. The model dimensions are actually in meters. It has not been converted to proper units when writing out the brep file. Basically DX would be 54.5873 mm actually. I have tried fillets with radius of 1 mm to 5 mm without success."

Shape is attached - toFillet.brep.
If try to scale the shape relative to center of gravity (x1000) =>
algorithm fails.
Steps To Reproducerestore toFillet.brep t
checkshape t

sprops t
tscale t 0.0507219 -0.0399294 -0.00324254 1000

explode t e
donly t t_3
fit

blend res t 2. t_3
tscale res 0.0507219 -0.0399294 -0.00324254 0.001
Additional information
and documentation updates
Modified entities:

ChFi3d_Builder_6.cxx

modified methods:

Standard_Boolean ChFi3d_Builder::CompleteData
(Handle(ChFiDS_SurfData)& Data,
 Blend_Function& Func,
 Handle(BRepBlend_Line)& lin,
 const Handle(Adaptor3d_HSurface)& S1,
 const Handle(Adaptor3d_HSurface)& S2,
 const TopAbs_Orientation Or1,
 const Standard_Boolean Gd1,
 const Standard_Boolean Gd2,
 const Standard_Boolean Gf1,
 const Standard_Boolean Gf2,
 const Standard_Boolean Reversed)

Now construction of BRepBlend_AppSurface is called in this method with two additional arguments: Degmax and Segmax.
TagsNo tags attached.
Test case numberchl 934 D5
Attached Files? file icon toFillet.brep (816,718 bytes) 2011-09-20 12:00
gz file icon chl_934_D5.tar.gz (654 bytes) 2011-10-17 20:03

- Relationships

-  Notes
(0018341)
jgv (developer)
2011-10-10 15:02

SVN branch http://svn/svn/occt/branches/22727 [^] is ready for reviewing
(0018362)
ifv (developer)
2011-10-14 14:34

Seems to be OK
(0018368)
mkv (tester)
2011-10-17 20:04
edited on: 2011-11-22 11:42

Dear BugMaster,
Workbench KAS:dev:mkv-22727-occt was created from SVN branch http://svn/svn/occt/branches/22727 [^]
(and mkv-22727-products from trunk) and compiled on Linux platform.

Test case for this bug is chl/934/D5. It is OK.

There are not regressions in mkv-22727-products regarding to KAS:dev:products-652-opt.

See results in /QADisk/occttests/results/KAS/dev/mkv-22727-products_17102011/lin
See reference results in /QADisk/occttests/results/KAS/dev/products-652-opt_23092011/lin
See test cases in /QADisk/occttests/tests/ED
N.B. In order to launch testing case you can make use the following instructions
http://doc/doku.php?id=occt:certification [^]

(0018399)
bugmaster (administrator)
2011-10-21 21:41
edited on: 2011-10-21 21:42

Integrated into trunk of occt repository:

Date: 2011-10-21 21:40:30 +0400 (Fri, 21 Oct 2011)
New Revision: 9234

Modified:
   trunk/src/ChFi3d/ChFi3d_Builder_6.cxx
Log:


- Related Changesets
occt: master 822ffdff
Timestamp: 2011-10-21 17:40:30
Author: jgv
Committer: bugmaster
Details ] Diff ]
0022727: Fillet not produces a result
mod - src/ChFi3d/ChFi3d_Builder_6.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2011-09-20 12:00 szy New Issue
2011-09-20 12:00 szy Assigned To => jgv
2011-09-20 12:00 szy File Added: toFillet.brep
2011-09-21 14:07 szy Target Version => 6.5.3
2011-09-22 16:51 szy Status new => assigned
2011-10-10 14:58 jgv Steps to Reproduce Updated View Revisions
2011-10-10 14:58 jgv Additional Information Updated View Revisions
2011-10-10 15:02 jgv Note Added: 0018341
2011-10-10 15:02 jgv Status assigned => resolved
2011-10-11 11:23 jgv Assigned To jgv => ifv
2011-10-14 14:34 ifv Note Added: 0018362
2011-10-14 14:34 ifv Status resolved => reviewed
2011-10-14 14:35 ifv Assigned To ifv => bugmaster
2011-10-17 20:03 mkv File Added: chl_934_D5.tar.gz
2011-10-17 20:04 mkv Note Added: 0018368
2011-10-17 20:05 mkv Test case number => chl 934 D5
2011-10-17 20:05 mkv Status reviewed => tested
2011-10-21 21:41 bugmaster Note Added: 0018399
2011-10-21 21:41 bugmaster Status tested => verified
2011-10-21 21:41 bugmaster Resolution open => fixed
2011-10-21 21:41 bugmaster Assigned To bugmaster => jgv
2011-10-21 21:42 bugmaster Note Edited: 0018399 View Revisions
2011-11-22 11:42 szy Note Edited: 0018368 View Revisions
2012-03-29 17:26 bugmaster Changeset attached => occt master 822ffdff


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker